Bug 465391 - pxdvi cannot display Japanese fonts.
pxdvi cannot display Japanese fonts.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xdvik (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 23:18 EDT by Takanori MATSUURA
Modified: 2008-10-20 16:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 16:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takanori MATSUURA 2008-10-02 23:18:08 EDT
This bug has two problem.

1. pxdvi reads not /usr/share/texmf/pxdvi/xdvi.cfg but /usr/share/texmf/xdvi/xdvi.cfg.

If I set the following value in /usr/share/texmf/web2c/texmf.cfg, pxdvi doesn't read cfg file from /usr/share/texmf/pxdvi.

XDVIINPUTS = .;$TEXMF/{xdvi,dvips,pdvips}//
XDVIINPUTS.pxdvi = .;$TEXMF/{pxdvi,xdvi,pdvips,dvips}//

But if I set the following value in /usr/share/texmf/web2c/texmf.cfg, pxdvi reads cfg file from /usr/share/texmf/pxdvi.
XDVIINPUTS = .;$TEXMF/{pxdvi,xdvi,pdvips,dvips}//

The second one solves this bug. But I don't like it because it also affects to original xdvips and may cause error in xdvi.

How to reproduce:
pxdvi -debug open test.dvi
and you can see
kdebug:fopen(/usr/share/texmf/xdvi/xdvi.cfg, r) => 0x2650030

2. xdvi-ptex.map is placed in wrong directory.
This should be placed like
/usr/share/texmf/fonts/map/pxdvi/xdvi-ptex.map
or we should fill the full path of this file like
ptexmap /usr/share/texmf/pxdvi/xdvi-ptex.map
in /usr/share/texmf/pxdvi/xdvi.cfg.
Comment 1 Jonathan Underwood 2008-10-06 08:51:47 EDT
OK, thanks for the report, I can see the problems, and will work on a fix.

Longer term though, maintaining the japanese patch and building a separate binary for japanese support is too much of a departure from upstream, so if you could petition the upstream japanese patch people to work on merging japanese support into upstream xdvik, that would be very much appreciated.
Comment 2 Takanori MATSUURA 2008-10-06 09:27:43 EDT
(In reply to comment #1)
Thank you.

Unfortunately, I'm not a maintainer of the Japanese patch. The developers have a plan to merge the Japanese patch to the upstream but it's not clear when it is.
Comment 3 Jonathan Underwood 2008-10-11 20:44:01 EDT
Ok, have pushed a new build which I hope will fix these issues - please test:

http://koji.fedoraproject.org/koji/taskinfo?taskID=874873
Comment 4 Jonathan Underwood 2008-10-11 21:01:56 EDT
Oops, that build failed. Should be corrected here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=874887
Comment 5 Fedora Update System 2008-10-12 07:56:25 EDT
xdvik-22.84.14-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xdvik-22.84.14-3.fc9
Comment 6 Takanori MATSUURA 2008-10-15 02:51:59 EDT
(In reply to comment #5)
> xdvik-22.84.14-3.fc9
works fine!

Thank you for your good work.
Comment 7 Fedora Update System 2008-10-15 22:01:21 EDT
xdvik-22.84.14-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xdvik'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8784
Comment 8 Fedora Update System 2008-10-20 16:26:03 EDT
xdvik-22.84.14-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.