Bug 465403 - alts_toggle is a bad default for F9/F10
alts_toggle is a bad default for F9/F10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-03 01:50 EDT by Peter Hutterer
Modified: 2008-10-14 19:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 14:48:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 4927 None None None Never

  None (edit)
Description Peter Hutterer 2008-10-03 01:50:58 EDT
Bug 443763 (CLOSED, UPSTREAM) details a keyboard layout change problem:

gnome-keyboard-properties uses "Both Alt keys together change layout" as default if two or more layouts are selected. Recent xkeyboard-config versions (including the ones in F9 and F10) cannot trigger this due to freedesktop.org Bug 4927.

The fix for FDO bug 4927 is likely to drop the xkm format which will not happen until at least xserver-1.6.

Meanwhile, a different default in gnome-keyboard-properties to switch between layouts would be good as a workaround. Note that this bug also affects the "both shift keys ..." and "both ctrl keys..." options.
Comment 1 Matthias Clasen 2008-10-08 14:48:55 EDT
I changed it to shift-capslock in 2.24.0.1-5.fc10
Comment 2 Mads Kiilerich 2008-10-14 19:07:06 EDT
It works fine, thanks.

Having used it and thought a bit about it: 

Based on experience from old type writers I would assume that shift-capslock had something to do with modifying capslock to make it more or less persistent and annoying.

The Alt keys are usually used for entering symbols from other character sets; a kind of temporary alternative keyboard layout.

So IMHO alt-capslock would make a lot of sense. 

It might however not be worth the effort to change it again, but I would just mention the idea ...

Note You need to log in before you can comment on or make changes to this bug.