Bug 465405 - SD on Asus EEE 701
SD on Asus EEE 701
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-10-03 02:04 EDT by Luke Sheldrick
Modified: 2009-05-20 16:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 16:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -vnn (8.47 KB, text/plain)
2008-10-10 18:19 EDT, Luke Sheldrick
no flags Details
lsusb -v (20.93 KB, text/plain)
2008-10-15 18:47 EDT, Luke Sheldrick
no flags Details
output from lspci, lsusb, and dmidecode (49.21 KB, text/plain)
2008-12-29 21:36 EST, Donald Harper
no flags Details
Please look at this SD Card error log from Asus eee 701 (2.09 KB, text/plain)
2008-12-31 05:30 EST, Valent Turkovic
no flags Details
output of lspci -vnn on asus eee 701 (6.11 KB, text/plain)
2008-12-31 05:34 EST, Valent Turkovic
no flags Details
output of lsusb -v on asus eee 701 (38.82 KB, text/plain)
2008-12-31 05:35 EST, Valent Turkovic
no flags Details
lsusb -v on EEE PC701 (12.72 KB, text/x-log)
2009-01-21 07:19 EST, Jaroslav Reznik
no flags Details

  None (edit)
Description Luke Sheldrick 2008-10-03 02:04:59 EDT
Description of problem:

Have just installed Rawhide 9.91 on my Asus eee 901. However, it would seem still it cannot read the 16GB Fukifilm Class 4 16GB SDHC card. The kernel detects it being inserted:

Oct  3 06:48:33 eee01 kernel: sd 2:0:0:0: [sdb] 31719424 512-byte hardware sectors (16240 MB)
Oct  3 06:48:33 eee01 kernel: sd 2:0:0:0: [sdb] Write Protect is off
Oct  3 06:48:33 eee01 kernel: sd 2:0:0:0: [sdb] Assuming drive cache: write through
Oct  3 06:48:33 eee01 kernel: sd 2:0:0:0: [sdb] 31719424 512-byte hardware sectors (16240 MB)
Oct  3 06:48:33 eee01 kernel: sd 2:0:0:0: [sdb] Write Protect is off
Oct  3 06:48:33 eee01 kernel: sd 2:0:0:0: [sdb] Assuming drive cache: write through
Oct  3 06:48:33 eee01 kernel: sdb: sdb1

However trying to mount, access, or fdisk it freezes the eee, until I manually remove the card. Naturally the kernal moans:

Oct  3 06:51:38 eee01 kernel: sd 2:0:0:0: [sdb] Device not ready: Sense Key : Not Ready [current] 
Oct  3 06:51:38 eee01 kernel: sd 2:0:0:0: [sdb] Device not ready: Add. Sense: Medium not present
Oct  3 06:51:38 eee01 kernel: end_request: I/O error, dev sdb, sector 31719408
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 3964926
Oct  3 06:51:38 eee01 kernel: sd 2:0:0:0: [sdb] Device not ready: Sense Key : Not Ready [current] 
Oct  3 06:51:38 eee01 kernel: sd 2:0:0:0: [sdb] Device not ready: Add. Sense: Medium not present
Oct  3 06:51:38 eee01 kernel: end_request: I/O error, dev sdb, sector 31719408
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 3964926
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 0
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 0
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 0
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 3964927
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 3964927
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 3964927
Oct  3 06:51:38 eee01 kernel: Buffer I/O error on device sdb, logical block 3964927


If I use the card, in the native Asus OS, all works fine, and if I use the card in a usb reader, in both os's, this is also fine.
Comment 1 Luke Sheldrick 2008-10-05 10:52:42 EDT
Originally opened to report SDHC errors, but it would appear, it's not just SDHC cards, exactlythe same problem is present for all SD cards. This is both in the OS once installed, and also halts the install process. The same is the same in FC9, so not attributed to just rawhide.
Comment 2 Chuck Ebbert 2008-10-10 00:37:33 EDT
What SD controller is that? Can you attach the output of 'lspci -vnn' command?
Comment 3 Luke Sheldrick 2008-10-10 18:19:32 EDT
Created attachment 320069 [details]
lspci -vnn

Hi Chuck,

Please see output of lspci -vnn attached
Comment 4 Chuck Ebbert 2008-10-14 13:38:08 EDT
Oh, it's a USB reader built into the machine. What does 'lsusb' print?
Comment 5 Luke Sheldrick 2008-10-15 18:47:08 EDT
Created attachment 320498 [details]
lsusb -v
Comment 6 Peter Robinson 2008-10-15 19:33:51 EDT
Searching against the USB vendor/product ID shows up some similar issues that people are having. It seems it worked <=2.6.24 but not stable in later kernels.

A few examples.
http://lkml.org/lkml/2008/3/30/11
http://forum.eeeuser.com/viewtopic.php?pid=255437
Comment 7 Darren Fulton 2008-10-31 15:47:53 EDT
This may be the same bug:
https://bugzilla.redhat.com/show_bug.cgi?id=427650
Comment 8 Darren Fulton 2008-10-31 18:31:59 EDT
By the way, I'm pretty sure that this is the on-board (but USB connected) card reader's info from /proc/bus/usb/devices as seen using Fedora 10 beta (2.6.27.4-58.fc10.i686 #1 SMP Mon Oct 27 18:21:44 EDT 2008 i686 i686 i386):

T:  Bus=03 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1     
P:  Vendor=0951 ProdID=1606 Rev= 1.00                            
S:  Manufacturer=ENE                                             
S:  Product=UB6225                                               
S:  SerialNumber=146030377350                                    
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=498mA                           
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms                              
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
Comment 9 Luke Sheldrick 2008-11-10 16:51:21 EST
Also still now working on the latest 'Preview' version of rawhide/fc10, same errors apparent.
Comment 10 Luke Sheldrick 2008-11-10 17:08:10 EST
Sorry that was supposed to say "still _not_ working..."
Comment 11 Darren Fulton 2008-11-10 18:14:01 EST
Here is a follow up.  I just wanted to make sure something was clear.  The onboard (USB connected) card reader is the thing that isn't working with Fedora 9 and Fedora 10 beta.  

I have an externally connected USB SD/SDHC card reader that I bought for my EEEPC to use until this bug is fixed and it _does_work_ without issues.  The problem is not the memory card and given that the onboard card reader worked properly under Fedora 8 [early kernels at least], isn't the card reader hardware.  Please consider this a Fedora bug and work toward a resolution.  I'm not smart enough to know whether it is a kernel bug or not, but I do know that it doesn't work under Fedora 9 and Fedora 10 and would appreciate it greatly if you Red Hat folks would help fix it.  Thank you.  Again, I'm available to help troubleshoot and test.
Comment 12 Peter Robinson 2008-11-17 07:09:01 EST
It looks like the patch in this message with patch on the usb-storage list fixes the problem. Something to do with reading the last sector on the disk as part of a multisector read. It didn't mention whether it was planned to get this patch upstream but as Hans is now a Redhat employee he might be able to answer that directly.

https://lists.one-eyed-alien.net/pipermail/usb-storage/2008-June/003767.html
Comment 13 Peter Robinson 2008-11-17 08:58:55 EST
Digging deeper it looks like the final patch due to go in for this is this one here https://kerneltrap.org/mailarchive/linux-scsi/2008/9/21/3359904
Comment 14 Bug Zapper 2008-11-25 22:29:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Valent Turkovic 2008-12-18 17:50:29 EST
I have one issue that might be the same bug as this sd card reader bug.

I have tried to permamently mount 8GB ext3 formated SD card and have setup /etc/fstab acordingly and when I try to mount it via "mount /storage" it mounts with no problem but during the restart something happens to SD card because on boot it stops boot process and gives me the option to enter root password for troubleshooting or to press CRTL+D for reboot.

I tried to mount /dev/sdb1 (SD card) but I got error and then I ran fsck and got errors.

Something happens during shutdown or unmounting that corrupts SD card.

Can I give you more feedback? When will this be fixed for Fedora?
Comment 16 Stephen Haffly 2008-12-20 09:08:37 EST
I can confirm that this issue also exists with the Eee PC 900 series.  I have found a thread that seems to indicate that the SDHC card is not being unmounted cleanly on shutdown

http://forum.eeeuser.com/viewtopic.php?id=10607

Although the topic addresses Fedora 8, the problem seems to be the same one I am encountering on Fedora 10 which is installed to a 16 Gb SDHC card.  If I use the onboard card reader slot, I can reliably reproduce the problem where / is left inconsistent and has to be checked (I have used gparted's check function on my desktop F10 system to do this) before it will mount at boot time.

I suspect that a modification to F10's halt script to ensure that all writes are completed and the SDHC card in unmounted cleanly as per the message thread I cited would solve this issue.  I am not sure where in the halt script to place the modifications suggested, so I have not been able to confirm that this is indeed the fix needed.
Comment 17 Valent Turkovic 2008-12-29 16:35:29 EST
This bug makes Fedora 10 unusable on Asus eee 701 because onboard 4GB drive is too small for default set of apps and after updates drive keeps shrinking to 0MB free :(((

Please take this into consideration.

If you need some more feedback please let us know or if there is some other way we users can help this bug gets fixed.
Comment 18 Darren Fulton 2008-12-29 16:42:36 EST
Valent's comments justified in that the distribution size problem is exacerbated by not being able to use SDHC cards as add-on storage; using the on-board card reader for user files and such.  Thank you.  Please take this issue seriously and please continue working for a resolution.  Thank you.
Comment 19 Donald Harper 2008-12-29 21:33:38 EST
What series of the 701 do you have?  Mine works just fine with F10.  

I will attach the output of  lspci -vnn && lsusb -v for my machine.
Comment 20 Donald Harper 2008-12-29 21:36:39 EST
Created attachment 327946 [details]
output from lspci, lsusb, and dmidecode

added dmidecode for grins and giggles.
Comment 21 Valent Turkovic 2008-12-30 12:24:15 EST
Regarding comment #17: what do you mean exactly by "Mine works just fine with F10."
Comment 22 Donald Harper 2008-12-30 13:25:31 EST
(In reply to comment #21)
> Regarding comment #17: what do you mean exactly by "Mine works just fine with
> F10."

I have full use of all of the native hardware on the 701, including the SD card reader:

duck@little:~> df
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      2.5G  1.5G  964M  62% /
/dev/sda1             190M   28M  153M  16% /boot
tmpfs                1009M     0 1009M   0% /dev/shm
/dev/sdb2              15G  1.4G   13G  10% /home

/dev/sdb is the SD card (16G)

Been working since 9.92 or so, and I have updated to the current, stable release.

Let me know if you need anything else.
Comment 23 Valent Turkovic 2008-12-31 05:15:56 EST
For me SD card (8BG) fails during anaconda install if I try to install Fedora 10 on SD Card. It also fails if I install Fedora 10 only on SSD drive and I try to use SD Card as permenent mount point - /storage through fstab for example.

I reformated SD card and checked it for error and it doesn't have any issues that I can see.

If I use SD Card as "Usb stick" ie. just pop it in and remove it while F10 is running then there is no problem and it works. It seams that something breaks SD Card during shutodown.

On boot-up Fedora wont mount before fsck fixes errors on it! Errors occur only if I leave SD Card mounted through fstab and poweroff eee.
Comment 24 Valent Turkovic 2008-12-31 05:30:50 EST
Created attachment 328001 [details]
Please look at this SD Card error log from Asus eee 701

I insert SD Card in after leaving it mounted while shutting down and look at the errors that cretes on it.
Comment 25 Valent Turkovic 2008-12-31 05:34:53 EST
Created attachment 328002 [details]
output of lspci -vnn on asus eee 701
Comment 26 Valent Turkovic 2008-12-31 05:35:34 EST
Created attachment 328003 [details]
output of lsusb -v on asus eee 701
Comment 27 Darren Fulton 2008-12-31 13:54:59 EST
(In reply to comment #24)


I'm not sure that this is the same thing, but you may be interested in this thread:

http://forum.eeeuser.com/viewtopic.php?id=16619&p=1
Comment 28 Valent Turkovic 2008-12-31 14:44:00 EST
Regarding comment #27:
I don't see the relevance in this forum thread. That thread is for Xandros running on eee and not for Fedora. Darren can you please clarify what is relevant in that forum thread with this issue.
Comment 29 Darren Fulton 2008-12-31 15:50:35 EST
That thread simply describes similar problems that people are having with SD cards.  I don't think anyone is assuming that this is a Fedora only problem.  It is probably a kernel or udev problem.  The links that the poster provided:
http://forum.eeeuser.com/viewtopic.php?id=16526
http://forum.eeeuser.com/viewtopic.php?id=13407
http://forum.eeeuser.com/viewtopic.php?id=10607
http://forum.eeeuser.com/viewtopic.php?id=9304
http://forum.eeeuser.com/viewtopic.php?id=9185
http://forum.eeeuser.com/viewtopic.php?id=15036

describe various problems that are similar to what we are having.  These issues could maybe have the same root cause.

I think there may be a general problem with how Linux distributions are dealing with SD cards during Suspend/Resume/Shutdown.  I have a card that has been plugged into my Acer Aspire One that I cannot read from any longer due to corruption. If I reformat it, it will be corrupt within weeks if I leave it in all the time.
Comment 30 Valent Turkovic 2008-12-31 16:19:57 EST
I had the same laptop with xandors and fedora 9 installed and same SD card any in each case SD card worked without problems. 

Problems started when I installed Fedora 10 on eee.

That isolates the issue to only Fedora 10.
Comment 31 Peter Robinson 2008-12-31 22:28:50 EST
Its not just Fedora 10. It also happens on generic kernels. I think Ubuntu patches the kernel to fix the issue. See the threads mentioned in comments 12 and 13. There have been a number of patches floating around to fix the issue but I'm yet to see a generic fix make the mainline kernel.
Comment 32 Jaroslav Reznik 2009-01-21 07:18:16 EST
What's the current status of this bug? My EEE PC 701 is affected too.
Comment 33 Jaroslav Reznik 2009-01-21 07:19:20 EST
Created attachment 329594 [details]
lsusb -v on EEE PC701
Comment 34 Peter Robinson 2009-01-29 02:40:23 EST
It looks like 2.6.27.13 might well finally have a fix for this issue
http://lwn.net/Articles/316624/

Alan Stern (2):
      usb-storage: add last-sector hacks
      usb-storage: set CAPACITY_HEURISTICS flag for bad vendors

Alan was the person I mentioned further up in the bug that was working on a fix.
Comment 35 Jaroslav Reznik 2009-02-10 03:57:02 EST
(In reply to comment #34)
> It looks like 2.6.27.13 might well finally have a fix for this issue
> http://lwn.net/Articles/316624/
> 
> Alan Stern (2):
>       usb-storage: add last-sector hacks
>       usb-storage: set CAPACITY_HEURISTICS flag for bad vendors
> 
> Alan was the person I mentioned further up in the bug that was working on a
> fix.

Finally it's working with latest kernel from Koji!

2.6.27.15-170.2.19.fc10.i686
Comment 36 Peter Robinson 2009-02-10 04:20:52 EST
I think it was fixed in 2.6.27.14 but I've been waiting for it to be pushed to updates-testing.
Comment 37 Valent Turkovic 2009-02-13 15:09:25 EST
I'm running 2.6.28-4.fc10 kernel and still having same issues...
Comment 38 Peter Robinson 2009-02-13 15:19:52 EST
(In reply to comment #37)
> I'm running 2.6.28-4.fc10 kernel and still having same issues...

The fix was backported from 2.6.29 to .27.x and .28.y. If your running an vanilla 2.6.28 it won't have the fix. You'll need to make sure your running a late 2.6.28.y or try the latest .27 release from koji. Fedora is skipping the 2.6.28 release due to stability issues with it.
Comment 39 Valent Turkovic 2009-02-14 06:27:33 EST
I just installed 2.6.27.15-170.2.24.fc10.i686 kernel and so far so good.

Is there a way I can respin Fedora ISO and force this latest 2.6.27.15-170.2.24.fc10.i686 kernel on it? I know how to respin Fedora but I don't know how to force this kernel to be installed. I would like to respin Fedora 10 so that I can install it on my eee's external SD card.

Cheers.
Comment 40 Valent Turkovic 2009-02-14 10:24:02 EST
I'm still having issues with SD card reader. After clean reboot I still get corrupted SD card!

Kernel is now 2.6.27.15-170.2.24.fc10.i686

]# fsck /dev/sdb1 
fsck 1.41.3 (12-Oct-2008)
e2fsck 1.41.3 (12-Oct-2008)
fsck.ext3: Group descriptors look bad... trying backup blocks...
Resize inode not valid.  Recreate<y>? yes

/dev/sdb1 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong for group #0 (65535, counted=0).
Comment 41 Luke Sheldrick 2009-02-15 12:47:22 EST
Have just tried with my eee701 again, clean installing using the livecd media and updating with the updates-testing repo branch.

Using the 2.6.27.15-170.2.24.fc10.i686 kernel all seems to be ok, once you've updated.

Feb 15 17:36:34 localhost kernel: sd 3:0:0:0: [sdc] 31719424 512-byte hardware sectors (16240 MB)
Feb 15 17:36:34 localhost kernel: sd 3:0:0:0: [sdc] Write Protect is off
Feb 15 17:36:34 localhost kernel: sd 3:0:0:0: [sdc] Assuming drive cache: write through
Feb 15 17:36:34 localhost kernel: sd 3:0:0:0: [sdc] 31719424 512-byte hardware sectors (16240 MB)
Feb 15 17:36:34 localhost kernel: sd 3:0:0:0: [sdc] Write Protect is off
Feb 15 17:36:34 localhost kernel: sd 3:0:0:0: [sdc] Assuming drive cache: write through
Feb 15 17:36:34 localhost kernel: sdc: sdc1
Feb 15 17:36:35 localhost hald: mounted /dev/sdc1 on behalf of uid 500
Feb 15 17:36:35 localhost gnome-keyring-daemon[22695]: adding removable location: volume_uuid_56B3_9844 at /media/SDHC


You'd still have the issue with installing to SD however, unless using a custom spin or F11 alpha? My solution was to install to the SDHC card via my usb SD card reader then once updated using the SDHC card in the internal reader. 

If there are no other objections, I'd class this as resolved.
Comment 42 Valent Turkovic 2009-02-16 04:54:54 EST
I have Fedora 10 with 2.6.27.15-170.2.24.fc10.i686 kernel installed on internal SSD and use SD card as external storage and leave it inserted all the time.

When I do reboot SD card gets corrupted even on this latest kernel, and I can't mount it unless I do fsck first.

Can you test this behaviour on your system?

If this happens to me and others should then this bug be closed? 

How can I make sure that this bug I'm experiencing isn't some other issue so we can close this bug if that is the case.
Comment 43 Peter Robinson 2009-02-16 05:08:53 EST
I believe the SD card wasn't working at all previously on the 701. Have you tried deleting the old filesystem and creating a new filesystem and see if that helps. Have you also tried explicitly unmounting the filesystem before you reboot to ensure the FS corruption isn't due to the FS being not unmounted cleanly?
Comment 44 Luke Sheldrick 2009-02-16 17:04:45 EST
#43, correct the original bug request was the fact that F10, couldn't mount the SD/SDHC card at all using the inbuilt reader. This however would appear to be fixed. 

I've just tested again with my EEE701. Having the SDHC 16GB card, or a SD 1GB card mounted, and rebooting either by gnome or shutdown -r now, doesn't affect the card at all upon rebooting. Remounts automatically with no errors on the boot. 

Valent: Does this just happen on one SD card, or have you tried different ones? Do you have an external/usb card reader to try this on, to try and replicate with an exernal reader? Is this a SD or SDHC card you're getting the problems with?
Comment 45 Valent Turkovic 2009-02-17 04:25:54 EST
I'll test it today and report back.
Comment 46 Valent Turkovic 2009-02-17 05:45:32 EST
I did these steps, on IBM R52 laptop via external USB card reader:

1. Move all files from SD card to one directoryon laptop
2. using fdisk remove sdb1 partition on SD card
3. format SD card via 'mkfs.ext3 /dev/sdb -L 8GB-SD' command
4. mounter SD card
5. as root added write privileges to all users via 'chmod 777 /media/8GB-SD/'
6. returned some files back from directory to SD card
7. sync && umount /media/8GB-SD && eject /dev/sdb
8. insert SD card into eee's SD card reader and power off - card appears on desktop.
9. copy 2 text files on SD card and reboot eee

- after that I still get errors for corrupt SD card

sdb: unknown partition table
EXT3-fs error (device sdb): ext3_check_descriptors: Block bitmap for group 1 not in group (block 0)!
EXT3-fs: group descriptors corrupted!

now I'll format it again and test via external reader.
Comment 47 Valent Turkovic 2009-02-17 06:20:10 EST
I repeated steps 1-9 just I used external card reader.

After reboot SD card is mounted without problems. 

I will now delete some files from SD card and reboot eee, then save some files and reboot the eee again.

After 3 cycles of moving, saving, deleting and rebooting eee afterwards I still have no error on SD card. Only thing I notice is different that SD card isn't mounted few seconds later after I login to Gnome. When SD card is in eee's SD card reader it is immediately visible on desktop (when it works).

Do you need some more feedback?
Comment 48 Valent Turkovic 2009-02-17 06:27:52 EST
(In reply to comment #44)
> #43, correct the original bug request was the fact that F10, couldn't mount the
> SD/SDHC card at all using the inbuilt reader. This however would appear to be
> fixed. 
> 
> I've just tested again with my EEE701. Having the SDHC 16GB card, or a SD 1GB
> card mounted, and rebooting either by gnome or shutdown -r now, doesn't affect
> the card at all upon rebooting. Remounts automatically with no errors on the
> boot. 
> 
> Valent: Does this just happen on one SD card, or have you tried different ones?
> Do you have an external/usb card reader to try this on, to try and replicate
> with an exernal reader? Is this a SD or SDHC card you're getting the problems
> with?

I have tested this with only one SD card, it is SDHC 8GB card, Class 6, brand: TakeMS.
Comment 49 Peter Robinson 2009-02-26 06:48:11 EST
Valent. You might be able to try something from a Fedora Re-Spin http://lwn.net/Articles/319753/

It was done on the tree as of Feb 10th I think so not sure if the kernel fix is in there.

Also are you able to try another card? From what I've read of other problems mileage varies dependant on the card as much as the reader.
Comment 50 Valent Turkovic 2009-02-26 14:43:15 EST
I tested Fedora 11 Alpha on that same SD card and that works, no errors.

Friend tested on his 8GB SDHC card and his Asus eee 701 with Fedora 10 and has same issues.

I did my own Fedora 10 respin with updated kernel and all other packages and I still get same errors.

Fedora 11 looks promising and works on SDHC card like a charm.
Comment 51 Luke Sheldrick 2009-05-20 16:26:17 EDT
Have tested, all works fine now.

Note You need to log in before you can comment on or make changes to this bug.