Bug 465440 - Intel Wireless Pro Link 5100/5300 not identified
Intel Wireless Pro Link 5100/5300 not identified
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 06:59 EDT by Lukas Tvrdy
Modified: 2009-01-29 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Tvrdy 2008-10-03 06:59:49 EDT
Description of problem:
lspci for my wifi card Intel Wireless Link 5100 did not
recognize the hardware

Version-Release number of selected component (if applicable):
pciutils-3.0.0-2.fc10.i386

How reproducible:

Steps to Reproduce:
lspci | grep Network shows:
02:00.0 Network controller: Intel Corporation Device 4237

Actual results:
02:00.0 Network controller: Intel Corporation Device 4237

Expected results:
4237 device is Wifi Link 5100 Wireless Adapter according announce from Intel.
They also send pci.ids to [2]

[1] http://linux.derkeiler.com/Mailing-Lists/Kernel/2008-08/msg05976.html
[2] http://pciids.sourceforge.net/

Additional info:
I tested Fedora 10 Beta, so I got point :)
"If you find a bug *and* report it, you get
the free attention of a package maintainer on a problem personally
important to you!" from [3]

[3] http://www.redhat.com/archives/fedora-announce-list/2008-September/msg00016.html
Comment 1 Michal Hlavinka 2008-10-03 08:47:52 EDT
Actual pci.ids database ( http://pciids.sourceforge.net/pci.ids ) doesn't contain ids from [1]. After all these ids are included, you can update your own ids database with: /sbin/update-pciids . New rpm will be released when new pciutils version shows up.
Comment 2 Michal Hlavinka 2008-11-04 10:11:25 EST
my mistake... pci.ids is not part of pciutils, it's part of hwdata...
changing component to hwdata
Comment 3 Bug Zapper 2008-11-25 22:30:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Brian Fristensky 2008-12-28 18:51:24 EST
I think I'm having a related problem. I have just done a fresh install
of F10 x86_64 on brand new LG R510 notebook. The Network Configuration
tool from System --> Administration is not able to detect my
wireless card. In the Wireless connection Wizard, no wireless card
shows up. The only choice is "Other Wireless Card". 

The specs for the R510 at

http://www.lge.com/products/model/detail/r510.jhtml

state that the onboard wireless for this machine is

  Intel WiFiLink 5300 (up to 450Mbps) or Intel WiFiLink 5100 (up to 300Mbps) or b/g/n (802.11 b/g/n)


I tried creating a wireless connection using the wizard, choosing
the closest match from the list of adaptors (Intel EtherExpress Pro 100B),
when I try to activate the interface, I get the message

  Device eth1 does not seem to be present, delaying initialization.
  
  
Comments #1 and #2 from Michal Hlavinka suggested running

/sbin/update-pciids

which I did. The new pci.ids file was found in /usr/share/hwdata.
I rebooted, but the wireless card is still not recognized.

Here's the output from lspci (run AFTER update-pciids and rebooting):

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 Network controller: RaLink RT2860
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

It's kind of pointless to have a notebook without wireless, so I'd appreciate any
suggestions.
Comment 5 Brian Fristensky 2008-12-30 14:30:24 EST
False alarm - sort of. It turns out that my laptop has an RaLink RT2860, 
rather than an Intel Wifi Link card, as listed on the product spec sheet.
Fortunately, RaLink actually distributes
a native Linux driver, so the Windows driver isn't needed. Even better, 
there are RPM packages available that yum can install:

kmod-rt2860
kmod-rt2860-2.6.27-9-159.fc10.x86_64
rt2860

I just installed these packages, rebooted, and was now able to 
create a wireless interface using the Network tool wizard.
I think these are all from the Fedora10 repo, but I should add
as a caveat that I also have livna and rpmfusion in my repo list.

I guess this is still a "bug", in the sense that F10 doesn't
detect this card and automatically install the necessary wireless
modules during the install process.
Comment 6 Brian Fristensky 2009-01-27 18:42:59 EST
Today's kernel kills wireless networking with the rt2860 interface.

Here's what was updated  on the system:
Jan 27 15:21:45 Updated: xine-lib-1.1.16.1-1.fc10.x86_64
Jan 27 15:21:46 Updated: vnc-libs-4.1.3-1.fc10.x86_64
Jan 27 15:21:51 Updated: libpurple-2.5.4-1.fc10.x86_64
Jan 27 15:22:10 Updated: pidgin-2.5.4-1.fc10.x86_64
Jan 27 15:22:13 Updated: vnc-4.1.3-1.fc10.x86_64
Jan 27 15:22:14 Updated: vnc-server-4.1.3-1.fc10.x86_64
Jan 27 15:22:14 Updated: xine-lib-extras-1.1.16.1-1.fc10.x86_64
Jan 27 15:22:15 Updated: xine-lib-pulseaudio-1.1.16.1-1.fc10.x86_64
Jan 27 15:22:15 Updated: iw-0.9.7-1.fc10.x86_64
Jan 27 15:22:15 Updated: kernel-firmware-2.6.27.12-170.2.5.fc10.noarch
Jan 27 15:22:35 Updated: selinux-policy-3.5.13-40.fc10.noarch
Jan 27 15:22:58 Updated: selinux-policy-targeted-3.5.13-40.fc10.noarch
Jan 27 15:23:15 Installed: kernel-devel-2.6.27.12-170.2.5.fc10.x86_64
Jan 27 15:23:18 Updated: kernel-headers-2.6.27.12-170.2.5.fc10.x86_64
Jan 27 15:23:34 Updated: kernel-doc-2.6.27.12-170.2.5.fc10.noarch
Jan 27 15:23:58 Installed: kernel-2.6.27.12-170.2.5.fc10.x86_64
Jan 27 15:23:59 Updated: PackageKit-yum-0.3.13-1.fc10.x86_64
Jan 27 15:23:59 Updated: PackageKit-yum-plugin-0.3.13-1.fc10.x86_64
Jan 27 15:23:59 Updated: PackageKit-glib-0.3.13-1.fc10.x86_64
Jan 27 15:24:00 Updated: PackageKit-gstreamer-plugin-0.3.13-1.fc10.x86_64
Jan 27 15:24:02 Updated: PackageKit-0.3.13-1.fc10.x86_64
Jan 27 15:24:16 Updated: gnome-packagekit-0.3.13-1.fc10.x86_64
Jan 27 15:24:20 Updated: PackageKit-udev-helper-0.3.13-1.fc10.x86_64

I also tried uninstalling and reinstalling:
rt2860
kmod-rt2860-2.6.27.9-159.fc10.x86_64
kmod-rt2860

but that didn't help. Does this mean that there need to be new kmod packages to go with the new kernel?
Comment 7 Fedora Update System 2009-01-29 18:00:23 EST
hwdata-0.222-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-01-29 18:00:59 EST
hwdata-0.222-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.