Bug 465480 - Openoffice.org doesn't build with java/javac combination of java from java-1.6.0-openjdk and javac of java-1.5.0-gcj-devel
Openoffice.org doesn't build with java/javac combination of java from java-1....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 10:56 EDT by Philip Ashmore
Modified: 2008-10-04 13:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 11:50:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmrc (178 bytes, text/plain)
2008-10-03 10:57 EDT, Philip Ashmore
no flags Details
rpmmacros (3.24 KB, application/octet-stream)
2008-10-03 10:58 EDT, Philip Ashmore
no flags Details
gzipped build log (1.49 MB, application/octet-stream)
2008-10-03 11:35 EDT, Philip Ashmore
no flags Details

  None (edit)
Description Philip Ashmore 2008-10-03 10:56:16 EDT
Description of problem:
Openoffice.org doesn't build on x86_64

Version-Release number of selected component (if applicable):
openoffice.org-2.4.1-17.6.fc9

How reproducible:
I tried it once - it looks serious.

Steps to Reproduce:
1. cd ~/rpmbuild
2. yumdownloader --source openoffice.org
3. TIME="%E" time rpmbuild -ba openoffice.org.spec 2>&1 | tee build.log

Actual results:
Build failed

Expected results:
Build succeeded

Additional info:
In order to satisfy build dependencies, I ran -
yum install ant icu java-1.5.0-devel vigra-devel libxml2-devel libxslt-devel neon-devel libcurl-devel libidn-devel pam-devel cups-devel xulrunner-devel libwpd-devel hunspell-devel unixODBC-devel sane-backends-devel libicu-devel perl-Archive-Zip gtk2-devel gnome-vfs2-devel evolution-data-server-devel libtextcat-devel nss-devel gstreamer-devel gstreamer-plugins-base-devel hyphen-devel

- although there are bound to be other dependencies that I already had installed.

I've got a custom build environment - see attached .rpmmacros and .rpmrc
I've gzipped the build log but it's 1.5MB compressed, 15.2MB uncompressed.
I will attach it if more information is needed.
Comment 1 Philip Ashmore 2008-10-03 10:57:27 EDT
Created attachment 319371 [details]
rpmrc
Comment 2 Philip Ashmore 2008-10-03 10:58:11 EDT
Created attachment 319372 [details]
rpmmacros
Comment 3 Philip Ashmore 2008-10-03 11:04:38 EDT
Between "Steps to Reproduce" steps 2 and 3 above insert
rpm -i openoffice.org-2.4.1-17.6.fc9.src.rpm
cd openoffice.org-2.4.1
Comment 4 Caolan McNamara 2008-10-03 11:13:56 EDT
Well, it definitely *does* build on x86_64 on vanilla F9, seeing as I build it all the time :-), so you'll have to show me your specific failure.
Comment 5 Philip Ashmore 2008-10-03 11:35:48 EDT
Created attachment 319383 [details]
gzipped build log
Comment 6 Caolan McNamara 2008-10-03 11:50:19 EDT
Your "java" is probably openjdk and your "javac" is probably "ecj". Mixing them doesn't work in 2.4.1, they both have to match, i.e. both from java-1.5.0-gcj or both from java-1.6.0-openjdk

I think I fixed this upstream for 3.0
Comment 7 Philip Ashmore 2008-10-03 20:30:06 EDT
My /root/install.log contains

    Installing java-1.6.0-openjdk-1.6.0.0-0.10.b09.fc9.x86_64
    ...
    Installing java-1.5.0-gcj-1.5.0.0-21.fc9.x86_64

so they were installation choices - not mine.
I agree that one or the other should be chosen - why this isn't the case for the F9 x86_64 install DVD is curious.

I installed java-1.6.0-openjdk-devel and galternatives shows that my system is now using java-1.6.0-openjdk-devel's version.

I'll give it a try tomorrow and see how it goes.
Comment 8 Philip Ashmore 2008-10-04 13:56:44 EDT
Yep. Build complete.

Note You need to log in before you can comment on or make changes to this bug.