Bug 465486 - building kernel-modules for ppc64 fails as
building kernel-modules for ppc64 fails as
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 11:16 EDT by Thorsten Leemhuis
Modified: 2008-12-08 19:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 09:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2008-10-03 11:16:25 EDT
Description of problem:
Trying to build different external modules for ppc64 results in quite long list of errors like

In file included from include/linux/mm.h:4,
                 from include/linux/pagemap.h:7,
                 from /builddir/build/BUILD/iscsitarget-kmod-0.4.15/_kmod_build_2.6.27-0.352.rc7.git1.fc10.ppc64/kernel/iscsi.h:10,
                 from /builddir/build/BUILD/iscsitarget-kmod-0.4.15/_kmod_build_2.6.27-0.352.rc7.git1.fc10.ppc64/kernel/tio.c:7:
include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory

Version-Release number of selected component (if applicable):
2.6.27-0.382.rc8.git4.fc10

Additional info:

From IRC
dwmw2> | I wonder if it's fallout from include/asm-foo moving to arch/foo/include/asm ?
knurd> | dwmw2, you might remember, I'm not a programmer, but I gurss you are right; kernel-devel.ppc64 on rawhide only contains one file in include/asm/; kernel-devel.x86_64 has a lot more in that directtory, including errno.h
dwmw2> | that sounds like the problem
knurd> | I guess I'll file a bug then; or do you want to take care of it?
dwmw2> | file a bug, assign it to me.
dwmw2> | hm, it's because x86 is lagging behind and hasn't moved from include/asm-$ARCH yet
Comment 1 Thorsten Leemhuis 2008-10-19 08:10:33 EDT
reopening, as afaics still unfixed; log of two failed builds can be found here:
http://buildsys.rpmfusion.org/logs/fedora-development-rpmfusion_free/1375-em8300-kmod-0.17.2-0.1.rc1.fc10.1/ppc/build.log
http://buildsys.rpmfusion.org/logs/fedora-development-rpmfusion_free/1376-em8300-kmod-0.17.2-0.1.rc1.fc10.1/ppc64/build.log

The patch that was supposed to fix this afaics was the second part of this commit:
http://cvs.fedora.redhat.com/viewvc/rpms/kernel/devel/kernel.spec?r1=1.1007&r2=1.1008 ; e.g. this code:

> if [ -d arch/%{_arch}/include ]; then
>    cp -a --parents arch/%{_arch}/include   \
>        $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
> fi

That code afaics has a small bug: %{_arch} is and rpm macro that becomes "ppc" or "ppc64"; but the directory that holds the files that are missing is arch/powerpc/include/
Comment 2 David Woodhouse 2008-10-20 06:44:37 EDT
Hm, I copied the arch/%{_arch}/ bit from a few lines further up. That one seems only to be required on IA64 though, where %{_arch} and $Arch will always be equal. I'll "fix" it anyway, to prevent anyone else from copying it and making the same mistake in future.
Comment 3 David Woodhouse 2008-10-20 09:57:24 EDT
Should be fixed properly this time, in kernel-2.6.27.3-31.rc1.fc10.
Thanks.
Comment 4 Kyle McMartin 2008-12-08 19:52:07 EST
Sadly, the previous fix wasn't enough for x86 at least, should be fixed in rawhide in the upcoming build.

cheers, Kyle

Note You need to log in before you can comment on or make changes to this bug.