Bug 465492 - Deleting package from spacewalk results in error
Deleting package from spacewalk results in error
Status: CLOSED DUPLICATE of bug 484305
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-10-03 11:30 EDT by John Hodrien
Modified: 2009-03-10 14:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 14:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Email WEB TRACEBACK (9.99 KB, text/plain)
2008-10-03 11:30 EDT, John Hodrien
no flags Details
Traceback from 0.3 (8.61 KB, text/plain)
2008-11-25 06:43 EST, John Hodrien
no flags Details
Traceback from Spacewalk 0.4 (9.76 KB, text/plain)
2009-01-19 12:55 EST, Brian Beaudoin
no flags Details
Extract of the catalina logfile, spacewalk 0.4 (15.56 KB, application/octet-stream)
2009-02-25 02:08 EST, Nicolas Raspail
no flags Details

  None (edit)
Description John Hodrien 2008-10-03 11:30:09 EDT
Created attachment 319381 [details]
Email WEB TRACEBACK

Description of problem:

Attempting to delete a package from spacewalk results in errors, and package is not deleted

Version-Release number of selected component (if applicable):

0.2

How reproducible:

Not entirely sure.

Steps to Reproduce:
1.  Attempt to delete awstats-6.8-2.fc9.noarch
  
Actual results:

Error reported in browser and by email

Expected results:

Package deleted from spacewalk

Additional info:

spacewalk-backend-0.2.7-1.el5.sw
spacewalk-backend-config-files-0.2.7-1.el5.sw
spacewalk-config-0.2.2-1.el5.sw
spacewalk-html-0.2.3-1.el5.sw
rhn-oracle-jdbc-1.0-20.el5.sw
spacewalk-backend-xmlrpc-0.2.7-1.el5.sw
spacewalk-java-0.2.8-1.el5.sw
spacewalk-grail-0.2.3-1.el5.sw
spacewalk-0.2.2-1.el5.sw
spacewalk-setup-0.2.4-1.el5.sw
spacewalk-java-lib-0.2.8-1.el5.sw
spacewalk-backend-server-0.2.7-1.el5.sw
spacewalk-backend-app-0.2.7-1.el5.sw
spacewalk-backend-package-push-server-0.2.7-1.el5.sw
spacewalk-taskomatic-0.2.8-1.el5.sw
spacewalk-base-0.2.3-1.el5.sw
spacewalk-sniglets-0.2.3-1.el5.sw
spacewalk-admin-0.2.2-1.el5.sw
rhnpush-0.2.4-1.el5.sw
spacewalk-java-config-0.2.8-1.el5.sw
spacewalk-backend-config-files-common-0.2.7-1.el5.sw
spacewalk-certs-tools-0.2.3-1.el5.sw
spacewalk-backend-xp-0.2.7-1.el5.sw
spacewalk-search-0.2.7-1.el5.sw
spacewalk-pxt-0.2.3-1.el5.sw
spacewalk-dobby-0.2.3-1.el5.sw
spacewalk-backend-satellite-tools-0.2.7-1.el5.sw
spacewalk-backend-xml-export-libs-0.2.7-1.el5.sw
spacewalk-backend-applet-0.2.7-1.el5.sw
spacewalk-moon-0.2.3-1.el5.sw
spacewalk-branding-0.1.5-1.el5.sw
spacewalk-backend-sql-0.2.7-1.el5.sw
spacewalk-backend-config-files-tool-0.2.7-1.el5.sw
spacewalk-schema-0.2.5-1.el5.sw
spacewalk-cypress-0.2.3-1.el5.sw
rhn-oracle-jdbc-tomcat5-1.0-20.el5.sw
Comment 1 John Hodrien 2008-11-25 06:40:40 EST
Same problem after upgrade to 0.3
Comment 2 John Hodrien 2008-11-25 06:43:23 EST
Created attachment 324592 [details]
Traceback from 0.3
Comment 3 Brian Beaudoin 2009-01-19 12:55:59 EST
Created attachment 329371 [details]
Traceback from Spacewalk 0.4

Traceback from Spacewalk 0.4
Comment 4 Nicolas Raspail 2009-02-25 02:08:06 EST
Hi,

on a fresh install of spacewalk on a RHEL 5.2 x86_64, I have the same problem when I want to delete some packages.

For example, if I select 500 packages to remove, the operation failed with a timeout. I have modified the Timeout value in httpd.conf but after that, It has failed with

2009-02-24 10:29:17,908 [TP-Processor6] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/rhn].[action] - Servlet.service() for servlet action threw exception java.lang.OutOfMemoryError: GC overhead limit exceeded

I have increase the Xmx value to 1024 and now, it failed with a java.lang.NullPointerException (I have put the catalina.out extract in attachment)

Thanks

Nicolas
Comment 5 Nicolas Raspail 2009-02-25 02:08:59 EST
Created attachment 333140 [details]
Extract of the catalina logfile, spacewalk 0.4
Comment 6 Nicolas Raspail 2009-02-25 03:51:18 EST
Hi,

I can remove 3 packages at the same time but no more, otherwise, I get the ISE with java.lang.NullPointerException

Nicolas
Comment 7 Brad Buckingham 2009-03-10 14:37:38 EDT
From looking over the stack traces, the scenario that generated the error was similar to :

1. select Channels -> Managed Software Channels -> Manage Software Packages
2. attempt to delete N packages

After further investigation, it appears that we had some duplicate bugs open on this issue, one of which has already been resolved.  I am now able to consistently delete 500+ packages at a time using the current space05 code base.

The BZ that resolved this issue was: 484305

*** This bug has been marked as a duplicate of bug 484305 ***

Note You need to log in before you can comment on or make changes to this bug.