This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 465548 - make canberra gtk module resident
make canberra gtk module resident
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libcanberra (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-03 16:17 EDT by Matthias Clasen
Modified: 2008-10-06 10:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 10:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-10-03 16:17:20 EDT
Since it doesn't handle being unloaded gracefully. To do so, add something like:

const char *
g_module_check_init (GModule *module)
{
    g_module_make_resident (module);

    return NULL;
}



to the end of canberra-gtk-module.c.

I've tested this and it does prevent the module from being unloaded, and thus prevents your desktop from dying when you play with the gtk-modules gconf settings in gconf-editor.
Comment 1 Lennart Poettering 2008-10-05 16:27:40 EDT
Fixed upstream. Need to upload a new version soon.
Comment 2 Lennart Poettering 2008-10-06 10:03:44 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.