Bug 465553 - Language selection should affect keyboard layout too
Language selection should affect keyboard layout too
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 464858
  Show dependency treegraph
 
Reported: 2008-10-03 16:40 EDT by Lauri Nurmi
Modified: 2014-06-02 15:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 15:34:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Nurmi 2008-10-03 16:40:31 EDT
Description of problem:
After selecting a language, the user needs to separately select a keyboard layout.  This is mostly an unnecessary extra step that a Live CD user has to go through at every boot.

Expected results:
After selecting a language, a proper keyboard layout would be automatically selected.

Additional info:
I know one cannot always guess the correct layout based on language.  However, if a language other than English (US) is chosen, the desired keyboard layout is almost certainly not en-US.  Probably with most languages it is possible to make a very good guess about the correct layout(s).
Comment 1 Mathieu Bridon 2008-10-19 08:00:11 EDT
Well, if you choose the French language, you're doomed.

For example, the first row of a french keyboard in France reads "azerty", while a french keyboard in Canada or Switzerland would have "qwerty" (like the US one) on the first row.

But both users use the french language...

And some french users might want to use a dvorak keyboard. Or they (like me) might have bought their laptop in the US with a US keyboard. Etc...

You see what I mean ? There's a clear difference between language and keyboard layout.

The language is a user preference. The layout is (generally) a hardware limitation (the letters are painted on the keys, you should use a layout that maps these paintings). And each and every paintings (hardware) might be found in each and every language are there are more than one country speaking the same language.
Comment 2 Lauri Nurmi 2008-10-19 08:43:54 EDT
Now, I have never suggested the keyboard layout should not be selectable at all.  I have just said it should be set to a reasonably guessed default after the language has been selected.

I see very well what you mean, as I already earlier wrote "I know one cannot always guess the correct layout based on language".

Are you seriously saying that because French and Canadian layouts differ, or because a small number of people may want to use Dvorak, the default layout should be en-US for everyone selecting French as language?  I would imagine that is the wrong layout for 99% of the users.

If a guess was made and "azerty" chosen automatically, that would still be wrong for 40% of the users, but it would be correct for the other 59%.  (Percentages are only examples.)  Now only 40% of them would need to go through the extra step instead of the previous 99%.
Comment 3 Mathieu Bridon 2008-10-19 08:49:38 EDT
Well, if I choose the French language, then I am asked to choose the keyboard layout.

But on the keyboard layout page, the french azerty is already selected by default.

This means that a reasonnable default is "guessed", but each one can change it at install / liveCD.

You just can't guess it and then launch the session as a canadian user won't be able to type is password in order to change it in the Gnome / whatever session.
Comment 4 Lauri Nurmi 2008-10-19 09:13:45 EDT
(In reply to comment #3)
> Well, if I choose the French language, then I am asked to choose the keyboard
> layout.

No, you are not.  This bug report is about GDM, and you must be talking about something else.

> This means that a reasonnable default is "guessed", but each one can change it
> at install / liveCD.

This bug report is not related to the installer.

> You just can't guess it and then launch the session as a canadian user won't be
> able to type is password in order to change it in the Gnome / whatever session.

There is no password for the Live CD user, therefore no need to type it.  And let me repeat that I have not suggested removing the possibility to change the layout.
Comment 5 Mathieu Bridon 2008-10-19 09:28:49 EDT
Sorry, I didn't have understood what you were talking about.

Then to me, this bug is only a duplicate of bug 466675 (read it from comment #17).

What's explained is that on first use, GDM defaults to "us" and not to whatever was set in X.

On a liveCD, what you have is an infinite loop of "first times" ;)
Comment 6 Lauri Nurmi 2008-10-19 11:45:12 EDT
This is most certainly not a duplicate of 466675.

Please pay attention to the fact that this bug report is a feature request, while bug 466675 is about an actual defect.
Comment 7 Matěj Cepl 2008-11-28 13:02:23 EST
There is quote certainly nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 8 Nicolas Chauvet (kwizart) 2009-06-30 08:10:01 EDT
(In reply to comment #2)
> Now, I have never suggested the keyboard layout should not be selectable at
> all.  I have just said it should be set to a reasonably guessed default after
> the language has been selected.
Indeed, selecting France as country code and having english instead of french as suggested user locale is rather improbable.
From the LiveCD point of view, switching theses options are really painfull (because CD access time).

It could be possible to preload every possible combinations of country codes and locales. But that may pull down boot time.
The other solution would be to allow to enter manually the Country code and locale without using the unwrap menu.

But until end-users locale and country are set in bios or wherever, this problem is likely to stay. Unless using a custom LiveCD image of course, but the purpose would be to keep the official LiveCD Desktop image and work on improving end-users experiences on non-default options usage.
Comment 9 Nicolas Chauvet (kwizart) 2011-01-11 09:16:38 EST
For the reminder, Ubuntu seems to have solved this situation by resolving the external IP address trying to discover where is the host location.

Instead I wonder if it would be possible to rely on the TXT DNS Entry that already has similar kind of tweak (for Paper size for example).
Comment 10 Fedora Admin XMLRPC Client 2011-06-21 11:29:31 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Fedora Admin XMLRPC Client 2011-06-21 11:31:33 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora Admin XMLRPC Client 2011-06-21 11:34:20 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Admin XMLRPC Client 2011-06-21 11:37:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 14 Fedora Admin XMLRPC Client 2011-06-21 11:43:15 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Fedora Admin XMLRPC Client 2011-06-21 11:47:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Fedora Admin XMLRPC Client 2011-06-21 11:49:33 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 17 Fedora Admin XMLRPC Client 2011-06-21 11:51:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 18 Fedora Admin XMLRPC Client 2011-06-21 11:52:59 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.