Bug 465556 - Exception in anaconda due to adding nonexistent rpm repo.
Exception in anaconda due to adding nonexistent rpm repo.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 17:03 EDT by Jonas Nyman
Modified: 2009-02-16 15:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Nyman 2008-10-03 17:03:35 EDT
Description of problem:
I accidentally tried to add a livna rpm repository that does not exist i.e. I wrote a repository URL that is actually a 404. 


Version-Release number of selected component (if applicable):
anaconda 11.

How reproducible:


Steps to Reproduce:
1. During installation of Fedora 10 beta add a third party repo
2. but mistype URL...
3. and see an unhandeled exception
   in anaconda
Actual results:
Anaconda crashes with exception, user is asked to report it to bugzilla

Expected results:
Error message informing of the erroneous url.

Additional info:
I could not send the exception traceback message because of an other bug.
A similar error happenes if one adds two rpm repos and tries to give them them identical names.
Comment 1 Chris Lumens 2008-10-06 14:25:28 EDT
I believe this should be fixed as part of the big repo editing patches Jeremy committed after the beta.  Is there any chance you could test rawhide tomorrow (or later) and see if you're still hitting the same problem?  A quick test I ran here didn't reproduce the issue.
Comment 2 Jonas Nyman 2008-10-07 14:23:26 EDT
I've done some more testing. It is the typos that's causing the crash. 
Please make some protection mechanism here. 

I havn't been able to test against rawhide, since I still haven't been able to install Fedora because of some other bugs.
Comment 3 Bug Zapper 2008-11-25 22:31:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.