Bug 465569 - spec file bug. Needs Requires on libattr
spec file bug. Needs Requires on libattr
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 17:31 EDT by Dax Kelson
Modified: 2008-10-06 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 09:28:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2008-10-03 17:31:37 EDT
Description of problem:

In creating a custom spin I noticed a missing dependency of coreutils.

The %post script uses the "mv" command:

    /bin/mv -f %{_infodir}/dir.rpmmodify %{_infodir}/dir

But the mv command won't run without libattr already being installed. 

ldd /bin/mv | grep attr
	libattr.so.1 => /lib64/libattr.so.1 (0x00000032fa600000)

Anaconda/yum doesn't know about the mv command in the %post section so it doesn't install libattr before installing coretuils. This results in that directory not getting renamed, and then all future info page installation in other packages fail.

The other libs that mv requires are installed before coreutils because those libs are dependencies of other packages.

Please add a Requires on libattr to the coreutils spec.
Comment 1 Ondrej Vasik 2008-10-06 09:28:29 EDT
Thanks for report, I added libattr requirements RAWHIDE in coreutils-6.12-11.fc10, closing RAWHIDE - will add that in F-9 as well in next F-9 coreutils update.

Note You need to log in before you can comment on or make changes to this bug.