Bug 465596 - Mouse cursor is hidden behing flickering square
Mouse cursor is hidden behing flickering square
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
: 473161 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 05:09 EDT by Peter Veres
Modified: 2018-04-11 04:17 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.2.903-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 19:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
You can see the white square. Mouse cursor should be behind it. (260.96 KB, image/jpeg)
2008-10-04 05:09 EDT, Peter Veres
no flags Details
Xorg.0.log, Clevo M66SR, Chrome9 HC IGP (40.25 KB, text/plain)
2008-10-31 01:46 EDT, Clifford Keele
no flags Details
Xorg.0.log.old, Clevo M66SR, Chrome9 HC IGP (40.68 KB, text/plain)
2008-10-31 01:48 EDT, Clifford Keele
no flags Details
My SMOLT file for the Clevo M66SR (6.31 KB, text/plain)
2008-10-31 01:49 EDT, Clifford Keele
no flags Details
Xorg.0.log, Clevo M66SR, Chrome9 HC IGP (40.25 KB, text/plain)
2008-10-31 01:58 EDT, Clifford Keele
no flags Details
xorg.conf from Fedora 9 (710 bytes, text/plain)
2008-10-31 05:41 EDT, Clifford Keele
no flags Details
Smolt from Fedora 9 (5.92 KB, text/plain)
2008-10-31 05:43 EDT, Clifford Keele
no flags Details
xorg Log files from Fedora 9 M66SR (30.71 KB, application/zip)
2008-10-31 05:49 EDT, Clifford Keele
no flags Details

  None (edit)
Description Peter Veres 2008-10-04 05:09:42 EDT
Created attachment 319448 [details]
You can see the white square. Mouse cursor should be behind it.

Description of problem:
Mouse cursor is hidden behind flickering white square. Square moves aroud screen with movement of mouse.

Version-Release number of selected component (if applicable):
Fedora 10 - Beta - KDE LIVE CD

How reproducible:

Boot system from CD and let KDE start. Mouse cursor is behind square.

Steps to Reproduce:
1.Boot system
2.Start KDE

  
Actual results:
Mouse cursor not usable. Responses for left and right click and movement but is invisible because of square in front of it.

Expected results:
Fully usable cursor.

Computer INFO:
VGA compatible controller: VIA Technologies, Inc. Chrome9 HC IGP (rev 01)
Fujitsu-Siemens Amilo Pro V3515
Comment 1 Matěj Cepl 2008-10-08 17:49:20 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Clifford Keele 2008-10-31 01:46:28 EDT
Created attachment 322021 [details]
Xorg.0.log, Clevo M66SR, Chrome9 HC IGP

Xorg.0.log, Clevo M66SR, Chrome9 HC IGP

Identical responses as mentioned in initial bug report
Comment 3 Clifford Keele 2008-10-31 01:48:07 EDT
Created attachment 322022 [details]
Xorg.0.log.old, Clevo M66SR, Chrome9 HC IGP

Xorg.0.log.old, Clevo M66SR, Chrome9 HC IGP
Comment 4 Clifford Keele 2008-10-31 01:49:22 EDT
Created attachment 322023 [details]
My SMOLT file for the Clevo M66SR

My SMOLT file for the Clevo M66SR
Comment 5 Clifford Keele 2008-10-31 01:58:00 EDT
Created attachment 322024 [details]
Xorg.0.log, Clevo M66SR, Chrome9 HC IGP

I am having similar responses with my Clevo M66SR with the same video card, Chrome9 HC IGP

Versions tested:
Fedora 9 - Stable, working, I think, although I did have install issues with beta versions.
Fedora 10 Snap2&Snap3 (KDE Live) - Boots to graphical environment, see cursor box.
Fedora 10 Snap2 DVD Install - Installs with TEXT environment.  Requires "startx" to open X-Windows (which opens fine).  However, cursor is still the box.

Active point on cursor is top left, and appears to be functional.
I can not see an "arrow" cursor.  Activity cursors such as widen window are identifiable only by slight change in cursor box.  
I was able to see some movement behind a bounding box "waiting" cursor.

Also note:
GIMP - program loads.  Appears to work, can draw bounding box.  However, when I try painting, nothing shows up on screen.

So far most other activities seem to be working.

See XOrg.log files attached, as well as SMOLT file also attached.
There was no Xorg.conf file.
Comment 6 Clifford Keele 2008-10-31 05:41:59 EDT
Created attachment 322034 [details]
xorg.conf from Fedora 9

xorg.conf from Fedora 9 (M66SR)
This file more or less works (in Fedora Core 9)

I had to manually set the screen resolution (system-preferences-hardware-screen resolution), set it to 1280x800.

Login screen still is off centered (so I can't select KDE)

Cursor is fine with this one.

See additional notes.
Comment 7 Clifford Keele 2008-10-31 05:43:06 EDT
Created attachment 322035 [details]
Smolt from Fedora 9

Smolt from Fedora 9
Comment 8 Clifford Keele 2008-10-31 05:49:45 EDT
Created attachment 322036 [details]
xorg Log files from Fedora 9 M66SR

Ok,
Here are the XORG log files from Fedora 9
Comment 9 Clifford Keele 2008-10-31 05:57:52 EDT
Ok,

I went ahead and re-installed Fedora 9 on my Clevo M66SR (with the Via Chrome 9 HC IGP).

The install on Fedora 9 wasn't as smooth as it could be, but the end result seems to be reasonably stable.

Install Notes:
No pointer cursor during setup (graphical).  Responds to tab and alt commands.
Cursor on map for time zone, but not elsewhere on page.
Once the "Welcome" screen comes up, screen is sized so that bottom left is not visible (but arrow cursor is ok), thus difficult to accept the options on the screen.
Reboot and Gnome comes up, but bottom and left side not visible.
Reset screen resolution with:
Preferences - Hardware - Screen Resolution, set to 1280x800

Now I can see the whole screen.
Cursor is fine.
Also tried GIMP (noted to have problems above with Fedora 10), and it seemed to work too.

Only problem with Fedora 9 is that the login screen is off centered, and thus one doesn't see the bar to change to KDE.

I've uploaded the xorg.conf and log files from Fedora 9.

When I get a chance, I'll re-install Fedora 10, and try the xorg.conf file from Fedora 9 (note, there wasn't one with Fedora 10).

Thanks for your help.
Comment 10 Xavier Bachelot 2008-11-07 11:42:40 EST
There's 2 problems here :
- The panel resolution is not detected properly.
- The hardware cursor is broken.

I cannot do much at the moment for the misedetection of the resolution. Force the proper resolution in your xorg conf. F10 includes a fix for that.
I cannot do much either for the hardware cursor issue. Force the software cursor on (Option "SWCursor"). The same (big) patch that is fixing the resolution detection is also carrying the cursor regression, unfortunately.

The hardware cursor bug is known and worked on upstream.
Comment 11 Bug Zapper 2008-11-25 22:32:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Xavier Bachelot 2008-12-29 20:16:21 EST
*** Bug 473161 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2009-01-05 19:21:50 EST
xorg-x11-drv-openchrome-0.2.903-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-3.fc10
Comment 14 Fedora Update System 2009-01-07 04:32:44 EST
xorg-x11-drv-openchrome-0.2.903-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0210
Comment 15 Fred Wittekind IV 2009-01-12 14:02:21 EST
Above update fixed issue on machine with a UniChrome Pro IGP
Comment 16 Joel Sass 2009-02-04 16:22:52 EST
Hey, just installed xorg-x11-drv-openchrome.i386 from the testing repository above (su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome')

This fix worked perfectly in our F10 LTSP environment using a DisklessWorkstation.com's LTSP Term 1420 Thin Client with VIA chipset.

Kudos.
Comment 17 Fedora Update System 2009-02-24 15:54:24 EST
xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2009
Comment 18 Fedora Update System 2009-03-09 19:05:14 EDT
xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Clifford Keele 2009-11-01 01:22:46 EST
THE CURSOR BOX IS BACK!!!!!!!

I've plugged my Clevo M66SR laptop as described above into a Dell 3008WFP monitor (VGA Cable).

Currently running Fedora 11.  The laptop video works much better than it had previously worked in Fedora 9 & 10...  thanks.

However, with the Dell monitor, it has set the resolution to 1280x800, which seems to be the max my laptop is able to support.

Unfortunately I have ended up with smaller text on the laptop screen and huge text on the Dell monitor.

I suppose there isn't much to complain about the resolution of the monitor, it apparently is pushing the capabilities of this laptop.

I can only seem to figure out how to get "mirrored" video, rather than two independent video displays too.

However,
the square flickering cursor box is back.

Fine on the laptop screen (mirrored screens).
Square flickering box on the remote Dell monitor screen.

I haven't tried the laptop with other remote screens...  I have an old Dell CRT that I'll dig out shortly and post an update.

Oh...
One other note...  a bit of a side...
gmplayer/mplayer does not seem to function on the remote Dell screen.  I can see the video player, but end up with a blank black box.

Odd...
With the Dell Monitor issue...
There are different cursors.

- Normal Pointing Arrow --> gives square box.
- Cross Arrow for moving window --> gives square box.
- Vertical line (mouse cursor) for editing text --> gives square box.
- Double Arrow for resizing window --> OK
This double arrow is OK for the two sides, top, bottom, and the four corners.

Note You need to log in before you can comment on or make changes to this bug.