Bug 465599 - Cheese doesn't shows any picture for 041e:405f creative webcam
Cheese doesn't shows any picture for 041e:405f creative webcam
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 05:39 EDT by Deependra Singh Shekhawat
Modified: 2008-10-06 14:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-05 11:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deependra Singh Shekhawat 2008-10-04 05:39:06 EDT
Description of problem:
Cheese in rawhide doesn't shows any picture when the webcam is plugged in to the system. Only a default picture is shown.

Version-Release number of selected component (if applicable):
cheese-2.24.0-1.fc10.i386
libv4l-0.5.0-1.fc10.i386
kernel-2.6.27-0.382.rc8.git4.fc10.i686

How reproducible:
Plug in the creative vista webcam on the usb port of a running rawhide machine. Open cheese to view the picture.

Steps to Reproduce:
1. Boot a rawhide system.
2. Login as a normal user in gnome.
3. Plugin the creative vista webcam (041e:405f) into the usb port 
4. Open cheese 
  
Actual results:
Cheese shows a default image.

Expected results:
Cheese should show the image as seen by the webcam.

Additional info:
The above camera is using gspca_ov519 driver as I can see in lsmod. Below is the output of lsmod | grep gspca
gspca_ov519 16900 0
gspca_main 21760 1 gspca_ov519
videodev   32128 1 gspca_main

When I install camstream and use it to view to the picture as seen by the webcam I can very well see the picture. No problem with camstream. But cheese just shows me a default image. Nothing else. When I click on preferences (menu item) of cheese I can see my Camera as Creative WebCam Vista (/dev/video0). No resolution is shown there. That's all.

If you like more info like log files etc. please feel free to ask. 

Thanks.
Comment 1 Daniel Qarras 2008-10-04 08:21:03 EDT
I am having this same problem with Labtec webcam id 046d:08a2. camstream works all ok but cheese does not show anything except the default. With Fedora 9 and self-compiled gspca this used to work also with cheese.
Comment 2 Hans de Goede 2008-10-05 11:13:55 EDT
Thanks for reporting this!

The issue with both cams was being caused by a bug in gstreamer-plugins-good (my bad).

I'll let the changelog explain:
* Sun Oct  5 2008 Hans de Goede <hdegoede@redhat.com> 0.10.10-5
- Fix gst-plugins-good-0.10.9-libv4l.patch to also patch config.in and
  Makefile.in so that the libv4l code actually gets enabled for real this time
  and remove plenty of egg from face for not fixing this properly in 0.10.10-2
  (rh465599)
- Explicitly disable pulse plugin so the spec builds even if you
  have the pulse devel packages installed.

* Fri Sep 12 2008 - Bastien Nocera <bnocera@redhat.com> 0.10.10-4
- Another rebuild

* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> 0.10.10-3
- Rebuild for GStreamer RPM provides

* Sun Aug 31 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.10-2
- Fix gst-plugins-good-0.10.9-libv4l.patch to not only patch configure.ac
  but also configure so that the libv4l code actually gets enabled

So this is fixed with gstreamer-plugins-good-0.10.10-5 which will be in tomorrows rawhide push. Please reopen if you still have issues with this new version.
Comment 3 Deependra Singh Shekhawat 2008-10-05 20:38:01 EDT
Hi,

Thanks. You are right. The above gstreamer update fixes the issue. Just one thing which is little sloppy is that I am not able to use video recording feature. So soon as I click on that button it shows that it has started the recording and cpu usage goes over to 100% and nothing happens cheese freezes. The overall system is usable though but cheese gets freezed. So I have to manually kill cheese.

Again thanks alot.
Comment 4 Daniel Qarras 2008-10-06 14:37:50 EDT
Yeah, "me too!" again, video recording does not work (or is unreliably at best). I also see a lot of errors/warning printed to stdout/stderr when starting cheese from the command line.

Perhaps I'll open a new bug few week later if these problems are not fixed by then.

Note You need to log in before you can comment on or make changes to this bug.