Bug 465608 - Installer should use Labels or partition numbers not UUIDs in /etc/fstab
Installer should use Labels or partition numbers not UUIDs in /etc/fstab
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 09:29 EDT by Joshua Rosen
Modified: 2008-10-16 11:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 11:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2008-10-04 09:29:35 EDT
Description of problem: The installer has switched from putting labels in /etc/fstab to UUIDs, this leads to problems if a partition is reformatted.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. During installation create a couple of root partitions, one for Fedora's / and one for another distro.
2. Install CentOS5 in the other root partition
3. Reboot Fedora
  
Actual results: Fedora won't boot because the UUID on the CentOS / partition will have been changed. If the partition had been mounted with LABEL or /dev/sdax instead there would be no problem because those don't change unless you delete the partition.

Also the UUIDs aren't human readable, LABELs are. 


Expected results: Fedora should boot.


Additional info:
Comment 1 Joel Andres Granados 2008-10-16 11:33:42 EDT
Dont see how this could be cause by parted.

Moreover: managing labels on reinstall was causing much trouble and the disicion was taken to use UUID.  I think the better Idea would be to come up with a way of letting the user decide if he wants to keep the UUID (if its possbile, not sure here.)
Comment 2 Chris Lumens 2008-10-16 11:40:57 EDT
The decision to use UUIDs was driven largely by the fact that labels are not at all unique, so moving drives from one computer to another, or having multiple drives with the same generic label in the same computer, was causing tons of problems.  By moving to UUIDs, we get away from this set of problems.

You're hitting the exact problem I'm describing, in fact.  Your multiple / partitions would all end up with the same label, or with silly things like LABEL=/1.

There's not really a good way to have some sort of label vs. UUID UI that I can see.  People using the UI aren't really going to care about that kind of choice.

Note You need to log in before you can comment on or make changes to this bug.