This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 465613 - [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
Status: CLOSED DUPLICATE of bug 465884
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 11:28 EDT by Naresh
Modified: 2009-12-05 18:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 18:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Naresh 2008-10-04 11:28:23 EDT
Description of problem:

Desktop hangs periodically using the latest Fedora 10 Rawhide. (oct-4-2008 updates).

Version-Release number of selected component (if applicable):

xorg-x11-xkb-utils-7.2-7.fc10.x86_64
xorg-x11-font-utils-7.2-6.fc10.x86_64
xorg-x11-drv-siliconmotion-1.6.0-1.fc9.x86_64
xorg-x11-drv-elographics-1.2.0-1.fc9.x86_64
xorg-x11-drv-magellan-1.2.0-1.fc9.x86_64
xorg-x11-drv-nvidia-177.78-1.lvn10.x86_64
xorg-x11-drv-openchrome-0.2.903-1.fc10.x86_64
xorg-x11-drv-vmmouse-12.5.0-1.fc9.x86_64
xorg-x11-drv-i740-1.2.0-1.fc9.x86_64
xorg-x11-drv-voodoo-1.2.0-1.fc9.x86_64
xorg-x11-drv-v4l-0.2.0-1.fc9.x86_64
xorg-x11-drv-savage-2.2.0-2.fc9.x86_64
xorg-x11-filesystem-7.3-2.fc10.noarch
xorg-x11-server-utils-7.4-3.fc10.x86_64
xorg-x11-apps-7.3-5.fc10.x86_64
xorg-x11-xtrans-devel-1.2.1-2.fc10.x86_64
xorg-x11-drv-ur98-1.1.0-5.fc9.x86_64
xorg-x11-drv-s3virge-1.10.0-1.fc9.x86_64
xorg-x11-drv-digitaledge-1.1.1-1.fc9.x86_64
xorg-x11-drivers-7.3-9.fc10.x86_64
xorg-x11-util-macros-1.1.6-2.fc10.x86_64
xorg-x11-drv-void-1.1.1-9.fc9.x86_64
xorg-x11-drv-dynapro-1.1.2-1.fc9.x86_64
xorg-x11-drv-dmc-1.1.2-1.fc9.x86_64
xorg-x11-drv-fpit-1.2.0-1.fc9.x86_64
xorg-x11-xinit-1.0.9-4.fc10.x86_64
xorg-x11-drv-r128-6.8.0-1.fc10.x86_64
xorg-x11-drv-tdfx-1.4.0-1.fc9.x86_64
xorg-x11-drv-trident-1.3.0-1.fc9.x86_64
xorg-x11-drv-hyperpen-1.2.0-1.fc9.x86_64
xorg-x11-drv-rendition-4.2.0-1.fc9.x86_64
xorg-x11-drv-i128-1.3.0-1.fc9.x86_64
xorg-x11-drv-calcomp-1.1.2-1.fc9.x86_64
xorg-x11-drv-ati-6.9.0-21.fc10.x86_64
xorg-x11-xauth-1.0.2-5.fc10.x86_64
xorg-x11-proto-devel-7.4-3.fc10.noarch
xorg-x11-drv-citron-2.2.1-1.fc9.x86_64
xorg-x11-drv-apm-1.2.0-1.fc9.x86_64
xorg-x11-drv-glint-1.2.1-1.fc9.x86_64
xorg-x11-drv-nouveau-0.0.11-1.20080902git6dd8ad4.fc10.x86_64
xorg-x11-drv-palmax-1.2.0-1.fc9.x86_64
xorg-x11-drv-mach64-6.8.0-1.fc10.x86_64
xorg-x11-utils-7.4-3.fc10.x86_64
xorg-x11-drv-diamondtouch-0.2.0-0.1.fc9.x86_64
xorg-x11-drv-cirrus-1.2.0-1.fc9.x86_64
xorg-x11-drv-dummy-0.3.0-1.fc9.x86_64
xorg-x11-drv-wiimote-0.0.1-1.fc9.x86_64
xorg-x11-drv-aiptek-1.1.1-1.fc9.x86_64
xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
xorg-x11-drv-nvidia-libs-177.78-1.lvn10.x86_64
xorg-x11-drv-mga-1.4.9-1.fc9.x86_64
xorg-x11-drv-microtouch-1.2.0-1.fc9.x86_64
xorg-x11-drv-vmware-10.16.0-1.fc9.x86_64
xorg-x11-drv-jamstudio-1.2.0-1.fc9.x86_64
xorg-x11-drv-evdev-2.0.4-3.fc10.x86_64
xorg-x11-drv-acecad-1.2.2-1.fc9.x86_64
xorg-x11-drv-summa-1.2.0-2.fc10.x86_64
xorg-x11-drv-tek4957-1.2.0-1.fc9.x86_64
xorg-x11-server-common-1.5.1-4.fc10.x86_64
xorg-x11-drv-sis-0.10.0-1.fc9.x86_64
xorg-x11-drv-penmount-1.3.0-1.fc9.x86_64
xorg-x11-drv-ast-0.85.0-1.fc9.x86_64
xorg-x11-drv-synaptics-0.15.2-1.fc10.x86_64
xorg-x11-drv-vesa-2.0.0-1.fc10.x86_64
xorg-x11-drv-mouse-1.3.0-2.fc9.x86_64
xorg-x11-drv-sisusb-0.9.0-1.fc9.x86_64
xorg-x11-drv-fbdev-0.3.1-7.fc9.x86_64
xorg-x11-drv-nv-2.1.12-5.fc10.x86_64
xorg-x11-drv-keyboard-1.3.0-3.fc9.x86_64
xorg-x11-drv-spaceorb-1.1.0-6.fc9.x86_64
xorg-x11-drv-mutouch-1.2.0-1.fc9.x86_64
xorg-x11-server-Xorg-1.5.1-4.fc10.x86_64


How reproducible:

Always

Steps to Reproduce:
1. Install Fedora 10 on Macbook Pro 4,1
2. Boot into GNOME/KDE desktops
3. Watch the /var/log/Xorg.0.log
  
Actual results:

Xorg is hanging frequently, but is working within few seconds.

Expected results:

X should not hang intermittently.

Additional info:

Info from /var/log/Xorg.0.log

[nareshv ~]$ sudo tail /var/log/Xorg.0.log
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.

[nareshv ~]$ sudo grep -c 'EQ overflowing.' /var/log/Xorg.0.log
339
[nareshv ~]$ uptime
 20:56:02 up 34 min,  3 users,  load average: 0.21, 0.42, 0.52
Comment 1 Dong Chen 2008-10-05 00:52:46 EDT
I have same problem. I am using dell 1720 laptop that have nv 8600m .so when I installed nvidia drivers,the f10 beta will hang frequently.the Xorg.0.log express the same thing :
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.

when uninstalling the nv driver,the problem will be solved.
Comment 2 Dong Chen 2008-10-05 00:59:35 EDT
But if I don't install the nv driver,I can't watch movie and haven't 3d and so on,so wish the problem can be solved soon.
Comment 3 Dong Chen 2008-10-05 01:11:07 EDT
oh I forgot, the f10 beta i have installed is x68_64.
Comment 4 Naresh 2008-10-05 08:01:29 EDT
I re-installed the F10-beta, this time i didn't upgraded to the latest rawhide packages. Now my desktop seems stable without any problems with xorg.

These are the default packages in the f10-DVD

xorg-x11-drv-ur98-1.1.0-5.fc9.x86_64
xorg-x11-drv-sisusb-0.9.0-1.fc9.x86_64
xorg-x11-drv-s3virge-1.10.0-1.fc9.x86_64
xorg-x11-drv-digitaledge-1.1.1-1.fc9.x86_64
xorg-x11-drv-fbdev-0.3.1-7.fc9.x86_64
xorg-x11-drivers-7.3-9.fc10.x86_64
xorg-x11-proto-devel-7.4-3.fc10.noarch
xorg-x11-apps-7.3-5.fc10.x86_64
xorg-x11-drv-voodoo-1.2.0-1.fc9.x86_64
xorg-x11-drv-sis-0.10.0-1.fc9.x86_64
xorg-x11-drv-nv-2.1.12-4.fc10.x86_64
xorg-x11-drv-penmount-1.3.0-1.fc9.x86_64
xorg-x11-drv-v4l-0.2.0-1.fc9.x86_64
xorg-x11-drv-ast-0.85.0-1.fc9.x86_64
xorg-x11-drv-savage-2.2.0-2.fc9.x86_64
xorg-x11-filesystem-7.3-2.fc10.noarch
xorg-x11-xkb-utils-7.2-7.fc10.x86_64
xorg-x11-font-utils-7.2-6.fc10.x86_64
xorg-x11-utils-7.4-3.fc10.x86_64
xorg-x11-drv-keyboard-1.3.0-3.fc9.x86_64
xorg-x11-server-Xorg-1.5.0-6.fc10.x86_64
xorg-x11-drv-r128-6.8.0-1.fc10.x86_64
xorg-x11-drv-acecad-1.2.2-1.fc9.x86_64
xorg-x11-drv-tdfx-1.4.0-1.fc9.x86_64
xorg-x11-drv-openchrome-0.2.903-1.fc10.x86_64
xorg-x11-drv-trident-1.3.0-1.fc9.x86_64
xorg-x11-drv-summa-1.2.0-2.fc10.x86_64
xorg-x11-drv-hyperpen-1.2.0-1.fc9.x86_64
xorg-x11-drv-vmmouse-12.5.0-1.fc9.x86_64
xorg-x11-drv-rendition-4.2.0-1.fc9.x86_64
xorg-x11-drv-tek4957-1.2.0-1.fc9.x86_64
xorg-x11-drv-i128-1.3.0-1.fc9.x86_64
xorg-x11-drv-i740-1.2.0-1.fc9.x86_64
xorg-x11-drv-calcomp-1.1.2-1.fc9.x86_64
xorg-x11-drv-nvidia-177.78-1.lvn10.x86_64
xorg-x11-server-utils-7.4-3.fc10.x86_64
xorg-x11-drv-mouse-1.3.0-2.fc9.x86_64
xorg-x11-drv-evdev-2.0.4-3.fc10.x86_64
xorg-x11-drv-void-1.1.1-9.fc9.x86_64
xorg-x11-drv-mga-1.4.9-1.fc9.x86_64
xorg-x11-drv-spaceorb-1.1.0-6.fc9.x86_64
xorg-x11-drv-siliconmotion-1.6.0-1.fc9.x86_64
xorg-x11-drv-dynapro-1.1.2-1.fc9.x86_64
xorg-x11-drv-microtouch-1.2.0-1.fc9.x86_64
xorg-x11-drv-mutouch-1.2.0-1.fc9.x86_64
xorg-x11-drv-elographics-1.2.0-1.fc9.x86_64
xorg-x11-drv-dmc-1.1.2-1.fc9.x86_64
xorg-x11-drv-vmware-10.16.0-1.fc9.x86_64
xorg-x11-drv-ati-6.9.0-14.fc10.x86_64
xorg-x11-drv-magellan-1.2.0-1.fc9.x86_64
xorg-x11-drv-fpit-1.2.0-1.fc9.x86_64
xorg-x11-drv-jamstudio-1.2.0-1.fc9.x86_64
xorg-x11-drv-nvidia-libs-177.78-1.lvn10.x86_64
xorg-x11-xinit-1.0.9-4.fc10.x86_64
xorg-x11-drv-diamondtouch-0.2.0-0.1.fc9.x86_64
xorg-x11-drv-cirrus-1.2.0-1.fc9.x86_64
xorg-x11-drv-dummy-0.3.0-1.fc9.x86_64
xorg-x11-drv-synaptics-0.15.1-1.fc10.x86_64
xorg-x11-drv-wiimote-0.0.1-1.fc9.x86_64
xorg-x11-drv-i810-2.4.2-8.fc10.x86_64
xorg-x11-drv-aiptek-1.1.1-1.fc9.x86_64
xorg-x11-server-common-1.5.0-6.fc10.x86_64
xorg-x11-xauth-1.0.2-5.fc10.x86_64
xorg-x11-drv-vesa-2.0.0-1.fc10.x86_64
xorg-x11-drv-citron-2.2.1-1.fc9.x86_64
xorg-x11-drv-apm-1.2.0-1.fc9.x86_64
xorg-x11-drv-glint-1.2.1-1.fc9.x86_64
xorg-x11-drv-nouveau-0.0.11-1.20080902git6dd8ad4.fc10.x86_64
xorg-x11-drv-palmax-1.2.0-1.fc9.x86_64
xorg-x11-drv-mach64-6.8.0-1.fc10.x86_64


Not sure if there is a new bug introduced after f10-beta.
Comment 5 Naresh 2008-10-07 05:43:51 EDT
just now upgraded F10 to the latest rawhide, the problem is back again.
Comment 6 Dong Chen 2008-10-08 05:20:17 EDT
updated f10 to the latest,and install the 177.80,then try again.probably solved.
Comment 7 Naresh 2008-10-08 08:20:40 EDT
yea, changelog also says the same http://www.nvidia.com/object/linux_display_ia32_177.80.html . lemme update to rawhide and see.
Comment 8 Dong Chen 2008-10-08 09:42:56 EDT
i have tried ,not to solve it.
Comment 9 Naresh 2008-10-08 13:14:29 EDT
Upgraded to 177.80 nvidia driver

I still see the errors in my /var/log/Xorg.0.log,

1. Boot into F10
2. The moment GDM comes up, you'll notice the screen becoming unresponsive, also the wallpaper behind the GDM also wont appear for few seconds (when compared to a good case)
3. After you choose the Login and enter the passcode, your server goes unresponsive for few seconds.( cursor animation gets hung and visible).
4. Once all the panels are loaded and the applets are loaded, desktop becomes to a usable state.

After the GNOME desktop is up, you wont see the errors filling in the xorg.log
Comment 10 Matěj Cepl 2008-10-08 18:11:23 EDT

*** This bug has been marked as a duplicate of bug 465884 ***

Note You need to log in before you can comment on or make changes to this bug.