Bug 465635 - Fedora won't boot after install on Athlon 64
Fedora won't boot after install on Athlon 64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 18:36 EDT by Juergen Bullinger
Modified: 2009-12-18 01:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:30:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2008-10-04 18:36:59 EDT
Description of problem:
Ater Installing the Beta of Fodora 10 I rebooted the system. At first it seemed to work, but than during the boot process I got plenty of ugly messages. Saying the file system (ext3) is buggy.
I tried to reinstall using (ext2) => delted partition, created new one and formated it as ext2 using the installers window (customized layout).
I checked the DVD medium after boot. It said the DVD was ok!

Version-Release number of selected component (if applicable):

Beta 10 x86_64. I think it was dated 30. September.

How reproducible:

Too often :o(

Steps to Reproduce:
1. Durn DVD image of Fedora 10 x86_64 Beta on DVD
2. Boot
3. Install on Harddisk using costumized layout (no automatic partitioning)
  
Actual results:
Hangs during boot process putting out many ugly messages

Expected results:
Boot and have fun with Fedora 10 :o)

Additional info:
Comment 1 Dave Jones 2008-10-04 18:52:07 EDT
we really need to know what those ugly messages are in order to diagnose this.

could you perhaps take a photograph of them ?
Comment 2 Juergen Bullinger 2008-10-05 11:14:33 EDT
I could look for the last messages which were put out, but probably those are only "second errors" which were probably caused by the first one.
I only know that it said something about file system errors.
I would need to install FC 10 again to reproduce it.
The idea with the photo is not bad. Is there something else I can do?
Comment 3 Dave Jones 2008-10-05 16:07:36 EDT
I wonder if your custom partitioning is confusing something.
Can you describe what you did in more detail?
Comment 4 Juergen Bullinger 2008-10-05 19:00:54 EDT
I just have some parallel fedora installations on the disk on other partitions. I also have a home directory which I mount, so I can use my data also on the next linux version.
This is the reason why I don't want the disk to be completely erased.
But for the partition I already tried different things:

a.) just format the partition as ext3 and install afterwards

b.) delete the partition and format it afterwards as ext3 and install on it

c.) delete the partition and format it afterwards as ext2 and install on it

none of these worked. This means the installation completed and asked me to reboot, but then I got the error messages.

I took photos of the screen unfortunately it scrolls very fast, when this happens and I need to download the pix from my camera first.
It says something like:



ext3_readpages: 0x1f/0x21
and than
/etc/rc.d/rc.sysinit line 22: 3317 getötet


I am not quite sure if it was line 22, its a little bit shaked. "getötet" means "killed".


Farther above:
: command not found0:
/bin/shown: line 261: *ColorSepScreenAngle: command not found
: command not found2:
/bin/shown: line 263: *ColorSepScreenAngle: command not found
: command not found4:
/bin/shown: line 265: *ColorSepScreenAngle: command not found
: command not found6:
/bin/shown: line 267: *ColorSepScreenAngle: command not found
BUG: unable to handle kernel NULL pointer dereference at 0000000000000080
IP: [<ffffffff812a4f49>] dm_merge_bvec+0x96/0d4
PGD: 3d4f0067 PUD 3d4b1067 PMD 3d4a2067 PTE 0
Oops: 0000 [3] SMP DEBUG_PAGEALLOC
CPU 0
Modules linked in: dm_multipath ppdev snd_via82xx gameport snd_seq_dummy_floppy


... a list of some more modules follows and than ...

Pid: 3347, comm: rc.sysinit Tainted: G         D  2.6.27-0.352.rc7.glt1.fc10.x86_64



Somewhere else it reads:

/etc/rc [something I cant read than]  rc.sysinit: line 605: /sbin/reboot/: cannot execute binary file
Root-Dateisystem mit Schreib- und Lese[something I can't read] einhängen EXT3-fs warning: mounting fs with errors, running e2fsck is recommended

[In the following line I coulud only sopt a] "dm-5): bad directory entry"


Please note that I did an e2fsck on the directory. It returned almost instantly without giving any error messages (e2fsck /dev/sda6)
Comment 5 Bug Zapper 2008-11-25 22:33:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-11-18 02:55:52 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-12-18 01:30:30 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.