Bug 465643 - Fedora 10 beta crashes qemu
Fedora 10 beta crashes qemu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 00:35 EDT by Philip Ashmore
Modified: 2009-04-28 19:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 09:16:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2008-10-05 00:35:23 EDT
Description of problem:
Fedora 10 beta crashes qemu

Version-Release number of selected component (if applicable):
Fedora 10 beta

How reproducible:
I tried it once

Steps to Reproduce:
1. download Fedora-10-Beta-x86_64-DVD.iso
2. as root run
    /usr/bin/qemu-system-x86_64 -boot d -m 768 -hda '/dev/sdc' -cdrom  \
    'Fedora-10-Beta-x86_64-DVD.iso' -net nic,vlan=0 -net user,vlan=0 -localtime &
  
Actual results:
RAX=00007fcf6cc2c000 RBX=0000000004c9f580 RCX=000000000042b5aa RDX=0000000000000001
RSI=0000000004c9f580 RDI=0000000000000000 RBP=00007fff798ca940 RSP=00007fff798ca7e0
R8 =00007fcf6cc2c000 R9 =0000000000000000 R10=0000000000000002 R11=0000000000010246
R12=0000000000000003 R13=0000000000000001 R14=00000000012ed700 R15=00007fff798cbfd7
RIP=0000000000407c44 RFL=00010213 [----A-C] CPL=3 II=0 A20=1 SMM=0 HLT=0
ES =0000 0000000000000000 00000000 00000000
CS =0033 0000000000000000 ffffffff 00affb00
SS =002b 0000000000000000 ffffffff 00cff300
DS =0000 0000000000000000 00000000 00000000
FS =0063 00000000012ec860 ffffffff 01dff32e
GS =0000 0000000000000000 00000000 00000000
LDT=0000 0000000000000000 00000000 00008000
TR =0040 ffff880002b8d480 00002087 00008900
GDT=     ffff880002a04000 0000007f
IDT=     ffffffff81ad2000 00000fff
CR0=80050033 CR2=00007fcf6cc2c010 CR3=00000000067e5000 CR4=000006e0
Unsupported return value: 0xffffffff

Expected results:
The installation should have completed.

Additional info:
I was trying to install Fedora 10 beta onto an external 10GB IDE hard disk through a USB 2.0 interface as I would like to be able to boot the beta from an external hard drive for testing.

I got the qemu parameters by running Qemu launcher.
I selected "delete all partitions" and "create default layout".
I selected disk encryption.
I customised the installation to install KDE, not Gnome.
The install process takes quite some time so I watched a DVD and checked the Qemu window every 20 minutes or so.
The last time I saw it, it was about 10% complete.
The next time I checked, the Qemu window had closed and the above register dump was left behind on konsole.

I'm filing this against Fedora 10 anaconda as I've completed F9 installs using this method, although I couldn't boot the resulting installation from an external USB disk enclosure.
Comment 1 Philip Ashmore 2008-10-05 08:47:53 EDT
The smolt details for my Compaq Presario A900 are at
http://www.smolts.org/client/show/pub_dd735748-621d-4d5e-9b8b-96ecfaf45e03
in case it helps (I tried to update it - failed).
Comment 2 Hans de Goede 2008-10-05 13:41:54 EDT
qemu crashing is not an anaconda bug, but rather a wemu bug changing component and assignment.
Comment 3 Philip Ashmore 2008-10-06 10:29:21 EDT
In  that case - qemu-0.9.1-6.fc9.
Changed Fedora version to 9.
Comment 4 Philip Ashmore 2008-10-06 10:45:26 EDT
Also, I'm using kqemu-kmod-1.3.0-0.40.lvn9

Submitted bug report to livna
http://bugzilla.livna.org/show_bug.cgi?id=2122
Comment 5 Mark Bidewell 2008-11-02 18:01:14 EST
I have been seeing this with KVM (kernel virtual machine) version 77 and 78.  Since KVM doesn't use kqemu I believe this is an upstream Qemu issue.
Comment 6 Mark McLoughlin 2009-04-20 06:06:54 EDT
Philip/Mark - please confirm that this is still happening. If qemu is segfaulting, could you attach a backtrace?
Comment 7 Mark Bidewell 2009-04-20 08:50:13 EDT
This issues was fixed in F10 final
Comment 8 Mark McLoughlin 2009-04-20 09:16:20 EDT
Thanks Mark
Comment 9 Philip Ashmore 2009-04-28 19:49:13 EDT
I had to switch to Debian for development purposes so I can't check it. sorry for my untimely reply.

Note You need to log in before you can comment on or make changes to this bug.