This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 465661 - FTBFS: asterisk fails to build from source and causes broken deps
FTBFS: asterisk fails to build from source and causes broken deps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asterisk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On: 457108 461338
Blocks: F10FTBFS
  Show dependency treegraph
 
Reported: 2008-10-05 06:22 EDT by Alex Lancaster
Modified: 2008-10-10 21:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.6.0.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 14:47:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-10-05 06:22:31 EDT
Broken deps for i386
----------------------------------------------------------
        asterisk-mobile-1.6.0-0.21.beta9.fc10.i386 requires libbluetooth.so.2

Failed a rebuild:

https://koji.fedoraproject.org/koji/taskinfo?taskID=820346

Also, I see from www.asterisk.org it looks like official 1.6.0 has been
released, perhaps it will fix these issues?
Comment 1 Jeffrey C. Ollie 2008-10-05 08:46:44 EDT
More recent versions of Asterisk (including the official release) require DAHDI, which is awaiting review:

https://bugzilla.redhat.com/show_bug.cgi?id=461338

It'd be nice to get libss7 reviewed too, but that's not a required dependency:

https://bugzilla.redhat.com/show_bug.cgi?id=457108
Comment 2 Jeffrey C. Ollie 2008-10-08 15:26:12 EDT
libss7 has been reviewed and is now in rawhide.  Still waiting for DAHDI to be reviewed.
Comment 3 Jeffrey C. Ollie 2008-10-10 14:47:00 EDT
dahdi-tools has been reviewed and the final version of Asterisk 1.6.0 has been built against it.  They should show up tomorrow in rawhide.  This will also fix the broken deps against libbluetooth.
Comment 4 Alex Lancaster 2008-10-10 21:50:01 EDT
Build here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=65989

should probably close as RAWHIDE, not NOTABUG, since it was a bug that was fixed. ;)

Note You need to log in before you can comment on or make changes to this bug.