Bug 465685 - (TB9148cf90) newlines in user name cause script errors and aborts
newlines in user name cause script errors and aborts
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-05 11:27 EDT by Juergen Bullinger
Modified: 2009-12-18 01:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 01:30:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2008-10-05 11:27:25 EDT
Description of problem:
I used the live-DVD (FC 10 x86_64 alpha) and set up my network.
It is a dsl connection. I copied the user name from a text editor and accidentally copied also a newline at the end of the string.
This newline seems to caus script errors.

Version-Release number of selected component (if applicable):

How reproducible:
Only tried once, but I am pretty sure, it is 100% reproducible, because I looked at the produced ifcfg-t file and saw the problem.

Steps to Reproduce:
1. open from Menu System->Administration->Network
2. chose new to create a connection
3. selected DSL
4. copied the user name string + a new line into the entry field for the user name
5. pressed ok
6. tried to start the connection
7. abort with error message
Actual results:

Script error (see below)

Expected results:
Start internet connection

Additional info:

Component: system-config-network
Version: 1.5.10
Summary: TB9148cf90 Conf.py:366:initvars:IndexError: end quote not found in //etc/sysconfig/networking/devices/ifcfg-t: USER

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 275, in __init__
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 299, in load
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 307, in loadDevices
    devicelist = getDeviceList()
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 318, in getDeviceList
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 59, in load
    conf = ConfDevice(dev, devdir)
  File "/usr/share/system-config-network/netconfpkg/NCDevice.py", line 49, in __init__
    Conf.ConfShellVar.__init__( self, self.filename )
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 342, in __init__
    separators='=', separator='=')
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 205, in __init__
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 346, in read
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 366, in initvars
    raise IndexError (self.filename, var)
IndexError: end quote not found in //etc/sysconfig/networking/devices/ifcfg-t: USER

Local variables in innermost frame:
var: ['USER', '001173589669550258087664#0001@t-online.de']
p: -42
self: <netconfpkg.NCDevice.ConfDevice instance at 0x7fa5f1a5ec68>
quote: '
Comment 1 Bug Zapper 2008-11-25 22:35:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 2 Bug Zapper 2009-11-18 04:17:12 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 3 Bug Zapper 2009-12-18 01:30:54 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.