Bug 465693 - Unable to browse network:/// through nautilus
Unable to browse network:/// through nautilus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-05 13:42 EDT by Shaopu Chiu
Modified: 2015-03-03 17:33 EST (History)
5 users (show)

See Also:
Fixed In Version: gvfs-1.0.1-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 08:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaopu Chiu 2008-10-05 13:42:59 EDT
Description of problem:
Unable to browse network:/// through nautilus.
It displayed:
 
Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.start nautilus
2.choose network on the left side
3.error message
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-10-06 11:46:50 EDT
This problem seems to be a combination of 

  fatal_mask = g_log_set_always_fatal (G_LOG_FATAL_MASK);
  fatal_mask |= G_LOG_LEVEL_WARNING | G_LOG_LEVEL_CRITICAL;
  g_log_set_always_fatal (fatal_mask);

in daemon-main.c and

              g_warning ("Couldn't create directory monitor on %s. Error: %s",
                         uri, error->message);

in gvfsbackendnetwork.c

Really, with that setup in daemon-main.c, we can never use g_warning at all in any daemon code.
Comment 2 Tomáš Bžatek 2008-10-07 08:54:28 EDT
This was accidentally left from the gvfs-obexftp-updated-apis-3.patch. Upstream is fine.

Fixed in gvfs-1.0.1-5.fc10.

Note You need to log in before you can comment on or make changes to this bug.