Bug 465695 - Smolt - web client
Smolt - web client
Status: CLOSED CURRENTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: l10n-requests (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dimitris Glezos
A S Alam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 14:21 EDT by Yaakov Nemoy
Modified: 2013-07-02 20:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 17:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Nemoy 2008-10-05 14:21:32 EDT
Module smoon
Description
smoon is the website front end to the smolt data
Project webpage
http://smolts.org/
http://smolt.fedorahosted.org/
VCS root, module, branch
http://git.fedorahosted.org/git/smolt.git
File filter (eg. <code>.*/po/.*</code>)
/smoon/locales/*
Note: we use the split directory folder that is parsable by gettext, not the flat directory for development.  This is due to an inherent limitation in Turbogears.  If you need this to be in any other format, let me know so I can hack something together.
Changelog file (if applicable)
Web front-end to VCS
http://git.fedorahosted.org/git/smolt.git
Comment 1 Dimitris Glezos 2008-10-05 18:14:52 EDT
Due to a limitation of the version the Fedora servers are running, we can't add two projects using the same (module, branch) combination.

I updated smolt's regular expression, though, to include the files of smoon:

.*/(smoon/locales|client/po)/.*

We only support new files being added in existing directories, for security reasons. I'm not sure if we should change that -- if yes, please open a ticket on http://transifex.org/ and/or drop by #transifex to talk about it.

For now, you can create the necessary empty directories of the style <lang>/LC_MESSAGES/ for the translators to be able to put files in them. Once that's in place, files can be submitted freely, and you can close the bug report.
Comment 2 Yaakov Nemoy 2008-10-07 12:59:01 EDT
For now, give me a list of languages that transifex currently supports, and i'll make the appropriate directories.

For the future, i'll file a nice bug report with Transifex :)

Please send in a test translation, so we can confirm that Transifex works.  (Feel free to mangle the NL translation for the time being, i will revert it.)

-Yaakov
Comment 3 Dimitris Glezos 2008-10-07 13:35:42 EDT
(In reply to comment #2)
> For now, give me a list of languages that transifex currently supports, and
> i'll make the appropriate directories.

To see the language codes we have in Fedora, you can take a look at:

http://translate.fedoraproject.org/languages/

> For the future, i'll file a nice bug report with Transifex :)

I'm happy to say that the new version we're developing (more about this in a few days) has lifted this limitation.

> Please send in a test translation, so we can confirm that Transifex works. 
> (Feel free to mangle the NL translation for the time being, i will revert it.)

https://hosted.fedoraproject.org/smolt/changeset/92e3d6fced96e987e87785829200d624c06d1b9a

Tx's submission layer supports any language, and any file basically. We just can't create arbitrary directories (eg. `mkdir -p`). If you'd like that feature, please _do_ open a ticket!

FWIW, translation statistics are another topic than submissions. In the version we're developing Tx has translation statistics support embedded, which currently has one stats extraction backend: POT-based projects, with `po/*po` files. Once published, I'd encourage a patch that adds a backend to extract statistics from `LC_MESSAGES/<lang>/<foo>.po` i18n architectures.
Comment 4 Yaakov Nemoy 2008-10-07 17:01:40 EDT
I got the commit.  I think we can close this bug.  I put two tickets in the Transifex trac though.

Note You need to log in before you can comment on or make changes to this bug.