Bug 465706 - When a problem arises during boot and you are forced into a shell the terminal is broken
Summary: When a problem arises during boot and you are forced into a shell the termina...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NEEDSRETESTING
Depends On:
Blocks: F10DesktopBlocker
TreeView+ depends on / blocked
 
Reported: 2008-10-05 20:14 UTC by Lennart Poettering
Modified: 2013-01-10 04:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-12 15:34:38 UTC
Type: ---


Attachments (Terms of Use)

Description Lennart Poettering 2008-10-05 20:14:32 UTC
When a problem arises during boot and you are forced into a shell (i.e. when one partition couldn't be mounted during boot) the terminal is broken. It seems as if plymouthd interferes with the terminal in some way that eats the cursor and only a part of the character typed reach the shell.

Comment 1 Ray Strode [halfline] 2008-10-06 19:43:48 UTC
This is actually most likely just another manfestation of bug 464216

Normally we do 

plymouth --hide-splash

before starting up the shell.  since plymouth depends on /usr being available it would fail and plymouth wouldn't give up the tty.

*** This bug has been marked as a duplicate of bug 464216 ***

Comment 2 Lennart Poettering 2008-10-10 20:35:19 UTC
Sorry, still doesn't work. The console goes completely bonkers when I switch to it by pressing Esc during the plymouth screen. When I press enter I get ^M on the screen. Not particularly helpful. Still no cursor.

Sorry, reopening.

plymouth-0.6.0-0.2008.10.08.1.fc10.i386

Comment 3 Gerd Hoffmann 2008-10-16 08:25:56 UTC
Booting with a serial console has simliar terminal/display issues (same bug?):

System boots up fine.  At some point in the middle of the boot process the cursor disappears and the cursor position seems to jump to the top of the screen, making following boot messages scribble over the previous ones.  Finally the login prompt appears, the cursor is still invisible.  Login works nevertheless.  Running the "reset" command brings the terminal back into normal state.

[root@fedora ~]# cat /proc/cmdline 
ro root=/dev/VolGroup00/LogVol00 console=ttyS0
[root@fedora ~]# rpm -q plymouth
plymouth-0.6.0-0.2008.10.08.2.fc10.i386

Comment 4 Ray Strode [halfline] 2008-10-30 21:52:10 UTC
Hi Gerd, your issue should already be fixed with latest rawhide.

Lennart, I believe your issue should be fixed by plymouth-0.6.0-0.2008.10.27.6.fc10

Can you confirm?

Comment 5 Lennart Poettering 2008-10-31 01:37:46 UTC
Sorry, still doesn't work with plymouth-0.6.0-0.2008.10.27.7.fc10.i386.

Comment 6 Lennart Poettering 2008-10-31 01:45:36 UTC
BTW, maybe I should mention than I only get the text-version of plymouth (intel gfx) -- that's where i press Esc. Also, when I press Esc early during bootup the hdd pasword stuff is completely borked -- you get a lot of erros about "partition not found" and then a root password prompt for a shell -- but of course you cannot type the password in, since your terminal is broken.

Also, at about half the boot the plymouth screen already reaches 100% and I am swicthed back to the classic boot screen with all those "... [done]" lines for the remaining half.

Comment 7 Ray Strode [halfline] 2008-10-31 01:48:08 UTC
sounds impressively broken

Comment 8 Gerd Hoffmann 2008-10-31 09:38:26 UTC
Re #4: yes, serial console works ok now.

Comment 9 Bill Nottingham 2008-11-04 18:57:36 UTC
Testing by forcing a drop to one of the emergency shelsl in rc.sysinit yields, for me:

- Text mode - echo works, cursor works (i.e., everything normal)
- GUI mode (solar) - echo works, no cursor (reset fixes the cursor)

plymouth-0.6.0-0.2008.10.30.2.fc10.x86_64
mkinitrd-6.0.69-1.fc10.x86_64

Comment 10 Ray Strode [halfline] 2008-11-05 16:14:44 UTC
which emergency shell?

What i did is:

echo "AUTOFSCK_SINGLEUSER=yes" >> /etc/sysconfig/autofsck
touch /.autofsck

sync

*pull power plug*

It brought me to an emergency shell and everything worked fine.

What am I doing differently than you?

Comment 11 Bill Nottingham 2008-11-05 16:27:46 UTC
(In reply to comment #10)
> which emergency shell?

The same one.

> What am I doing differently than you?

Dunno. I'm using vesafb for testing the GUI plymouth - that may be it.

Comment 12 Ray Strode [halfline] 2008-11-05 19:42:11 UTC
me too.

Comment 13 Ray Strode [halfline] 2008-11-10 22:01:28 UTC
The no cursor issue is fixed now along with some other issues with sulogin.  I don't know if lennart's original problem is fixed though (since I can't reproduce and haven't made any changes to that effect).

Lennart, mind trying with the latest version?

Comment 14 Ray Strode [halfline] 2008-11-10 22:02:37 UTC
(by latest i mean plymouth-0.6.0-0.2008.11.10.4 or later)

Comment 15 Jesse Keating 2008-11-10 22:09:10 UTC
plymouth-0.6.0-0.2008.11.10.5.fc10 will be tagged today, I'd like it if everybody involved re-tests this issue and see if it still shows up.

Comment 16 Ray Strode [halfline] 2008-11-12 15:34:38 UTC
I'm going to close this out.  Lennart, if you're still seeing the original problem, please reopen. 

If the other issues you mentioned in comment 6 didn't get independently fixed in the interim, please file separate reports for those issues.


Note You need to log in before you can comment on or make changes to this bug.