Bug 465707 - Starting up X locks up my machine
Starting up X locks up my machine
Status: CLOSED DUPLICATE of bug 464866
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-05 16:22 EDT by Lennart Poettering
Modified: 2008-11-04 13:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 13:38:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.0.log (53.25 KB, text/plain)
2008-10-05 16:22 EDT, Lennart Poettering
no flags Details
New xorg.0.log (128.06 KB, text/plain)
2008-10-30 21:51 EDT, Lennart Poettering
no flags Details
xorg.conf (663 bytes, text/plain)
2008-10-30 21:52 EDT, Lennart Poettering
no flags Details
/proc/bus/input/devices (3.30 KB, text/plain)
2008-10-30 21:55 EDT, Lennart Poettering
no flags Details

  None (edit)
Description Lennart Poettering 2008-10-05 16:22:10 EDT
Created attachment 319501 [details]
xorg.0.log

When I start up X on my machine the machine locks up entirely.

If this happens with gdm all you see is a gray frame where the login window should be and then things are frozen. The animated cursors before that is shown properly however.

If you start X from the console by typing "X" it freezes right-away.

This is "Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)".

xorg-x11-drv-i810-2.4.2-9.fc10.i386
Comment 1 Bill Nottingham 2008-10-27 16:30:12 EDT
Any improvements with new rawhide kernel/intel 2.5.0 driver?
Comment 2 Lennart Poettering 2008-10-30 21:50:23 EDT
The problem is still unchanged even with current rawhide.

But, I now get a differnt Xorg.0.log output. Will attach. It seems to suggest that this is not actually a problem of the intel driver, but of evdev instead. Also, the machine is not completely locked up. Logging in via ssh still works.

When I switch to the "vesa" driver the problem goes away.

I'll also attache my xorg.conf.
Comment 3 Lennart Poettering 2008-10-30 21:51:23 EDT
Created attachment 322011 [details]
New xorg.0.log
Comment 4 Lennart Poettering 2008-10-30 21:52:35 EDT
Created attachment 322012 [details]
xorg.conf
Comment 5 Lennart Poettering 2008-10-30 21:54:29 EDT
/me wonders if that has anything to do with the "Video Bus" devices showing up as input devices in /proc/bus/input/devices. I'll attach a dump.
Comment 6 Lennart Poettering 2008-10-30 21:55:16 EDT
Created attachment 322013 [details]
/proc/bus/input/devices
Comment 7 Bill Nottingham 2008-10-31 12:23:51 EDT
CC'ing evdev guru.
Comment 8 Peter Hutterer 2008-11-02 18:41:45 EST
nope, this isn't evdev. what happens is that the graphics driver hogs the server, so all input events that are processed during SIGIO are appended to the event queue but never removed.
After a while, the EQ starts overflowing - causing all these warnings and the backtrace (for debugging).

So these warnings mean that the evdev driver still works happily, but the graphics driver doesn't.
Comment 9 Bill Nottingham 2008-11-04 13:38:47 EST
This appears to be a dup of a different i945 bug - there is a test package listed in that bug to try.

*** This bug has been marked as a duplicate of bug 464866 ***

Note You need to log in before you can comment on or make changes to this bug.