Bug 465717 - make pdf-en-US does not include all books in a set
make pdf-en-US does not include all books in a set
Status: CLOSED DEFERRED
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 20:16 EDT by Jeroen van Meeuwen
Modified: 2010-11-23 23:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 19:06:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Resulting PDF file (83.28 KB, application/octet-stream)
2008-10-05 20:18 EDT, Jeroen van Meeuwen
no flags Details

  None (edit)
Description Jeroen van Meeuwen 2008-10-05 20:16:26 EDT
Description of problem:

make pdf-en-US does not include all books in a set

Version-Release number of selected component (if applicable):

publican-fedora-0.15-0.fc9.noarch
publican-0.37-0.fc9.noarch

How reproducible:


Steps to Reproduce:
1. git clone git://git.fedorahosted.org/courses.git
2. cd courses
3. make pdf-en-US
  
Actual results:

10-page PDF file with only the first book

Expected results:

114+ -page PDF with all books

Additional info:
Comment 1 Jeroen van Meeuwen 2008-10-05 20:18:40 EDT
Created attachment 319512 [details]
Resulting PDF file
Comment 2 Jeff Fearn 2008-10-09 02:39:56 EDT
Hi Jeroen, I am pretty sure there are two issues with your XML.

Firstly you are mixing book and set at the same level within a set. This is not supported by DocBook, although due to limitations in how DTDs work it can't be validated by xmllint.

This is why the content doesn't appear as expected.

Once you fix that issue, by putting the first book in a set or by moving the following books out of sets, another issue is revealed.

Secondly you have seglists with more than two columns (segtitles etc). This is not valid when the seglist is being displayed as a table, which is how publican displays seglists. This can not be validated by xmllint either :(

Note that I had to troll through the DocBook XSL to find out this limitation, it doesn't seem to be documented anywhere :(
Comment 3 Jeroen van Meeuwen 2008-10-11 15:14:48 EDT
OK,

- getting the first book within a set does resolve the issue but does not give the desired result/layout, so I guess I'll have to find some other way to make/build the collection of books, I'm fine with that.

- What other then a segmentedlist you recommend I use if a table has more then 2 columns?
Comment 4 Jeroen van Meeuwen 2008-10-16 19:06:01 EDT
Closing deferred

Note You need to log in before you can comment on or make changes to this bug.