Bug 465757 - gstreamer or pulseaudio adds terrible amount of noise making it
gstreamer or pulseaudio adds terrible amount of noise making it
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-06 05:22 EDT by Matěj Cepl
Modified: 2008-11-06 08:57 EST (History)
7 users (show)

See Also:
Fixed In Version: gstreamer-plugins-good-0.10.10-5.fc1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 08:57:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
debug log when playing the WAV file via gst-launch (1.36 MB, application/x-bzip2)
2008-10-06 05:22 EDT, Matěj Cepl
no flags Details
debug log when converting ogg to wav (1.31 MB, application/x-bzip2)
2008-10-06 05:23 EDT, Matěj Cepl
no flags Details
original OGG sound (102.30 KB, application/ogg)
2008-10-06 05:25 EDT, Matěj Cepl
no flags Details
what I get from gst-launch (1.30 MB, audio/x-wav)
2008-10-06 05:26 EDT, Matěj Cepl
no flags Details
what I get from ogg123 -- how it should sound like (1.30 MB, audio/x-wav)
2008-10-06 05:28 EDT, Matěj Cepl
no flags Details
/var/log/messages (553.50 KB, text/plain)
2008-10-07 09:42 EDT, Matěj Cepl
no flags Details
output of gst-launch -v playbin uri=$(curl -s http://www.wbur.org/listen/feed/ogg.m3u) (43.08 KB, text/plain)
2008-10-17 08:44 EDT, Matěj Cepl
no flags Details
gst-launch -v souphttpsrc location=$(curl -s http://www.wbur.org/listen/feed/ogg.m3u) '!' decodebin '!' audioconvert '!' audioresample '!' alsasink (2.37 KB, text/plain)
2008-10-17 08:47 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-10-06 05:22:24 EDT
Created attachment 319532 [details]
debug log when playing the WAV file via gst-launch

Description of problem:
Tried to play my music with Rhythmbox and the level of noise much bigger than actual sound, so that it is actually unusable. In order to find out where is the problem, I have tried with gst-launch and the results are interesting. I have tried also to play the same file with mplayer (using PA) and playing wav files with paplay and both work just fine without any problems.

When trying to play the same MP3 file with gst-launch

$ gst-launch filesrc location=Ubuntu-startup.ogg '!' \
  decodebin '!' audioconvert '!' audioresample '!' pulsesink

I got gst-launch-log.txt (to be attached), and no sound. Without debugging information it says just:

[matej@viklef gst-sounds]$ LANG=en_IE.utf-8 gst-launch filesrc location=Ubuntu-startup.ogg '!' decodebin '!' audioconvert '!' audioresample '!' autoaudiosink
Setting pipeline to PAUSED ...
E: shm.c: shm_open() failed: Permission denied
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "pipeline0".
Execution ended after 8113381349 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
FREEING pipeline ...
[matej@viklef gst-sounds]$ 

CPU goes to 100% for couple of seconds and then it just finished with making some one-sec-or-so sound but nothing else.

Interesting thing was when trying to convert to WAV with gst:

gst-launch filesrc location=Ubuntu-startup.ogg '!' decodebin '!' audioconvert '!' audioresample '!' progressreport '!' audio/x-raw-int,rate=44100,channels=1 '!' volume volume=5 '!' wavenc '!' filesink location=Ubuntu-startup-gst.wav >gst-launch-log.txt 2>&1

the resulting sound is MUCH better (guessing by playing with paplay) than what happened in Rhythmbox, but still it is by far not as perfect as the result of ogg123. (ogg123 playing to -d oss with padsp or without any device at all -- which I guess means alsa-pulse-plugins -- works just as perfectly).

Version-Release number of selected component (if applicable):
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
gstreamer-tools-0.10.21-1.fc10.i386
gstreamer-python-0.10.12-1.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-plugins-good-devel-0.10.10-4.fc10.i386
gstreamer-plugins-farsight-0.12.9-3.fc10.i386
gstreamer-devel-0.10.21-1.fc10.i386
gstreamer-pitfdll-0.9.1.1-1.cvs20071027.fc8.i386
gstreamer-ffmpeg-debuginfo-0.10.4-1.lvn10.i386
gstreamer-debuginfo-0.10.21-1.fc10.i386
gstreamer-plugins-good-0.10.10-4.fc10.i386
gstreamer-plugins-schroedinger-1.0.5-3.fc10.i386
totem-gstreamer-2.24.1-1.fc10.i386
gstreamer-plugins-ugly-0.10.8-1.lvn9.i386
gstreamer-plugins-bad-0.10.7-1.lvn9.i386
gstreamer-0.10.21-1.fc10.i386
gstreamer-plugins-bad-devel-0.10.7-1.lvn9.i386
gstreamer-ffmpeg-0.10.4-1.lvn9.i386
gstreamer-plugins-base-devel-0.10.21-2.fc10.i386
gstreamer-pitfdll-debuginfo-0.9.1.1-1.cvs20071027.fc8.i386
vorbis-tools-1.2.0-2.fc10.i386
pulseaudio-libs-0.9.12-6.fc10.i386
pulseaudio-module-x11-0.9.12-6.fc10.i386
pulseaudio-libs-glib2-0.9.12-6.fc10.i386
pulseaudio-debuginfo-0.9.12-6.fc10.i386
pulseaudio-module-bluetooth-0.9.12-6.fc10.i386
pulseaudio-core-libs-0.9.12-6.fc10.i386
pulseaudio-utils-0.9.12-6.fc10.i386
pulseaudio-0.9.12-6.fc10.i386
pulseaudio-esound-compat-0.9.12-6.fc10.i386
pulseaudio-libs-zeroconf-0.9.12-6.fc10.i386
pulseaudio-module-jack-0.9.12-6.fc10.i386
pulseaudio-module-zeroconf-0.9.12-6.fc10.i386
pulseaudio-module-lirc-0.9.12-6.fc10.i386
pulseaudio-libs-devel-0.9.12-6.fc10.i386
pulseaudio-module-gconf-0.9.12-6.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
almost unusable

Expected results:
nice crisp sound as with ogg123+paplay

Additional info:
Comment 1 Matěj Cepl 2008-10-06 05:23:52 EDT
Created attachment 319533 [details]
debug log when converting ogg to wav
Comment 2 Matěj Cepl 2008-10-06 05:25:24 EDT
Created attachment 319534 [details]
original OGG sound
Comment 3 Matěj Cepl 2008-10-06 05:26:47 EDT
Created attachment 319535 [details]
what I get from gst-launch
Comment 4 Matěj Cepl 2008-10-06 05:28:30 EDT
Created attachment 319536 [details]
what I get from ogg123 -- how it should sound like
Comment 5 Matěj Cepl 2008-10-06 05:40:41 EDT
Just to emphasize this is "Intel(R) Core(TM)2 Duo CPU     T7300  @ 2.00GHz" -- so there should be plenty of horsepower for playing WAV files ;-).
Comment 6 Matěj Cepl 2008-10-07 09:26:51 EDT
Either pulseaudio-0.9.12-6.fc10 or 
gstreamer-plugins-good-0.10.10-5.fc10 just made this work. Weird.
Comment 7 Matěj Cepl 2008-10-07 09:36:08 EDT
OK, so this is probably pulseaudio, reassigning and reopening.
Comment 8 Matěj Cepl 2008-10-07 09:42:42 EDT
Created attachment 319640 [details]
/var/log/messages

OK, so this looks like a problem in pulseaudio. After rebooting of the computer with new pulseaudio (currently I have pulseaudio-libs-0.9.13-1.fc10.i386) and gstreamer-plugins-good (I have gstreamer-plugins-good-0.10.10-5.fc10.i386 now), everything seemed to work. However, after playing a podcast for couple of minutes in Rhythmbox, I lost the sound and rhythmbox process went to 100% CPU. I killed RB and since then no GStreamer based application is able to play anything. mplayer (with pa backend) still works like a charm.
Comment 9 Yijun Yuan 2008-10-13 20:20:37 EDT
play something with "padsp realplay", after 35 or 36 minutes playing, the sound stops while the pictures are still moving fine. When it is played to the end, "padsp realplay" crashes. Sound comes back if run "padsp realplay" again. Is this a same problem?
Comment 10 Matěj Cepl 2008-10-17 08:42:52 EDT
Still not working. Trying with

$ gst-launch playbin uri=$(curl -s http://www.wbur.org/listen/feed/ogg.m3u)

produces 100% garbage in the speakers.

[matej@viklef tmp]$ rpm -qa \*pulse\* \*gstreamer\*
pulseaudio-module-lirc-0.9.13-2.fc10.i386
totem-gstreamer-2.24.2-2.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
gstreamer-plugins-schroedinger-1.0.5-3.fc10.i386
pulseaudio-core-libs-0.9.13-2.fc10.i386
pulseaudio-libs-devel-0.9.13-2.fc10.i386
gstreamer-plugins-base-devel-0.10.21-2.fc10.i386
pulseaudio-module-x11-0.9.13-2.fc10.i386
pulseaudio-esound-compat-0.9.13-2.fc10.i386
gstreamer-plugins-farsight-0.12.9-3.fc10.i386
pulseaudio-libs-zeroconf-0.9.13-2.fc10.i386
pulseaudio-debuginfo-0.9.13-2.fc10.i386
gstreamer-plugins-good-devel-0.10.10-5.fc10.i386
gstreamer-pitfdll-0.9.1.1-1.cvs20071027.fc8.i386
pulseaudio-0.9.13-2.fc10.i386
gstreamer-tools-0.10.21-1.fc10.i386
gstreamer-plugins-good-0.10.10-5.fc10.i386
pulseaudio-module-zeroconf-0.9.13-2.fc10.i386
gstreamer-pitfdll-debuginfo-0.9.1.1-1.cvs20071027.fc8.i386
pulseaudio-module-gconf-0.9.13-2.fc10.i386
pulseaudio-module-bluetooth-0.9.13-2.fc10.i386
pulseaudio-module-jack-0.9.13-2.fc10.i386
pulseaudio-libs-glib2-0.9.13-2.fc10.i386
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.i386
gstreamer-devel-0.10.21-1.fc10.i386
pulseaudio-utils-0.9.13-2.fc10.i386
gstreamer-ffmpeg-debuginfo-0.10.4-1.lvn10.i386
pulseaudio-libs-0.9.13-2.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-ffmpeg-0.10.4-1.lvn9.i386
gstreamer-debuginfo-0.10.21-1.fc10.i386
gstreamer-plugins-ugly-0.10.8-1.lvn9.i386
gstreamer-python-0.10.12-1.fc10.i386
gstreamer-0.10.21-1.fc10.i386

mplayer, and lonely paplay works just fine.
Comment 11 Matěj Cepl 2008-10-17 08:44:54 EDT
Created attachment 320657 [details]
output of gst-launch -v playbin uri=$(curl -s http://www.wbur.org/listen/feed/ogg.m3u)

This sounds absolutely terrible
Comment 12 Matěj Cepl 2008-10-17 08:47:25 EDT
Created attachment 320658 [details]
gst-launch -v souphttpsrc location=$(curl -s http://www.wbur.org/listen/feed/ogg.m3u) '!'   decodebin '!' audioconvert '!' audioresample '!' alsasink

Actually, this is not a perfect but sounds well enough to be listenable. So, maybe it is something about PulseAudio anyway.
Comment 13 Bill Nottingham 2008-11-05 16:49:30 EST
We've updated PulseAudio recently - can you retest?
Comment 14 Matěj Cepl 2008-11-06 08:57:40 EST
Sorry, this has been fixed sometime ago.

Note You need to log in before you can comment on or make changes to this bug.