Bug 465763 - Dual Head configuration doesn't works in control-center / gnome-display-properties
Dual Head configuration doesn't works in control-center / gnome-display-prope...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 05:51 EDT by Juraci Paixão Kröhling
Modified: 2009-05-12 10:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 10:37:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (1.76 KB, text/plain)
2008-10-27 06:25 EDT, Juraci Paixão Kröhling
no flags Details
Xorg.0.log file with the bug, without any xorg.conf file. (237.34 KB, text/plain)
2008-10-27 06:28 EDT, Juraci Paixão Kröhling
no flags Details
Xorg.0.log file with the bug, using xorg.conf file (233.96 KB, text/plain)
2008-10-27 06:48 EDT, Juraci Paixão Kröhling
no flags Details
sticky displays (581.12 KB, image/png)
2009-01-07 04:39 EST, Alexey Kuznetsov
no flags Details
disabled screen (26.11 KB, image/png)
2009-01-07 04:40 EST, Alexey Kuznetsov
no flags Details

  None (edit)
Description Juraci Paixão Kröhling 2008-10-06 05:51:21 EDT
Description of problem:
Dual Head configuration doesn't works in control-center / gnome-display-properties . When adding a "Virtual 2720 1024" into Screen/Display in xorg.conf it starts to work as expected. 

Hardware: Lenovo T61 + Samsung 943n monitor, using both as display devices.

Version-Release number of selected component (if applicable):
control-center-2.24.0.1-4.fc10.x86_64 (and previous)
xorg-x11-server-Xorg-1.5.1-4.fc10.x86_64 (with no xorg.conf)

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-display-properties
2. Uncheck the "mirror screens" option
3. Adjust the two monitors at your wish
4. Hit Apply - Nothing happens
5. Restart X - Same settings as previous
6. Re-open gnome-display-properties - The old configuration is there
  
Actual results:
The changes are not persisted. 

Expected results:
On step 4, X would refresh with the two screens acting as dual head.

Additional info:
I guess that the trick here is to check/add a "SubSection Display" with "Virtual x y", where x and y are appropriate to the resolution the user chosen when clicking on "Apply". I'm not sure, however, what to do if no xorg.conf file is present (i.e.: automatic configurations are being used).

Also, this bug report is probably a duplicate of others, but I could only find bugs opened as Fedora 9. I was not sure whether I would open a new one or edit an existing report.
Comment 1 Matěj Cepl 2008-10-26 18:13:30 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Juraci Paixão Kröhling 2008-10-27 06:25:56 EDT
Created attachment 321596 [details]
xorg.conf file 

This is the conf file which *works*. The version which *doesn't works* is the same, but without the "SubSection Display" part, inside Screen0.
Comment 3 Juraci Paixão Kröhling 2008-10-27 06:28:11 EDT
Created attachment 321597 [details]
Xorg.0.log file with the bug, without any xorg.conf file. 

Attached Xorg.0.log file related to the session with "mirrored" screens (ie: with the bug).
Comment 4 Juraci Paixão Kröhling 2008-10-27 06:48:22 EDT
Created attachment 321599 [details]
Xorg.0.log file with the bug, using xorg.conf file

Xorg.0.log file for a "mirrored" screen with the attached xorg.conf file, without the SubSection Display part. The bug is present in the session.
Comment 5 Bug Zapper 2008-11-25 22:36:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Nicolas Troncoso Carrere 2008-11-30 10:43:36 EST
I'm seing a similar issue with KDE display setting on a macbook pro. When conecting an aditional monitor on the DVI output it is detected correctly, but it just clones the output.

Modifying the layout and applying does not work.

Finally i used a custom xorg.conf and once i boot i have to apply the folowing:
xrandr --output LVDS --auto
xrandr --output DVI-0 --auto
xrandr --output DVI-0 --right-of LVDS

which does the trick.

Please advice if additional info is required.
Comment 7 Alexey Kuznetsov 2009-01-07 04:39:28 EST
Created attachment 328357 [details]
sticky displays

sticky displays, you can see two displays sticky  on one display. that run done without xorg.conf. second monitor connected at boot time
Comment 8 Alexey Kuznetsov 2009-01-07 04:40:35 EST
Created attachment 328358 [details]
disabled screen

disabled screen, you can not enable second screen, after enabling setting rolling back. that run done without xorg.conf. second monitor connected after login
Comment 9 Alexey Kuznetsov 2009-03-14 09:02:25 EDT
that is not related to -i810 driver, same for -ati (x1600 ati card). please update component to xrandr or similar.
Comment 10 Matías Kreder 2009-04-23 19:50:14 EDT
any news on this bug? I'm experiencing the same problem with a t61 also, please let me know if you have additional information
Comment 11 Matías Kreder 2009-04-24 12:18:14 EDT
I avoid this problem running:

xrandr --output LVDS --auto
xrandr --output VGA --auto
xrandr --output VGA --right-of LVDS

and adding this to xorg.conf:

-----------------------------------
Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Virtual 2464 900 
	EndSubSection
EndSection

------------------------------------

adding 'Virtual 2464 900' works, but then you should restart X.. and that's not the idea here.. 
and also I can not change the resolution of the VGA output to something better than 1024x768
Comment 12 Alexey Kuznetsov 2009-05-12 08:48:41 EDT
seems fixed in f11-rc
Comment 13 Matěj Cepl 2009-05-12 10:37:09 EDT
OK, I don't have high hopes this will be fixed for F10. Closing as NEXTRELEASE

Note You need to log in before you can comment on or make changes to this bug.