Bug 465794 - problem setting MTU > 1500 to bridge devices
problem setting MTU > 1500 to bridge devices
Status: CLOSED DUPLICATE of bug 463014
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.2
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 09:28 EDT by Nenad Opsenica
Modified: 2008-10-07 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 10:39:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
set MTU on interface before adding to bridge. (689 bytes, patch)
2008-10-06 09:28 EDT, Nenad Opsenica
no flags Details | Diff

  None (edit)
Description Nenad Opsenica 2008-10-06 09:28:41 EDT
Created attachment 319552 [details]
set MTU on interface before adding to bridge.

Description of problem:

When bringing up interface (with ifup or service network start) which has MTU>1500 set in ifcfg-ethX file, but is also a part of some bridge device (BRIDGE=br0), MTU on ethX is not set to specified value. As a result, MTU of whole bridge device remains 1500.


Version-Release number of selected component (if applicable):

initscripts-8.45.19.1.EL-1.el5

How reproducible:

Easy.


Steps to Reproduce:
1. Configure ethX interface (file /etc/sysconfig/network-scripts/ifcfg-ethX) with
MTU=8000
BRIDGE=br0

ethX has to be GigE interface in order to increase MTU.

2. Configure br0 interface (file /etc/sysconfig/network-scripts/ifcfg-br0) 

3. bring up ethX and br0

  
Actual results:

MTU on ethX and br0 is 1500


Expected results:

MTU on ethX and br0 should be 8000


Additional info:

Attached patch solves this problem - MTU is explicitly set to specified value before adding ethX to bridge.
Comment 1 Bill Nottingham 2008-10-07 10:39:05 EDT
Not exactly a duplicate of 463014, but the patch there will solve it. Marking as a duplicate.

*** This bug has been marked as a duplicate of bug 463014 ***

Note You need to log in before you can comment on or make changes to this bug.