Bug 465796 - Apache process SizeLimit reached during rhnpush
Apache process SizeLimit reached during rhnpush
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Clifford Perry
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-10-06 09:38 EDT by Aidan Delaney
Modified: 2009-09-17 03:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 485532 (view as bug list)
Environment:
Last Closed: 2009-09-17 03:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Apache error_log (4.07 KB, text/plain)
2008-10-06 09:38 EDT, Aidan Delaney
no flags Details
Apache access_log (20.10 KB, text/plain)
2008-10-06 09:44 EDT, Aidan Delaney
no flags Details

  None (edit)
Description Aidan Delaney 2008-10-06 09:38:21 EDT
Created attachment 319553 [details]
Apache error_log

Description of problem:
When I run rhnpush to add packages to channels the process takes a _long_ time.  Looking at the logs it appears that apache processes are being killed as they grow larger than the 400,000kb limit in /etc/rhn/satellite-httpd/conf/startup.pl

How reproducible:
Execute the following rhnpush (on pretty much any rpm file)
echo foo.rpm | rhnpush --server http://localhsot/APP --channel=fedora-9-ppc64 -u space -p space -v --tolerant

Actual results:
An error appears in the error_log file.

Expected results:
I'd expect no errors.  This may also be the cause of the slowdown I've been experiencing.

Additional info:
Running on a CentOS 5.2 KVM VM with 1Gb RAM.
Comment 1 Aidan Delaney 2008-10-06 09:44:10 EDT
Created attachment 319556 [details]
Apache access_log
Comment 2 Frank Ederveen 2008-12-26 19:51:06 EST
Hi, just wanted to let you know that I was having exactly the same problem: rhnpush was causing httpd processes to respawn a lot.

[Fri Dec 26 10:01:06 2008] (2022) Apache2::SizeLimit httpd process too big, exiting at SIZE=526616 KB  SHARE=13580 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Dec 26 10:01:08 2008] (2034) Apache2::SizeLimit httpd process too big, exiting at SIZE=526708 KB  SHARE=13548 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Dec 26 10:01:13 2008] (2044) Apache2::SizeLimit httpd process too big, exiting at SIZE=526708 KB  SHARE=13548 KB  REQUESTS=2 LIFETIME=0 seconds
...

After editing: /etc/rhn/satellite-httpd/conf/startup.pl and changing the MAX_PROCESS_SIZE to 800_000 instead of 400_000, everything works much quicker and without errors.

This is in a git-build version, checked out on 26/12/2008.

Regards,

Frank
Comment 6 Jesus M. Rodriguez 2009-03-25 13:26:53 EDT
fixed in commit 9ee8820ac7e71029f9d78e77234d3b8b6f0b757a

removed usage of Apache::SizeLimit and switched to using
MaxRequestsPerChild instead. Currently set to 200.
Comment 7 Jesus M. Rodriguez 2009-04-14 10:11:36 EDT
Spacewalk 0.5 released.
Comment 8 Dane Butler 2009-09-04 00:57:29 EDT
Problem discovered in Satellite 5.2 as well (x86_64 RHEL5.3)

[Fri Sep  4 14:43:59 2009] (11457) Apache2::SizeLimit httpd process too big, exiting at SIZE=496704/400000 KB  SHARE=12644/0 KB  UNSHARED=484060/0 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Sep  4 14:44:09 2009] (11322) Apache2::SizeLimit httpd process too big, exiting at SIZE=542212/400000 KB  SHARE=14500/0 KB  UNSHARED=527712/0 KB  REQUESTS=3 LIFETIME=31 seconds
[Fri Sep  4 14:44:18 2009] (11522) Apache2::SizeLimit httpd process too big, exiting at SIZE=469196/400000 KB  SHARE=12044/0 KB  UNSHARED=457152/0 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Sep  4 14:44:20 2009] (11418) Apache2::SizeLimit httpd process too big, exiting at SIZE=548132/400000 KB  SHARE=14468/0 KB  UNSHARED=533664/0 KB  REQUESTS=3 LIFETIME=21 seconds
[Fri Sep  4 14:44:29 2009] (11630) Apache2::SizeLimit httpd process too big, exiting at SIZE=469196/400000 KB  SHARE=12044/0 KB  UNSHARED=457152/0 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Sep  4 14:44:30 2009] (11635) Apache2::SizeLimit httpd process too big, exiting at SIZE=538992/400000 KB  SHARE=13996/0 KB  UNSHARED=524996/0 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Sep  4 14:44:40 2009] (11636) Apache2::SizeLimit httpd process too big, exiting at SIZE=538992/400000 KB  SHARE=13992/0 KB  UNSHARED=525000/0 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Sep  4 14:44:44 2009] (11682) Apache2::SizeLimit httpd process too big, exiting at SIZE=469196/400000 KB  SHARE=12044/0 KB  UNSHARED=457152/0 KB  REQUESTS=2 LIFETIME=0 seconds
[Fri Sep  4 14:44:50 2009] (11695) Apache2::SizeLimit httpd process too big, exiting at SIZE=539252/400000 KB  SHARE=13988/0 KB  UNSHARED=525264/0 KB  REQUESTS=2 LIFETIME=0 seconds
Comment 9 Miroslav Suchý 2009-09-17 03:08:24 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.