Bug 465801 - issues when bridging bond devices
issues when bridging bond devices
Status: CLOSED DUPLICATE of bug 463014
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.2
All Linux
medium Severity high
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 09:48 EDT by Nenad Opsenica
Modified: 2008-10-07 10:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 10:41:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
change order of IF initialization when dealing with bridged bond devices (4.84 KB, patch)
2008-10-06 09:48 EDT, Nenad Opsenica
no flags Details | Diff

  None (edit)
Description Nenad Opsenica 2008-10-06 09:48:48 EDT
Created attachment 319558 [details]
change order of IF initialization when dealing with bridged bond devices

Description of problem:

I tried to bridge bond device, but it was not possible as order of bringing up devices is wrong:
- unable to add bond0 device to br0 (because bond0 has no slaves at the moment)
- after manual interface configuration, unable to bring down bond0 device because bond0 still has slaves.


Version-Release number of selected component (if applicable):

initscripts-8.45.19.1.EL-1.el5


How reproducible:

Easy

Steps to Reproduce:
1. Configure eth, bond and br interfaces:

# cat ifcfg-bond0
DEVICE=bond0
BOOTPROTO=none
BRIDGE=br0
NOZEROCONF=yes
ONBOOT=yes
BONDING_OPTS="mode=1 miimon=100 primary=eth0"

# cat ifcfg-br0
DEVICE=br0
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.1
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
NETMASK=255.255.255.0
NOZEROCONF=yes
ONBOOT=yes
GATEWAY=192.168.1.254

# cat ifcfg-eth0
DEVICE=eth0
HWADDR=00:90:27:0d:2b:54
BOOTPROTO=none
NOZEROCONF=yes
ONBOOT=yes
MASTER=bond0
SLAVE=yes


# cat ifcfg-eth3
DEVICE=eth3
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:50:8b:63:35:eb
MASTER=bond0
SLAVE=yes

2. Try to bring them up (or restart network):

Bringing up interface bond0:  can't add bond0 to bridge br0: Invalid argument [  OK  ]

# brctl show
bridge name     bridge id               STP enabled     interfaces
br0             8000.000000000000       no


Additional info:

Attached patch changes order of interface initialization, and solves this problem.
Comment 1 Bill Nottingham 2008-10-07 10:41:22 EDT

*** This bug has been marked as a duplicate of bug 463014 ***

Note You need to log in before you can comment on or make changes to this bug.