Bug 465833 - api.getVersion return value includes string "Java"
api.getVersion return value includes string "Java"
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: API (Show other bugs)
0.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Brad Buckingham
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-10-06 12:28 EDT by Rob James
Modified: 2009-02-24 14:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 14:08:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob James 2008-10-06 12:28:42 EDT
The return value of api.getVersion contains the string "Java" (e.g. "0.2 Java") which was apparently historically to be able to tell the difference between the old style (Perl?) and new style stuff. Since this is apparently ancient history it should probably be removed (and it's not documented in the api docs either).
Comment 1 Jesus M. Rodriguez 2009-01-16 20:17:57 EST
Verify that getVersion no longer returns "Java", and close the bug.
Comment 2 Jesus M. Rodriguez 2009-02-24 14:08:59 EST
api.getVersion() returns the value of 'web.apiversion' as defined in
/etc/rhn/defaults/rhn_web.conf

See bug #472346 for more information.

Note You need to log in before you can comment on or make changes to this bug.