Bug 46585 - Internal compiler error when attempting to compile avifile-0.53.5 (available via sourceforge)
Internal compiler error when attempting to compile avifile-0.53.5 (available ...
Status: CLOSED DUPLICATE of bug 38131
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-29 08:39 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-29 08:39:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 95)

Description of problem:
On compiling avifile-0.53.5 (available via sourceforge) I get the 
following error:

Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [win32.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

How reproducible:
Always

Steps to Reproduce:
1. Download avifile source via sourceforge
2. Configure
3. attempt to compile
	

Actual Results:  Full results from a > to a text file are shown below.

Making all in include
make[1]: Entering directory `/usr/src/redhat/SOURCES/avifile-
0.53.5/include'
make  all-recursive
make[2]: Entering directory `/usr/src/redhat/SOURCES/avifile-
0.53.5/include'
Making all in wine
make[3]: Entering directory 
`/usr/src/redhat/SOURCES/avifile-0.53.5/include/wine'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory 
`/usr/src/redhat/SOURCES/avifile-0.53.5/include/wine'
make[3]: Entering directory `/usr/src/redhat/SOURCES/avifile-
0.53.5/include'
make[3]: Leaving directory `/usr/src/redhat/SOURCES/avifile-0.53.5/include'
make[2]: Leaving directory `/usr/src/redhat/SOURCES/avifile-0.53.5/include'
make[1]: Leaving directory `/usr/src/redhat/SOURCES/avifile-0.53.5/include'
Making all in lib
make[1]: Entering directory `/usr/src/redhat/SOURCES/avifile-0.53.5/lib'
Making all in loader
make[2]: Entering directory 
`/usr/src/redhat/SOURCES/avifile-0.53.5/lib/loader'
/bin/sh ../../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. 
-I. -I../../include   -g  -march=i586 -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT -w  -I../../include 
-DWIN32_PATH=\"/usr/lib/win32\" -D__WINE__ -Ddbg_printf=__vprintf 
-DTRACE=__vprintf -fno-omit-frame-pointer -fno-inline -c pe_image.c
/bin/sh ../../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. 
-I. -I../../include   -g  -march=i586 -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT -w  -I../../include 
-DWIN32_PATH=\"/usr/lib/win32\" -D__WINE__ -Ddbg_printf=__vprintf 
-DTRACE=__vprintf -fno-omit-frame-pointer -fno-inline -c module.c
/bin/sh ../../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. 
-I. -I../../include   -g  -march=i586 -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT -w  -I../../include 
-DWIN32_PATH=\"/usr/lib/win32\" -D__WINE__ -Ddbg_printf=__vprintf 
-DTRACE=__vprintf -fno-omit-frame-pointer -fno-inline -c ext.c
/bin/sh ../../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. 
-I. -I../../include   -g  -march=i586 -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT -w  -I../../include 
-DWIN32_PATH=\"/usr/lib/win32\" -D__WINE__ -Ddbg_printf=__vprintf 
-DTRACE=__vprintf -fno-omit-frame-pointer -fno-inline -c win32.c
make[2]: Leaving directory 
`/usr/src/redhat/SOURCES/avifile-0.53.5/lib/loader'
make[1]: Leaving directory `/usr/src/redhat/SOURCES/avifile-0.53.5/lib'


Expected Results:  I'd hope that it would compile :o(

Additional info:

The version number of my compiler is shown below.

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-85)
Comment 1 Richard Henderson 2004-10-01 18:55:27 EDT

*** This bug has been marked as a duplicate of 38131 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.