Bug 465852 - XDG_SESSION_COOKIE not set
XDG_SESSION_COOKIE not set
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 14:01 EDT by Michael J. Chudobiak
Modified: 2015-01-14 18:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 15:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2008-10-06 14:01:39 EDT
My systems do not seem to set XDG_SESSION_COOKIE properly, resulting in:

[mjc@xena etc]$ env | grep XDG
[mjc@xena etc]$ ck-list-sessions 
[mjc@xena etc]$ 

That is, ConsoleKit is not working, and thus plug-in storage devices (thumb drives, cameras, etc) are not working.

My use files are located on /fileserver/home, rather than /home. /fileserver is nfsv4 mounted. So, in /etc/passwd I have:

mjc:x:500:512:Dr. Michael J. Chudobiak:/fileserver/home/mjc:/bin/bash

and in /etc/fstab I have:

192.168.0.3:/ /fileserver nfs4 intr,suid,dev,soft,exec 0 0

However, establishing a local test user (on /home) seems to produce the same behaviour.

I would really love some help with this...


- Mike
Comment 1 Michael J. Chudobiak 2008-10-06 14:08:58 EDT
[mjc@xena ~]$ cat .xsession-errors

[snip keychain stuff] 

SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2933,unix/unix:/tmp/.ICE-unix/2933
Initializing nautilus-open-terminal extension
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

** (nautilus:3101): WARNING **: Unable to add monitor: Not supported
Unable to open desktop file /home/mjc/Desktop/openoffice.org-1.9-writer.desktop for panel launcher: No such file or directory
could not attach to desktop process
** Message: Could not connect to ConsoleKit: Could not get owner of name 'org.freedesktop.ConsoleKit': no such name

** (gnome-panel:3100): WARNING **: Failed to establish a connection with GDM: No such file or directory

** (gnome-panel:3100): WARNING **: panel-applet-frame.c:1285: failed to load applet OAFIID:TomboyApplet:
(null)
Comment 2 Michael J. Chudobiak 2008-10-06 15:47:32 EDT
Found the problem. My /etc/passwd, group, shadow, and gshadow files had entries for both messagebus (uid/gid 81) and dbus (uid/gid 113), due to a long history of upgrades.

Deleting messagebus and assigning uid/gid 81 to dbus fixed things.

- Mike

Note You need to log in before you can comment on or make changes to this bug.