Bug 465866 - after creating nonsparse disk: 'Device 0 (vif) could not be connected. Hotplug scripts not working.'
after creating nonsparse disk: 'Device 0 (vif) could not be connected. Hotplu...
Status: CLOSED DUPLICATE of bug 456926
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
http://rhts.redhat.com/testlogs/31434...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 16:13 EDT by Jeff Burke
Modified: 2009-12-14 16:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 10:08:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-10-06 16:13:28 EDT
Description of problem:
When installing a paravirt xen guest on sun-x4600m2-01.rhts.bos.redhat.com it fails.

Version-Release number of selected component (if applicable):
libvirt-0.3.3-7.el5

How reproducible:
Often

Steps to Reproduce:
1. Install RHEL5.3 on sun-x4600m2-01.rhts.bos.redhat.com
2. Try and create a paravirt xen guest with the --nonsparse option
  
Actual results:
virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start guest69-205.rhts.bos.redhat.com'; otherwise, please
 restart your installation.
Mon, 06 Oct 2008 11:25:42 ERROR    virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 502, in ?
    main()
  File "/usr/sbin/virt-install", line 462, in main
    dom = guest.start_install(conscb,progresscb)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 813, in start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 834, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 573, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')

Expected results:
Should Pass

Additional info:
Spoke with Cole about this issue. He was also able to see/reproduce this issue.

http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=4577109
Binary Logs: virtinstall.fs5457
Comment 1 Cole Robinson 2008-10-07 09:58:50 EDT
This has been reproduced pretty reliably. I tried to insert a sleep after the nonsparse disk creation in virt-install to see if it solved the problem. A 10 second sleep didn't help, a 20 second sleep reduced the occurrence but didn't fully stop the problem.

Danpb, I know you've fixed issues in this area before. The RHTS link has all the needed logs, could you take a look?
Comment 2 Chris Lalancette 2008-10-09 10:08:12 EDT
I'm pretty sure this one is a duplicate of the earlier 456926 that Barry and Cole have been working on.  I'm going to close it as such so we don't duplicate effort.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 456926 ***

Note You need to log in before you can comment on or make changes to this bug.