Bug 465882 - Nagios plugin check_linux_raid.pl syntax error (with patch)
Nagios plugin check_linux_raid.pl syntax error (with patch)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 18:40 EDT by Mike Harris
Modified: 2008-10-20 18:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 18:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch, apply against check_linux_raid (357 bytes, patch)
2008-10-06 18:40 EDT, Mike Harris
no flags Details | Diff

  None (edit)
Description Mike Harris 2008-10-06 18:40:24 EDT
Created attachment 319600 [details]
patch, apply against check_linux_raid

Description of problem:
Nagios plugin check_linux_raid.pl syntax error

Version-Release number of selected component (if applicable):
1.4.13-4

How reproducible:
Quite.

Steps to Reproduce:
1. execute /usr/lib/nagios/plugins/check_linux_raid
  
Actual results:
"use" not allowed in expression at ./check_linux_raid.orig line 27, at end of line
syntax error at ./check_linux_raid.orig line 27, near "use utils "
Execution of ./check_linux_raid.orig aborted due to compilation errors.

Expected results:
OK md0 status=[UU]. md1 status=[UU].
or something similar

Additional info:
Patch included, apply against check_linux_raid
Comment 1 Fedora Update System 2008-10-08 10:45:01 EDT
nagios-plugins-1.4.13-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.13-5.fc9
Comment 2 Fedora Update System 2008-10-09 17:35:45 EDT
nagios-plugins-1.4.13-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Mike Harris 2008-10-16 18:01:10 EDT
I just tested this package, and it seems to still be wrong. The ; is still missing.
Comment 4 Mike McGrath 2008-10-16 18:19:35 EDT
Which version of the package for which OS did you test?
Comment 5 Mike Harris 2008-10-16 18:34:03 EDT
I used package nagios-plugins-linux_raid-1.4.13-5.fc9.i386, on Fedora 9 i386.
Comment 6 Fedora Update System 2008-10-16 19:28:39 EDT
nagios-plugins-1.4.13-9.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.13-9.fc9
Comment 7 Fedora Update System 2008-10-20 18:14:53 EDT
nagios-plugins-1.4.13-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.