Bug 465891 - Depending on java-1.6.0-openjdk instead of java >= 1:1.6.0
Depending on java-1.6.0-openjdk instead of java >= 1:1.6.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: netbeans (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Victor G. Vasilyev
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 620330 620331
  Show dependency treegraph
 
Reported: 2008-10-06 19:37 EDT by Muayyad Alsadi
Modified: 2010-08-02 04:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 620330 (view as bug list)
Environment:
Last Closed: 2009-01-12 07:58:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Muayyad Alsadi 2008-10-06 19:37:45 EDT
Description of problem:
I believe we should not force our users to use openjdk,
we should give them the freedom to choose between openjdk and sun's jdk or any other jdk

Version-Release number of selected component (if applicable):
netbeans-java2-6.1-6.fc10.noarch.rpm

How reproducible:
always

Steps to Reproduce:
rpm -qp -R netbeans-java2-6.1-6.fc10.noarch.rpm
  
Actual results:
java >= 1:1.6.0
java-1.6.0-openjdk >= 1:1.6.0

Expected results:
java >= 1:1.6.0
Comment 1 Victor G. Vasilyev 2008-10-07 11:42:36 EDT
Hi Muayyad,

I absolutely agree that the netbeans-java2-6.1 package should not explicitly depend on the java-1.6.0-openjdk package. 
But, it was my wrong attempt to establish dependency on JDK (not JRE!).

There is related Bug https://bugzilla.redhat.com/show_bug.cgi?id=464558 . 

Both bugs (this and #464558) are fixed by means of replacing the dependency on java-1.6.0-openjdk with java-sdk.

In result:

$ rpm -qp -R netbeans-java2-6.1-7.fc10.noarch.rpm
...
java >= 1:1.6.0
java-sdk >= 1:1.6.0
...

Note, the netbeans-java2 subpackage requires both java and java-sdk, because it doesn't make any assumptions about possible packaging of both JRE and JDK and relations between their packages. E.g. such solution will work properly even if both java and java-sdk will be provided by one package. 

Successful koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=866444
Comment 2 Bug Zapper 2008-11-25 22:37:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Muayyad Alsadi 2009-01-12 07:58:20 EST
thanks, it worked for me
sorry for being late

I changed the status to closed currentrelease
is this correct ?
Comment 4 Victor G. Vasilyev 2009-01-13 06:55:07 EST
Thanks, Muayyad. I think the status is correct, because FC9 is actually the current release now.
Comment 5 Victor G. Vasilyev 2009-01-13 06:58:18 EST
Sorry I've typo. I meant FC10 is the current release.

Note You need to log in before you can comment on or make changes to this bug.