Bug 465910 - Marked as dead.package without explanation or proper procedure followed
Summary: Marked as dead.package without explanation or proper procedure followed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkmozembedmm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-07 04:09 UTC by Alex Lancaster
Modified: 2008-10-11 02:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-11 02:40:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Lancaster 2008-10-07 04:09:57 UTC
The proper procedure for retiring a package (i.e. completely removing from the distribution for future releases) is documented here:

https://fedoraproject.org/wiki/PackageMaintainers/PackageEndOfLife

No parts of this procedure were properly followed.  dead.package was added but no explanation given as per step 2.  Nor were the "cvs rm" done, nor mail sent to rel-eng, nor was it added to:

https://fedoraproject.org/wiki/PackageMaintainers/RetiredPackages

if this was simply an orphaning of a package, a completely different procedure should have be done, see:

https://fedoraproject.org/wiki/PackageMaintainers/OrphanedPackages

Can the maintainer please clarify his intention, otherwise I am initiating the non-responsive procedure as per:

https://fedoraproject.org/wiki/PackageMaintainers/Policy/NonResponsiveMaintainers

Comment 1 Alex Lancaster 2008-10-07 05:03:34 UTC
OK, I went ahead and did some of the missing steps on

https://fedoraproject.org/wiki/PackageMaintainers/RetiredPackages

because the CVS commit on 2008/08/09 15:56:38 by maintainer hguemar made clear the intention

"remove gtkmozembedmm from devel branch (future F-10) since it has no more
active upstream"

I have now "cvs rm" all other files (except for dead.package), added it to the retired package list and opened up a rel-eng request for blocking:

https://fedorahosted.org/rel-eng/ticket/845

Comment 2 Alex Lancaster 2008-10-07 05:07:26 UTC
PS, I checked with repoquery that nothing else appears to depend on this package as far as I can tell:

$ repoquery --whatrequires --alldeps --recursive gtkmozembedmm
gtkmozembedmm-0:1.4.2.cvs20060817-21.fc9.x86_64
gtkmozembedmm-0:1.4.2.cvs20060817-17.fc9.x86_64
gtkmozembedmm-devel-0:1.4.2.cvs20060817-21.fc9.x86_64
gtkmozembedmm-0:1.4.2.cvs20060817-21.fc9.i386
gtkmozembedmm-0:1.4.2.cvs20060817-17.fc9.i386
gtkmozembedmm-devel-0:1.4.2.cvs20060817-17.fc9.x86_64
gtkmozembedmm-devel-0:1.4.2.cvs20060817-17.fc9.i386
gtkmozembedmm-devel-0:1.4.2.cvs20060817-21.fc9.i386

$ repoquery --whatrequires --alldeps --recursive libgtkmozembedmm-1.4.so.0
gtkmozembedmm-0:1.4.2.cvs20060817-21.fc9.x86_64
gtkmozembedmm-0:1.4.2.cvs20060817-17.fc9.x86_64
gtkmozembedmm-devel-0:1.4.2.cvs20060817-21.fc9.x86_64
gtkmozembedmm-0:1.4.2.cvs20060817-21.fc9.i386
gtkmozembedmm-0:1.4.2.cvs20060817-17.fc9.i386
gtkmozembedmm-devel-0:1.4.2.cvs20060817-17.fc9.x86_64
gtkmozembedmm-devel-0:1.4.2.cvs20060817-17.fc9.i386
gtkmozembedmm-devel-0:1.4.2.cvs20060817-21.fc9.i386

Comment 3 Alex Lancaster 2008-10-11 02:40:08 UTC
rel-eng has now blocked package from rawhide.  Closing bug.


Note You need to log in before you can comment on or make changes to this bug.