Bug 465921 - openmpi is missing BR gcc4-gfortran
openmpi is missing BR gcc4-gfortran
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openmpi (Show other bugs)
4.7.z
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Gurhan Ozen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 02:59 EDT by Tuomo Soini
Modified: 2013-11-03 20:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:36:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomo Soini 2008-10-07 02:59:35 EDT
Description of problem:

Openmpi can't be rebuild under mock because of missing BR.

Version-Release number of selected component (if applicable):

1.2.7-2.el4_7

How reproducible:

Always.

How to fix:

add missing build requirement to spec

BuildRequires: gcc4-gfortran

I think this is not correct fix, but this was minimum change in build environment to get package build.
Comment 2 Doug Ledford 2009-01-27 16:06:28 EST
Adding gcc4-gfortran breaks the build (well, the build succeeds, but it is missing fortran support entirely because of the mix of g77 and gfortran in the build process).  You can only have one of gcc-g77 or gcc4-gfortran used to build the package, and since all previous versions have used gcc-g77, switching to gcc4-gfortran would break compatibility with existing, compiled fortran programs.  As such I can't add gcc4-gfortran to the build requirements.  If you are having problems building in a mock environment, it's likely caused by some difference between your initial mock environment and ours.  The build requires that this package currently has are correct for our particular build environment.  As such, I'm closing as NOTABUG.
Comment 3 Doug Ledford 2009-01-27 20:34:22 EST
OK, due to a change in the build system, packages that were previously not giving a specific buildrequires of gcc4-gfortran were getting it anyway.  The build system recently changed such that this no longer happens.  If I were to allow openmpi to be build using gcc-g77 instead, then programs that were built with the old packages wouldn't run after an upgrade.  So, I've done what's necessary to make the package build with a specific buildrequires on gcc4-gfortran.  Therefore I'm reopening this bug as it specifically *must* be fixed in order to avoid breaking existing openmpi applications.
Comment 6 errata-xmlrpc 2009-05-18 16:36:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1023.html

Note You need to log in before you can comment on or make changes to this bug.