Bug 465936 - Evolution error connecting to exchange server in modified account
Evolution error connecting to exchange server in modified account
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-07 04:58 EDT by Mikkel Lauritsen
Modified: 2009-12-18 01:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 01:31:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Debugging output from Evolution (3.71 KB, text/plain)
2008-10-07 04:58 EDT, Mikkel Lauritsen
no flags Details

  None (edit)
Description Mikkel Lauritsen 2008-10-07 04:58:49 EDT
Created attachment 319626 [details]
Debugging output from Evolution

Fedora 10 Beta with evolution-2.24.0-2.fc10.x86_64 and evolution-exchange-2.24.0-1.fc10.x86_64 .

After having installed Fedora 10 Beta I tried configuring an Evolution account against an Exchange server. I didn't initially check whether evolution-exchange had been installed, so I wasn't able to choose the proper server type, and I just finished creating the account with more or less random settings.

I then installed evolution-exchange and reconfigured the account to point at the Exchange server, but as shown in the attached debugging output Evolution was unable to talk to the server. Clicking the Authenticate button on the Receiving Email tab in the account editor didn't show any errors.

After fiddling for some time with the user name, password and OWA URL I ended up completely deleting the account and recreating it with the exact same settings, and suddenly everything worked.

So - apparently there is some kind of difference between the account settings depending on whether the account is initially pointed at an Exchange server or not. As Exchange support isn't installed by default there is a risk that other people hit the same problem as well.

There is no ISA proxy between me and the Exchange server, so this doesn't immediately appear to be related to bug 454947.
Comment 1 Bug Zapper 2008-11-25 22:37:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 2 Mike Chambers 2009-03-07 08:45:52 EST
Are you still experiencing this problem?  If so, what version of evolution are you currently using? If your not having any more problems, would you please close the bug?

Fedora Bugzappers volunteer triage team
Comment 3 Mikkel Lauritsen 2009-03-09 10:45:03 EDT
This on my daily workstation, so I have to admit that since I need to have it up and running I haven't (yet) tried setting up a new Evolution-Exchange account.
Comment 4 Bug Zapper 2009-11-18 03:31:33 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 5 Bug Zapper 2009-12-18 01:31:24 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.