Bug 465947 - Remove spacewalk-proxy-tools package
Remove spacewalk-proxy-tools package
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Proxy Server (Show other bugs)
0.3
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-10-07 07:11 EDT by Rob James
Modified: 2009-09-17 03:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob James 2008-10-07 07:11:31 EDT
The spacewalk-proxy-tools package now only has two things in it (now that rhn-proxy-activate has moved to the installer package): the rhn-proxy init script and rhn-proxy-debug.

rhn-proxy-debug does pretty much exactly the same thing as "sosreport -o rhn" but the sosreport tool is probably somewhat more widely deployed. That just leaves the init script which can probably be moved to the spacewalk-proxy-installer package.

Looking through spacewalk-proxy.spec it seems that spacewalk-proxy-installer is used for upgrades for the RHN product forcing a new config deploy so I thought I'd let someone from RH take a look to ensure we don't break the RHN Proxy product.
Comment 1 Miroslav Suchý 2008-10-07 11:54:18 EDT
I agree that spacewalk-proxy-tools is heading toward removing. 

I definitely do not want to move init.d script to spacewalk-proxy-installer, because is fundamental script and have to be installer and web based installer of RHN proxy do not install spacewalk-proxy-installer package. And I want to have this web installer to be functional in RHN Proxy 5.3 (in 5.2 is CLI installer as tech preview, web installer is still prefered, in 5.3 will be prefered CLI and web installer obsolete, but still functional). Becouse of this, it may happen that I leave this open for longer time before resolving.

I will investigate if we can replace rhn-proxy-debug with sosreport.
Comment 2 Miroslav Suchý 2009-01-20 11:14:58 EST
Fixed in 66ce1d8eced74300bd394fe13d8ac1c2c3c0431e
and d78ae82f1985837cac1dc424ad4fc878c88fdbc1
Comment 3 Jesus M. Rodriguez 2009-04-14 10:11:38 EDT
Spacewalk 0.5 released.
Comment 4 Miroslav Suchý 2009-09-17 03:08:26 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.