Bug 465999 - numpy 1.2.0 is released, update please?
numpy 1.2.0 is released, update please?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOLPCDelta
  Show dependency treegraph
 
Reported: 2008-10-07 13:28 EDT by Chris Schanzle
Modified: 2008-10-30 08:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 16:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Schanzle 2008-10-07 13:28:41 EDT
Hi, numpy 1.2.0 is released and we could make use of its fixes.  I built it under mock using just these changes below.  Note python-nose is needed for the %check section only.


6c6
< Version:        1.1.1
---
> Version:        1.2.0
17c17
< BuildRequires:  python-devel blas-devel lapack-devel python-setuptools gcc-gfortran
---
> BuildRequires:  python-devel blas-devel lapack-devel python-setuptools gcc-gfortran python-nose

Thanks!
Comment 1 Chris Schanzle 2008-10-07 13:37:44 EDT
Further testing shows that for the tests to work after installation, python-nose is required as a dependency.  You may want to also make python-nose a Requires in case users want to execute numpy.test() .
Comment 2 Gwyn Ciesla 2008-10-07 13:41:52 EDT
Will do.  Watch this space.
Comment 3 Gwyn Ciesla 2008-10-07 16:03:24 EDT
Odd, I get the following on F-9:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.97814
+ umask 022
+ cd /home/limb/rpmbuild/BUILD
+ cd numpy-1.2.0
+ pushd doc
+ PYTHONPATH=/var/tmp/numpy-1.2.0-1.fc9-root-limb/usr/lib/python2.5/site-packages
+ /usr/bin/python -c 'import pkg_resources, numpy ; numpy.test(1, 1)'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/numpy/testing/nosetester.py", line 221, in test
  File "/usr/lib/python2.5/site-packages/numpy/testing/nosetester.py", line 141, in _test_argv
TypeError: Selection label should be a string
error: Bad exit status from /var/tmp/rpm-tmp.97814 (%check)
Comment 4 Chris Schanzle 2008-10-08 09:02:40 EDT
Try changing "numpy.test(1, 1)" to "numpy.test()".

Strangely, it built okay without this change under under mock for CentOS 5, but when run interactively after installing the rpm, I had to remove the arguments.

If you are motivated, it would be "super" if you made this an EPEL package too.
Comment 5 Gwyn Ciesla 2008-10-08 09:32:57 EDT
Testing.

numpy isn't in EPEL for EL-4, but it's at 1.0.4 in EPEL for EL-5.  Are you looking for it to be added to EL-4, updated for EL5, or both?
Comment 6 Chris Schanzle 2008-10-08 09:37:13 EDT
EL5 is my interest, thanks!
Comment 7 Gwyn Ciesla 2008-10-08 09:47:55 EDT
The test change works, I'll get it in Fedora.

I think update to 1.2.0 is reasonable for EL5, too.  I'll put it in EL-4, as well, since I've had a use for it at work.
Comment 8 Chris Schanzle 2008-10-08 09:53:28 EDT
Terrific!  Thanks, Jon
Comment 9 Gwyn Ciesla 2008-10-08 10:02:20 EDT
Only thing I'm waiting on is the new version of atlas, since I'll be building numpy against it in rawhide, but I'm working with the atlas maintainer on that, so it should be soon.
Comment 10 Fedora Update System 2008-10-15 22:01:36 EDT
numpy-1.2.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update numpy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8787
Comment 11 Chris Schanzle 2008-10-16 09:20:59 EDT
The above (boilerplate?) should refer to updates-testing-newkey, as in:

yum --enablerepo=updates-testing-newkey update numpy

Updated on F9 x86_64 box, numpy.test() works, feedback given, thanks!
Comment 12 Fedora Update System 2008-10-20 16:28:23 EDT
numpy-1.2.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Chris Ball 2008-10-29 19:24:41 EDT
Hi, I work for OLPC.  We use numpy, but don't wish to add the 900KB python-nose runtime dependency.  I think we'll pin numpy back at the old version for now, but we'd obviously like to get updates to it -- perhaps the help() function could be split out into numpy-devel, or something like that?

Thanks!
Comment 14 Jef Spaleta 2008-10-29 21:06:50 EDT
-devel probably not.  

But there may be room to explore splitting numpy/scipy/matplotlib into more fine grained subpackages based on functionality.

If that would help you make better use of numpy/scipy/matplotlib  I'm more than happy to work with you and see if we can do it.

So the first question is what in numpy are you using? Do you need for example the distutil subtree or the testing subtree?

If we ever get support for enthought traits in Fedora, we will probably want to modularize that runtime as well.

-jef
Comment 15 Gwyn Ciesla 2008-10-30 08:17:53 EDT
Just so your're all aware:
https://bugzilla.redhat.com/show_bug.cgi?id=461472

Will this cause OLPC issues?

Note You need to log in before you can comment on or make changes to this bug.