Bug 466002 - libipathverbs i686 libraries not built on x86_64 or ppc64 platforms
libipathverbs i686 libraries not built on x86_64 or ppc64 platforms
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libibverbs (Show other bugs)
4.7
x86_64 Linux
medium Severity low
: rc
: ---
Assigned To: Doug Ledford
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 13:32 EDT by Shawn Houston
Modified: 2008-10-07 14:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 14:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed SPEC file for libipathverbs RPM (2.23 KB, text/plain)
2008-10-07 13:32 EDT, Shawn Houston
no flags Details

  None (edit)
Description Shawn Houston 2008-10-07 13:32:56 EDT
Created attachment 319672 [details]
fixed SPEC file for libipathverbs RPM

Description of problem:

The i686 versions of the libipathverbs libraries are not built on the x86_64 platforms. Binaries built 32 bit using older openmpi releases complain when run that they cannot load the missing libraries.

/usr/lib/libipathverbs-rdmav2.so
/usr/lib/libipathverbs.so



Version-Release number of selected component (if applicable):


How reproducible:

Run binaries built 32 bit using openmpi as released in RHEL4 4.5 under 4.6 or 4.7


Steps to Reproduce:
1. build 32 bit openmpi binary on x86_64 system before upgrading openmpi
2. upgrade to latest openmpi
3. run old binary
  
Actual results:

Warning generated

Expected results:

No warnings

Additional info:

The attached SPEC file allows me to build and install the i686 libraries.
Comment 1 Doug Ledford 2008-10-07 14:17:31 EDT
Are you actually using ipath hardware, or are you using mthca hardware?
Comment 2 Shawn Houston 2008-10-07 14:47:36 EDT
mthca hardware. I am just removing warning with this RPM, not that it matters with it being closed... is there a better way to silence the warnings?
Comment 3 Doug Ledford 2008-10-07 14:55:33 EDT
OK, that's what I thought.  The deal is that the ipathverbs library doesn't actually work properly in 32bit mode and is not intended to do so (according to QLogic).  So, you get this warning when using 32bit binaries on a 64bit system with libipathverbs.x86_64 installed.  Since you aren't using it, the best thing is to just remove the library entirely.  Due to the fact that libibverbs uses the same config file for both the 32bit and 64bit libraries it loads, it isn't smart enough to tell the difference between having both or only one version of the driver library installed and that just doesn't work well for libipathverbs since it can only be used in 64bit mode.

Note You need to log in before you can comment on or make changes to this bug.