Bug 466009 - make %find_lang --with-kde work
make %find_lang --with-kde work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 13:59 EDT by Rex Dieter
Modified: 2009-07-11 12:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.7.0-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 09:04:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quick-n-dirty, look for kde HTML docs in the standard/default location (1.03 KB, patch)
2008-10-07 13:59 EDT, Rex Dieter
no flags Details | Diff
more robust solution, using path's queried from kde-config, kde4-config (1.81 KB, patch)
2008-10-07 14:26 EDT, Rex Dieter
no flags Details | Diff
Fix --with-kde with KDE 3 (1010 bytes, patch)
2009-04-12 14:40 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Rex Dieter 2008-10-07 13:59:03 EDT
%find_lang --with-kde
currently fails since it looks for kde docs in a non-standard location of
doc/kde/HTML

I'll send some patches shortly.
Comment 1 Rex Dieter 2008-10-07 13:59:52 EDT
Created attachment 319681 [details]
quick-n-dirty, look for kde HTML docs in the standard/default location
Comment 2 Rex Dieter 2008-10-07 14:00:47 EDT
I'll also whip up a better, long-term solution, to allow for even non-standard doc locations.
Comment 3 Rex Dieter 2008-10-07 14:26:42 EDT
Created attachment 319683 [details]
more robust solution, using path's queried from kde-config, kde4-config
Comment 4 Jindrich Novy 2008-10-07 16:07:52 EDT
Applied upstream, thanks for the patch!
Comment 5 Ville Skyttä 2009-04-12 14:39:13 EDT
The KDE3 hunk of the patch appears to contain one missing slash causing it not to work, will attach a fix against rpm-4.7.x
Comment 6 Ville Skyttä 2009-04-12 14:40:41 EDT
Created attachment 339258 [details]
Fix --with-kde with KDE 3
Comment 7 Panu Matilainen 2009-04-21 09:04:37 EDT
Thanks again for the patch, applied upstream and also rpm-4.7.0-3.fc12 just building for rawhide.
Comment 8 Fedora Update System 2009-06-18 12:19:11 EDT
rpm-4.7.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpm-4.7.0-2.fc11
Comment 9 Fedora Update System 2009-07-11 12:54:41 EDT
rpm-4.7.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.