Bug 466014 - gst-install-plugin-helper needs execstack, SELinux denials
gst-install-plugin-helper needs execstack, SELinux denials
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 468416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 14:14 EDT by Matt Domsch
Modified: 2008-10-29 10:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
matt_domsch: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-10-07 14:14:13 EDT
Description of problem:
SELinux is preventing gst-install-plu from making the program stack executable. 

type=SYSCALL msg=audit(1223402720.159:31): arch=c000003e syscall=10 success=yes exit=0 a0=7fff528ba000 a1=1000 a2=1000007 a3=3370a20000 items=0 ppid=3587 pid=3588 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts2 ses=1 comm="gst-install-plu" exe="/usr/libexec/pk-gstreamer-install" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1223402741.218:32): avc:  denied  { execstack } for  pid=3625 comm="totem" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


Version-Release number of selected component (if applicable):
SELinux is preventing gst-install-plu from making the program stack executable. 

Steps to reproduce:
run totem to play an MP3 file with no MP3 codecs installed, and selinux enforcing.
Comment 1 Richard Hughes 2008-10-07 16:11:54 EDT
I'm not sure why pk-codec-installer needs execstack -- it's a simple C program calling a DBUS method... I'll try doing this with enforcing on tomorrow.
Comment 2 Matthias Clasen 2008-10-25 17:00:41 EDT
Probably it loads some gstreamer plugins that need execstack ?
Comment 3 Richard Hughes 2008-10-26 12:30:52 EDT
I really can't reprodude -- Matt -- what plugins do you have installed and what is the file format of the file that triggered the PackageKit dialog? Thanks.
Comment 4 Richard Hughes 2008-10-27 10:10:37 EDT
Can you please provide:

 rpm -qa | grep gstreamer

Thanks.
Comment 5 Matt Domsch 2008-10-27 10:49:51 EDT
Turns out I did have streamer plugins (old ones) instealled in ~/.gstreamer-0.10/plugins/.  Removed those, no AVCs.  Downloaded latest MP3 plugin from Fluendo's web site, and it works now with no AVCs.  So an upgrade of the plugins is recommended.

I suspect the release notes should mention to upgrade any previously installed Fluendo MP3 codecs if you run into this problem.  Adding release notes flag.
Comment 6 Daniel Walsh 2008-10-27 15:53:57 EDT
*** Bug 468416 has been marked as a duplicate of this bug. ***
Comment 7 Matt Domsch 2008-10-29 10:43:46 EDT
https://fedoraproject.org/wiki/Docs/Beats/Multimedia
now includes text for this.

Note You need to log in before you can comment on or make changes to this bug.