Bug 466063 - cannot disable tap to click with xorg-x11-drv-synaptics-0.15.0-3.fc9.i386
cannot disable tap to click with xorg-x11-drv-synaptics-0.15.0-3.fc9.i386
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 20:16 EDT by Tim
Modified: 2008-10-15 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 00:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (1.47 KB, text/plain)
2008-10-14 10:57 EDT, Tim
no flags Details
log file generated with that xorg.conf file (11.77 KB, text/plain)
2008-10-14 10:58 EDT, Tim
no flags Details

  None (edit)
Description Tim 2008-10-07 20:16:27 EDT
Description of problem:
Any time the touchpad is caught accidentally, or my hands approach it without contact, I get random mouse actions that foul up what I'm doing.  I've tried disabling tap to click going through all suggestions in the synaptics man file and readme supplied with this package, all are ineffective.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-0.15.0-3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Add options to xorg.conf like:
Option "SHMConfig" "true"
Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"
Option "ClickFinger1" "0"
Option "ClickFinger2" "0"
Option "ClickFinger3" "0"
Option "MaxTapTime" "0"
Option "MaxTapMove" "0" 
Option "PalmDetect" "on"
Option "FastTaps" "off"

2.
3.
  
Actual results:
No change in behaviour, and gsynaptics won't run, claiming that I need to set SHMConfig to true, even though it already is.

Expected results:
To be able to kill off tap to click, somehow.  Without totally disabling use of the touchpad.

Additional info:
The following added to xorg.conf while trying to solve this.

Section "InputDevice"
Driver      "synaptics"
Identifier  "TouchPad"
Option      "SendCoreEvents"
Option      "Protocol" "auto-dev"
Option "SHMConfig" "true"
Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"
#Option "TouchpadOff" "2"
Option "ClickFinger1" "0"
Option "ClickFinger2" "0"
Option "ClickFinger3" "0"
Option "MaxTapTime" "0"
Option "MaxTapMove" "0" 
Option "PalmDetect" "on"
Option "FastTaps" "off"
EndSection

The ability to totally kill the touchpad when a mouse is connected, automatically, and re-enable when disconnected, would be good.
Comment 1 Peter Hutterer 2008-10-07 21:01:01 EDT
I need your Xorg.log and your xorg.conf please.
Comment 2 Tim 2008-10-14 10:57:10 EDT
Created attachment 320307 [details]
xorg.conf file

The following section was inserted into that file to try and get synaptics to work, it didn't exist beforehand.

Section "InputDevice"
# see http://satyajitranjeev.wordpress.com/2008/05/16/fedora-9-and-touchpads/
# see http://forums.fedoraforum.org/showthread.php?t=200840
Identifier      "Synaptics Touchpad"
Driver      "synaptics"
Option      "SendCoreEvents"
Option      "Protocol" "auto-dev"
Option "SHMConfig" "true"
Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"
#Option "TouchpadOff" "2"
Option "ClickFinger1" "0"
Option "ClickFinger2" "0"
Option "ClickFinger3" "0"
Option "MaxTapTime" "0"
Option "MaxTapMove" "0" 
Option "PalmDetect" "on"
 Option "FastTaps" "off"
EndSection
Comment 3 Tim 2008-10-14 10:58:02 EDT
Created attachment 320308 [details]
log file generated with that xorg.conf file
Comment 4 Peter Hutterer 2008-10-15 00:46:51 EDT
The device in your xorg.conf isn't picked up as it isn't referenced. Instead it is picked up when HAL notifies X that the device is available.

Two solutions:
1. Reference the touchpad by adding "InputDevice "Synaptics Touchpad"" to the ServerLayout section.
2. Add the options to the /usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi
file. This way you don't need an xorg.conf entry for the touchpad at all. Add each option in the form of

<merge key="input.x11_options.TapButton1" type="string">0</merge>

to the respective section (info.product is Synaptics Touchpad in your case)

Closing as NOTABUG, this is caused by misconfiguration.

Note You need to log in before you can comment on or make changes to this bug.