Bug 466106 - document potential inability to install/update kernel with USB storage attached
document potential inability to install/update kernel with USB storage attached
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 07:23 EDT by Alexey Kuznetsov
Modified: 2008-12-16 15:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 15:51:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2008-10-08 07:23:36 EDT
In case of bug 440661 need to update requirements section to: avoid put any USB devices to until system fully installed.

affect systems: fedora 8, fedora 9 and probably fedora 10 if no one will apply patch to rawhide.
Comment 2 Alexey Kuznetsov 2008-10-08 12:25:38 EDT
I think is good idea to put there note about usb-flash. For many users, for me also, that is not mean Nonstandard configuration.
Comment 3 Karsten Wade 2008-10-08 12:46:44 EDT
Some questions:

* Does this affect all architectures, or just PowerPC?
* What happens with USB devices that are installing from?  For example, USB thumb drive with a live media install.
* Is the requirement really, "Remove all USB storage when updating the kernel"?
* Does anyone know if this is going to be fixed in mkinitrd for Fedora 10?

I'm not sure what is the right thing to do for F8 and F9; maybe put a note on their "common bugs" page?
Comment 4 Alexey Kuznetsov 2008-10-08 12:59:27 EDT
1. any arch x86, ppc, any
2. i think they will crash too (depend on bug nature)
3. yes, for now it's true.
4. i also have question. i try to find answer in fedora development community and try to understand patches live cycle.


that is memory overrun bug really critical and should be fixed before f10 come out. also it should be fixed for f8 and f9, but impossible to fix it for already published dvd images.
Comment 5 Karsten Wade 2008-10-09 16:07:28 EDT
Adding Peter Jones to this bug so he can help us get a clear answer for the upcoming F10 work.  

Peter -- let us know if we need to put in a note for the Preview Release.  Absolute deadline for that decision (and content to put in) is 2300 UTC 09 October by special I'll-hack-it-in-at-the-last-hour-myself reprieve.

As for the rest of the point about F8 and F9 existing media, if I'm getting this correctly, the concern is that the initial run of mkinitrd when installing the system may not work if there is a USB storage device attached?

I'm thinking that once the system is installed, it will no longer matter, presuming the kernel they update to no longer has the problem.

This could therefore make sense as an addition to the F8 and F9 common bugs pages, and perhaps an update of the release notes for more details.

(Changing summary to be more specific.)
Comment 6 Jason Taylor 2008-12-16 09:39:47 EST
Looks like we need more information on this, if no one has anything to add I am for closing out this bug...
Comment 7 Alexey Kuznetsov 2008-12-16 11:44:28 EST
which info? bug closed for f10 and still applicable to f9
Comment 8 Karsten Wade 2008-12-16 15:51:50 EST
The bug for F10 was closed successfully, and it looks as if it was in time for the GA, right?  Thus I'll close it as NOTABUG since we never needed the content in the actual release notes.

If further content is needed for F9 or F8, the best place to update on this issue is the common bugs page for that release.

Note You need to log in before you can comment on or make changes to this bug.