Bug 466120 - error during install of openoffice.org-voikko
error during install of openoffice.org-voikko
Status: CLOSED DUPLICATE of bug 461763
Product: Fedora
Classification: Fedora
Component: openoffice.org-voikko (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville-Pekka Vainio
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 10:44 EDT by Tom Horsley
Modified: 2009-05-12 17:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 17:41:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-10-08 10:44:22 EDT
Description of problem:

Did install from rawhide last night on my f10 beta system, got this
during install:

  Updating       : openoffice.org-voikko                         [ 89/203] 
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

Version-Release number of selected component (if applicable):
openoffice.org-voikko-3.0-2.fc10.x86_64

How reproducible:
I only tried it the one time.

Steps to Reproduce:
1.yum update
2.
3.
  
Actual results:
bad_alloc exception

Expected results:
no errors during install

Additional info:
Comment 1 Ville-Pekka Vainio 2008-10-08 15:35:54 EDT
This is quite hard to debug. The exception means something went wrong with allocating memory. When installing openoffice.org-voikko, rpm runs an OpenOffice.org tool called unopkg, I presume that's where the exception comes from (and that's why I'm CCing Caolan).

For what it's worth, I couldn't reproduce the error on my i386 Rawhide virtual machine.
Comment 2 Caolan McNamara 2008-10-08 18:00:26 EDT
Hmm, I have no idea either, but I suspect there might be a connection to #461763

Feel free to mark it as a duplicate along the lines of super-suspicious failure during a big yum transaction which fails to happen in isolation.

I'm suspicious as to whether it is OOo which is doing something crazy, or of e.g. the python garbage collector hasn't had a chance to run during transactions and eats all available memory. Though that's just a crazy theory. 

I would be interested in knowing what memory exists on the box that failed ?
Comment 3 Tom Horsley 2008-10-08 18:11:01 EDT
There is two gig of physical memory on the machine where this happened
and an 8 gig swap area. The messages also scrolled past at normal
speed, nothing seemed like it had bogged down due to trashing or
anything. I suppose rather than using up all memory, it might have
had some corrupted memory location cause it to request something
like 200 gig and have that request rejected as ridiculous without
first going to all the trouble of eating all memory and bogging
down the machine.
Comment 4 Bug Zapper 2008-11-25 22:40:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Caolan McNamara 2009-05-12 17:41:05 EDT
Let's call it a duplicate of 461763. Not that that helps fix it, but hasn't been seen again so...

*** This bug has been marked as a duplicate of bug 461763 ***

Note You need to log in before you can comment on or make changes to this bug.