Bug 466140 - No bluetooth mouse in FC10
No bluetooth mouse in FC10
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 13:05 EDT by jim tate
Modified: 2009-12-18 01:32 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:32:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages bluetoothd (2.09 KB, text/plain)
2008-10-08 13:05 EDT, jim tate
no flags Details

  None (edit)
Description jim tate 2008-10-08 13:05:48 EDT
Created attachment 319768 [details]
/var/log/messages  bluetoothd

Description of problem:
Can't get Bluetooth mouse to connect in Bluetooth Wizard.
Bluetooth Wizard detects Bluetooth Mouse Logitech.
But in Bluetooth Wizard "Device Setup" I get error Message: "Pairing with (null) failed"
This Logitech Mouse worked fine in Fedora 9.
Had same problem before update to bluez-4.12-1.fc10.i386

Version-Release number of selected component (if applicable):

bluez-4.12-1.fc10.i386


How reproducible:
All the Time


Steps to Reproduce:
1.n/a
2.
3.
  
Actual results: No Bluetooth mouse


Expected results:


Additional info:
Comment 1 jim tate 2008-10-08 13:19:19 EDT
This is tail -f /var/log/messages while I was running Bluetooth Wizard.


Oct  8 13:09:04 eeePC kernel: hci_cmd_task: hci0 command tx timeout
Oct  8 13:09:09 eeePC bluetoothd[2050]: Unable to start periodic inquiry: Connection timed out (110)
Comment 2 Bastien Nocera 2008-10-08 14:18:05 EDT
This is a problem with the dongle, which should be worked around in the kernel.
Comment 3 jim tate 2008-10-08 14:42:36 EDT
 I updated to the kernel-2.6.27.0.398.fc10.i686 today and didn't change anything in  Bluetooth.
Comment 4 Bastien Nocera 2008-10-09 05:57:15 EDT
btusb probably needs a quirk for your device to work properly. Send a mail about the errors you see to the linux-bluetooth@ mailing-list, they should be able to get this kickstarted.
Comment 5 jim tate 2008-10-09 10:37:07 EDT
This timeout problem  in Bluetooth also happen in FC8 and FC9.
Check with Tim Waugh he knows what the problem is, if I remember it was in bluez-utils.
Comment 6 jim tate 2008-10-09 10:38:42 EDT
That is Tim Waugh at RedHat.
Comment 7 Tim Waugh 2008-10-15 05:31:31 EDT
I don't know anything about this problem, sorry.
Comment 8 jim tate 2008-10-20 14:32:40 EDT
kernel-2.6.27.3-27.rc1.fc10.i386.

I upgraded to bluez-4.15-1.fc10.i386 and still no Bluetooth Mouse.
And when I run kbluetooth4 , it won't run, if I run kbluetooth4 again in Konsole
it comes back with "kbluetooth is already running" but I have no Icon on Panel.

If I run bluetooth-wizard , the mac# for mouse (Logitech) is detected, I hilite mac # and click on "forward" and then I get a "Segmentation Fault" .
Comment 9 jim tate 2008-11-01 12:23:13 EDT
After updates to;

bluez-4.17-2.fc10.i386
kernel-2.6.27.4-68.fc10.i686

I still do not have a bluetooth mouse working, running "bluetooth-wizard"
I get the error message;
"Pairing with 00-07-61-96-81-C4 Failed"  The MAC# is my Bluetooth Mouse.

What's up ??
Comment 10 Darius Ivanauskas 2008-11-04 03:30:38 EST
BT mouse worked for me until some update. Now it seems that there is problem with SELinux policies and bluetoothd - seeing lots of messages with setroubleshoot:
...
SELinux is preventing bluetoothd (bluetooth_t) "read write" to
./lastused (var_lib_t).
SELinux is preventing bluetoothd (bluetooth_t) "getattr" to
/var/lib/bluetooth/00:1F:E2:F5:6E:B8/lastused (var_lib_t).
SELinux is preventing bluetoothd (bluetooth_t) "read write" to
./manufacturers (var_lib_t).
SELinux is preventing bluetoothd (bluetooth_t) "read" to ./classes (var_lib_t).
SELinux is preventing bluetoothd (bluetooth_t) "read write" to
./config (var_lib_t).
SELinux is preventing bluetoothd (bluetooth_t) "read write" to ./did
(var_lib_t).
...
Comment 11 jim tate 2008-11-04 09:35:49 EST
Yes I had the same problem, I had to 'Disable" Selinux.
Comment 12 jim tate 2008-11-12 16:29:56 EST
FC 10 /KDE

Using bluez-4.17-2.fc10.i386

Error message while running Bluetooth-Wizard.
Is it missing some GTK packages or What ??


$ bluetooth-wizard

(bluetooth-wizard:4061): Gtk-CRITICAL **: gtk_tree_model_filter_set_visible_func: assertion `GTK_IS_TREE_MODEL_FILTER
(filter)' failed                   
(bluetooth-wizard:4061): Gtk-CRITICAL **: gtk_tree_model_sort_new_with_model: assertion `GTK_IS_TREE_MODEL (child_model)' failed                         
(bluetooth-wizard:4061): Gtk-CRITICAL **: gtk_tree_sortable_set_sort_column_id: assertion `GTK_IS_TREE_SORTABLE (sortable)' failed                       
(bluetooth-wizard:4061): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed                                               
(bluetooth-wizard:4061): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Comment 13 Bug Zapper 2008-11-25 22:40:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Daniel Mircea 2009-02-07 06:08:38 EST
I think I'm having the same(or similar?) problem with a Microsoft Notebook Bluetooth Mouse 5000. To make it work I have to run as root:

hidd --connect <bluetooth-mac-address>

Whereas the bluetooth applet never manages to connect though it finds the mouse. It looks like a permission issue.
Comment 15 Bug Zapper 2009-11-18 02:56:17 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-12-18 01:32:00 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.