Bug 466143 - Brother MFC465CN CUPS Print Failure
Brother MFC465CN CUPS Print Failure
Status: CLOSED DUPLICATE of bug 247225
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 13:25 EDT by Glenn White
Modified: 2008-10-20 10:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 09:38:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Brother MFC465CN CUPS Print Failure (15.30 KB, application/pdf)
2008-10-08 13:25 EDT, Glenn White
no flags Details

  None (edit)
Description Glenn White 2008-10-08 13:25:37 EDT
Created attachment 319771 [details]
Brother MFC465CN CUPS Print Failure

Description of problem:
Unable to print after installing Brother MFC465CN CUPS print driver.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
See attached file.
Comment 1 Tim Waugh 2008-10-13 09:37:44 EDT
What does this command say?

locate inf|grep -w usr|grep '/inf\(/.*\)\?$'
Comment 2 Glenn White 2008-10-13 13:01:25 EDT
$ locate inf|grep -w usr|grep '/inf\(/.*\)\?$'
/usr/local/Brother/Printer/mfc465cn/inf
/usr/local/Brother/Printer/mfc465cn/inf/brPrintListij2
/usr/local/Brother/Printer/mfc465cn/inf/brio06aa.bcm
/usr/local/Brother/Printer/mfc465cn/inf/brio06ab.bcm
/usr/local/Brother/Printer/mfc465cn/inf/brio06ac.bcm
/usr/local/Brother/Printer/mfc465cn/inf/brio06af.bcm
/usr/local/Brother/Printer/mfc465cn/inf/brio06ag.bcm
/usr/local/Brother/Printer/mfc465cn/inf/brmfc465cnfunc
/usr/local/Brother/Printer/mfc465cn/inf/brmfc465cnrc
/usr/local/Brother/Printer/mfc465cn/inf/paperinfij2
/usr/local/Brother/Printer/mfc465cn/inf/setupPrintcapij
$
Comment 3 Tim Waugh 2008-10-14 05:53:40 EDT
Thanks.  Now, what does this say?:

rpm -qf /usr/local/Brother/Printer/mfc465cn/inf
Comment 4 Glenn White 2008-10-18 09:09:56 EDT
$ rpm -qf /usr/local/Brother/Printer/mfc465cn/inf
file /usr/local/Brother/Printer/mfc465cn/inf is not owned by any package
$
Comment 5 Tim Waugh 2008-10-20 09:38:02 EDT
This looks like it has the same cause as bug #247225.

*** This bug has been marked as a duplicate of bug 247225 ***
Comment 6 Daniel Walsh 2008-10-20 10:53:48 EDT
restorecon -r -v /usr/local/Brother 

will fix.  

The problem here is these files are created without the proper context because they are not in the rpm payload, but created in the postinstall.

If Brother included /usr/local/Brother/Printer/mfc465cn/inf in their rpm this would not happen.

Note You need to log in before you can comment on or make changes to this bug.