Bug 466146 - Konsole always invoked with home directory
Konsole always invoked with home directory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: krusader (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 13:42 EDT by Lukas Tvrdy
Modified: 2009-07-14 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:11:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 154710 None None None Never

  None (edit)
Description Lukas Tvrdy 2008-10-08 13:42:31 EDT
Description of problem:
Krusader 1.90.0 in Fedora 9/KDE4 has function to run Konsole using default keybind F2. When you invoke Konsole, it opens always in ~ directory.

Version-Release number of selected component (if applicable):
Krusader 1.90.0
KDE4.1.1

How reproducible:


Steps to Reproduce:
1.Navigate yourself in other directory e.g. ~/Documents
2.Press F2 to invoke konsole
3.pwd should give the directory where you navigate yourself within krusader
  
Actual results:
Konsole always in home directory

Expected results:
Konsole in directory you navigate yourself 

Additional info:
This probably needs patching..
Comment 1 Steven M. Parrish 2008-10-09 19:02:40 EDT
Found this matching report upstream. https://bugs.kde.org/show_bug.cgi?id=154710  If you dont think this matches what you are describing please open a new upstream report and include that info in this report.
Comment 2 Kevin Kofler 2008-10-10 00:54:37 EDT
This would suggest that Konsole is to blame, not Krusader. In some way this makes sense. I wonder if the change was deliberate or if it's just a bug. Unfortunately, the Konsole maintainer did not reply to the upstream bug. :-(

Krusader could certainly be patched to make it work though.
Comment 3 Kevin Kofler 2008-10-22 15:13:04 EDT
This is the patch which went into the KDE 4 version, it can probably be backported:
http://krusader.svn.sourceforge.net/viewvc/krusader?view=rev&revision=6067
Comment 4 Lukas Tvrdy 2008-10-24 06:01:53 EDT
Here is the upstream "report":
http://www.krusader.org/phpBB/viewtopic.php?t=2159

I installed rawhide version, and it also had this problem 
but I resolved it according the post:

" try "konsole --workdir %d" for the terminal in Konfigurator in the General settings. Settings -> Configure Krusader -> General "

So far I resolved this by using Krusader 2 beta from rawhide and it works for me!
Comment 5 Kevin Kofler 2008-10-24 20:48:22 EDT
But support for the %d escape is added by the above patch, it won't work without backporting that patch.

But there should be a kconf_update script IN ADDITION to that patch to fix the setting automatically. (And upstream should be told that that's what kconf_update is for, saying "you have to manually change your settings" sucks. A kconf_update script can contain arbitrary Perl, it's perfectly possible to check that the setting starts with "konsole" and contains "--workdir ." before changing "--workdir ." to "--workdir %d".)
Comment 6 Lukas Tvrdy 2008-12-28 07:21:15 EST
Works now..So I'm closing it.
Comment 7 Kevin Kofler 2008-12-28 07:27:00 EST
No, it doesn't work in F9, it's fixed only in F10 (Krusader 2). And there's still no kconf_update script to upgrade existing configurations.
Comment 8 Steven M. Parrish 2009-02-06 10:36:57 EST
Do we plan on fixing this in F9.  Seems to no longer be an issue in F10+ so either we fix it in F9 or just wait for F9 to EOL
Comment 9 Kevin Kofler 2009-02-06 10:45:19 EST
It should be fixed in F9!
In addition, if you upgrade to F10, you don't get the fix, you have to reset the setting manually. That's what kconf_update is for! The package is supposed to provide a kconf_update script (and that's something to complain about upstream as well).
Comment 10 Kevin Kofler 2009-02-06 10:46:42 EST
PS: I can look into writing the kconf_update script and the backported patch for F9 if I have some time. But normally it should be upstream's and/or the maintainer's job. :-(
Comment 11 Marcin Garski 2009-02-06 11:25:29 EST
I will write kconf_update script (for F9+), but I'm unable to backport patch as I don't know Qt. So to fix this in F9 I can switch to Krusader 2, someone will backport upstream patch or leave it as it is?
Comment 12 Kevin Kofler 2009-02-06 12:00:27 EST
I can do the backport, should be fairly easy.
Comment 13 Steven M. Parrish 2009-06-07 19:30:47 EDT
Ping?  F9 is approaching EOL.  Has this been corrected if not might I suggest letting it die as F9 goes EOL.

-- 
Steven M. Parrish - KDE Triage Master
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Bug Zapper 2009-06-09 22:54:48 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-07-14 13:11:15 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.