Bug 466150 - hald segfaults on suspend
hald segfaults on suspend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-08 13:53 EDT by Kjartan Maraas
Modified: 2008-10-25 17:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 17:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2008-10-08 13:53:31 EDT
Description of problem:

On my laptop hald segfaults on suspend from rfkill_add() passing a null pointer to strcasecmp()

Program received signal SIGSEGV, Segmentation fault.
0x00372406 in __strcasecmp (s1=0x0, s2=0x8094ce1 "wimax") at strcasecmp.c:65
65	  while ((result = TOLOWER (*p1) - TOLOWER (*p2++)) == 0)
#0  0x00372406 in __strcasecmp (s1=0x0, s2=0x8094ce1 "wimax") at strcasecmp.c:65
#1  0x08072435 in rfkill_add (sysfs_path=0x9b645b4 "/sys/rfkill0", device_file=0x9b649b4 "", parent_dev=0x0, 
    parent_path=0x0) at device.c:3525
#2  0x0807a9ab in hotplug_event_begin_add_dev (subsystem=0x9b644b4 "rfkill", sysfs_path=0x9b645b4 "/sys/rfkill0", 
    device_file=0x9b649b4 "", parent_dev=0x0, parent_path=0x0, end_token=0x9b644a8) at device.c:4506
#3  0x0806d8ba in hotplug_event_begin_sysfs (hotplug_event=0x9b644a8) at hotplug.c:172
#4  0x0806dd07 in hotplug_event_begin () at hotplug.c:295
#5  hotplug_event_process_queue () at hotplug.c:435
#6  0x0806ca30 in hald_udev_data (source=0x9b16d30, condition=G_IO_IN, user_data=0x0) at osspec.c:256
#7  0x0020024d in g_io_unix_dispatch (source=0x9b16600, callback=0x806c080 <hald_udev_data>, user_data=0x0)
    at giounix.c:162
#8  0x001c9218 in g_main_dispatch () at gmain.c:2142
#9  IA__g_main_context_dispatch (context=0x9b0cd48) at gmain.c:2695
#10 0x001cc8c3 in g_main_context_iterate (context=0x9b0cd48, block=1, dispatch=1, self=0x9b0dd20) at gmain.c:2776
#11 0x001ccde2 in IA__g_main_loop_run (loop=0x9b0b750) at gmain.c:2984
#12 0x0805a325 in main (argc=1, argv=0xbf96e824) at hald.c:811
#0  0x00372406 in __strcasecmp (s1=0x0, s2=0x8094ce1 "wimax") at strcasecmp.c:65
	result = <value optimized out>
#1  0x08072435 in rfkill_add (sysfs_path=0x9b645b4 "/sys/rfkill0", device_file=0x9b649b4 "", parent_dev=0x0, 
    parent_path=0x0) at device.c:3525
	d = (HalDevice *) 0x9b17b40
	buf = "\030�\226���\004\b\200ٶ\t�D�\t\000\000\000\000\204\006\n\b���\t]e\t\b\030�\226�\201\221\036\000\b\000\000\000\000\000\000\000\201n\b\b\\B'\000|�\226�\000\000\000"
	type = (const gchar *) 0x0
#2  0x0807a9ab in hotplug_event_begin_add_dev (subsystem=0x9b644b4 "rfkill", sysfs_path=0x9b645b4 "/sys/rfkill0", 
    device_file=0x9b649b4 "", parent_dev=0x0, parent_path=0x0, end_token=0x9b644a8) at device.c:4506
	d = (HalDevice *) 0x807a87b
	__func__ = "hotplug_event_begin_add_dev"
#3  0x0806d8ba in hotplug_event_begin_sysfs (hotplug_event=0x9b644a8) at hotplug.c:172
	parent = (HalDevice *) 0x0
	parent_path = (gchar *) 0x0
	d = (HalDevice *) 0x0
	subsystem = "/sys/rfkill0/subsystem\000/0000:00:1c.1/0000:02:00.0/leds/iwl-phy1:radio/subsystem\000h��\t,\001\000\000�\217F\000\vŶ\t\201�C\000`�C\000�\232C\000\206\232C\000�d�\t@�F\000A\000\000\000sage\000\000\000\000l�F\000l�F\000\000\000\000\000p�F\000H\000\000\000�2�\t�\217F\000\000\000\000\000\213\2146\000�\217F\000\030\020\000\000\030\020\000\000$�\226�-�6\000\000\000\000\000efaults>"...
	subsystem_target = <value optimized out>
	__func__ = "hotplug_event_begin_sysfs"
#4  0x0806dd07 in hotplug_event_begin () at hotplug.c:295
No locals.
#5  hotplug_event_process_queue () at hotplug.c:435
	hotplug_event = (HotplugEvent *) 0x9b644a8
	lp = (GList *) 0x9b1cec0
	lp2 = (GList *) 0x0
	processing = 1
	__func__ = "hotplug_event_process_queue"
#6  0x0806ca30 in hald_udev_data (source=0x9b16d30, condition=G_IO_IN, user_data=0x0) at osspec.c:256
	fd = <value optimized out>
	retval = <value optimized out>
	smsg = {msg_name = 0x0, msg_namelen = 0, msg_iov = 0xbf96d2b8, msg_iovlen = 1, msg_control = 0xbf96e2c0, 
  msg_controllen = 24, msg_flags = 0}
	cmsg = <value optimized out>
	iov = {iov_base = 0xbf96d2c0, iov_len = 4096}
	cred = <value optimized out>
	cred_msg = "\030\000\000\000\001\000\000\000\002\000\000\000QL\000\000\000\000\000\000\000\000\000"
	buf = "change@/rfkill0\000UDEV_LOG=3\000ACTION=change\000DEVPATH=/rfkill0\000SUBSYSTEM=rfkill\000RFKILL_NAME=3945ABG\000RFKILL_TYPE=wlan\000RFKILL_STATE=0\000SEQNUM=1696\000UDEVD_EVENT=1", '\0' <repeats 3943 times>
	bufpos = 153
	action = <value optimized out>
	__func__ = "hald_udev_data"
#7  0x0020024d in g_io_unix_dispatch (source=0x9b16600, callback=0x806c080 <hald_udev_data>, user_data=0x0)
    at giounix.c:162
	buffer_condition = 4625280
#8  0x001c9218 in g_main_dispatch () at gmain.c:2142
No locals.
#9  IA__g_main_context_dispatch (context=0x9b0cd48) at gmain.c:2695
No locals.
#10 0x001cc8c3 in g_main_context_iterate (context=0x9b0cd48, block=1, dispatch=1, self=0x9b0dd20) at gmain.c:2776
	max_priority = 2147483647
	timeout = 678
	some_ready = 1
	nfds = 15
	allocated_nfds = <value optimized out>
	fds = (GPollFD *) 0x9b5e000
	__PRETTY_FUNCTION__ = "g_main_context_iterate"
#11 0x001ccde2 in IA__g_main_loop_run (loop=0x9b0b750) at gmain.c:2984
	self = (GThread *) 0x9b0dd20
	__PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#12 0x0805a325 in main (argc=1, argv=0xbf96e824) at hald.c:811
	loop = (GMainLoop *) 0x9b0b750
	path = <value optimized out>
	newpath = "/sbin:/usr/sbin:/bin:/usr/bin:/usr/libexec:/usr/lib/hal/scripts", '\0' <repeats 34 times>, "H�\022", '\0' <repeats 13 times>, "Ȥ\021\000��0\000Y�\004\b\000\000\000\000\000\000\000\000 \\��\002\000\000\0008\v\022\000t�\004\b�o���\017\023\000X�\226��[��\214�\226�\016�\021\000\000\000\000\000\000\000\000\000X\026\023\000\000\000\000\000\000P���6��L\031\023\000D\026\023\0004�\022\000.N=�q��\a\f\000\000\000$�/\000 �"...
	p_error = (PolKitError *) 0x0
	__func__ = "main"
	long_options = {{name = 0x8088f03 "exit-after-probing", has_arg = 0, flag = 0x0, val = 0}, {
    name = 0x8088f60 "daemon", has_arg = 1, flag = 0x0, val = 0}, {name = 0x8088f16 "verbose", has_arg = 1, 
    flag = 0x0, val = 0}, {name = 0x8088f1e "retain-privileges", has_arg = 0, flag = 0x0, val = 0}, {
    name = 0x8088f30 "use-syslog", has_arg = 0, flag = 0x0, val = 0}, {name = 0x8088ee1 "help", has_arg = 0, 
    flag = 0x0, val = 0}, {name = 0x809596e "version", has_arg = 0, flag = 0x0, val = 0}, {name = 0x0, has_arg = 0, 
    flag = 0x0, val = 0}}
[Current thread is 0 (process 18730)]
The program is running.  Quit anyway (and detach it)? (y or n) LND: Sending signal 11 to process 18730
Detaching from program: /usr/sbin/hald, process 18730



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2008-10-08 16:12:13 EDT
I've patched this upstream, and added a patch into the fedora package. Can you please try the packages here: http://koji.fedoraproject.org/koji/taskinfo?taskID=869136
Comment 2 Kay Sievers 2008-10-09 03:32:36 EDT
Please move that bug to the kernel after the reasonable "paper over the bug" fix in HAL. It is seriously broken to have "DEVPATH=/rfkill0" devices in the kernel.
Comment 3 Kjartan Maraas 2008-10-09 05:04:19 EDT
The hald crash is gone with the new packages but I still seem to have some problems with suspending. Looks like it suspended and popped right back up:

Oct  9 08:40:49 localhost NetworkManager: <info>  Sleeping...
Oct  9 08:40:49 localhost NetworkManager: <info>  (eth0): now unmanaged
Oct  9 08:40:49 localhost NetworkManager: <info>  (eth0): device state change: 2 -> 1
Oct  9 08:40:49 localhost NetworkManager: <info>  (eth0): cleaning up...
Oct  9 08:40:49 localhost NetworkManager: <info>  (eth0): taking down device.
Oct  9 08:40:49 localhost NetworkManager: <info>  (wlan0): now unmanaged
Oct  9 08:40:49 localhost NetworkManager: <info>  (wlan0): device state change: 8 -> 1
Oct  9 08:40:49 localhost NetworkManager: <info>  (wlan0): deactivating device.
Oct  9 08:40:49 localhost kernel: iwl3945 0000:02:00.0: PCI INT A disabled
Oct  9 08:40:49 localhost avahi-daemon[2394]: Interface wlan0.IPv4 no longer relevant for mDNS.
Oct  9 08:40:49 localhost avahi-daemon[2394]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 10.0.0.15.
Oct  9 08:40:49 localhost dnsmasq[2461]: reading /etc/resolv.conf
Oct  9 08:40:49 localhost dnsmasq[2461]: using nameserver 10.0.0.1#53
Oct  9 08:40:49 localhost avahi-daemon[2394]: Withdrawing address record for fe80::219:d2ff:fe37:b62c on wlan0.
Oct  9 08:40:49 localhost avahi-daemon[2394]: Withdrawing address record for 10.0.0.15 on wlan0.
Oct  9 08:40:49 localhost NetworkManager: <info>  wlan0: canceled DHCP transaction, dhcp client pid 7288
Oct  9 08:40:49 localhost NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Oct  9 08:40:49 localhost NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Oct  9 08:40:50 localhost NetworkManager: <info>  (wlan0): cleaning up...
Oct  9 08:40:50 localhost NetworkManager: <WARN>  remove_network_cb(): Couldn't remove network from supplicant interface: The requested network does not exist..
Oct  9 08:40:50 localhost NetworkManager: <WARN>  remove_network_cb(): Couldn't remove network from supplicant interface: The requested network does not exist..
Oct  9 08:40:50 localhost nm-dispatcher.action: Error in get_property: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist#012
Oct  9 08:40:51 localhost ntpd[2305]: Deleting interface #6 wlan0, fe80::219:d2ff:fe37:b62c#123, interface stats: received=0, sent=0, dropped=0, active_time=34586 secs
Oct  9 08:40:51 localhost ntpd[2305]: Deleting interface #7 wlan0, 10.0.0.15#123, interface stats: received=0, sent=0, dropped=0, active_time=34586 secs
Oct  9 08:40:51 localhost acpid: client has disconnected
Oct  9 08:41:02 localhost pulseaudio[6496]: alsa-util.c: Got POLLERR from ALSA
Oct  9 08:41:02 localhost pulseaudio[6496]: alsa-util.c: PCM state is SUSPENDED
Oct  9 08:40:52 localhost kernel: PM: Syncing filesystems ... done.
Oct  9 08:41:02 localhost kernel: Freezing user space processes ... (elapsed 0.00 seconds) done.
Oct  9 08:41:02 localhost kernel: Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
Oct  9 08:41:02 localhost kernel: Suspending console(s) (use no_console_suspend to debug)
Oct  9 08:41:02 localhost kernel: pci 0000:00:02.0: PCI INT A disabled
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Stopping disk
Oct  9 08:41:02 localhost kernel: parport_pc 00:03: disabled
Oct  9 08:41:02 localhost kernel: sdhci-pci 0000:04:06.3: PCI INT C disabled
Oct  9 08:41:02 localhost kernel: tifm_7xx1 0000:04:06.2: PCI INT A disabled
Oct  9 08:41:02 localhost kernel: ahci 0000:00:1f.2: PCI INT B disabled
Oct  9 08:41:02 localhost kernel: ata_piix 0000:00:1f.1: PCI INT A disabled
Oct  9 08:41:02 localhost kernel: ehci_hcd 0000:00:1d.7: PCI INT A disabled
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.3: PCI INT D disabled
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.2: PCI INT C disabled
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.1: PCI INT B disabled
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.0: PCI INT A disabled
Oct  9 08:41:02 localhost kernel: HDA Intel 0000:00:1b.0: PCI INT A disabled
Oct  9 08:41:02 localhost kernel: ACPI: Transitioning device [C11A] to D3
Oct  9 08:41:02 localhost kernel: PM: suspend devices took 1.786 seconds
Oct  9 08:41:02 localhost kernel: ACPI: Preparing to enter system sleep state S3
Oct  9 08:41:02 localhost kernel: Disabling non-boot CPUs ...
Oct  9 08:41:02 localhost kernel: CPU 1 is now offline
Oct  9 08:41:02 localhost kernel: SMP alternatives: switching to UP code
Oct  9 08:41:02 localhost kernel: CPU1 is down
Oct  9 08:41:02 localhost kernel: Extended CMOS year: 2000
Oct  9 08:41:02 localhost kernel: x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
Oct  9 08:41:02 localhost kernel: Intel machine check architecture supported.
Oct  9 08:41:02 localhost kernel: Intel machine check reporting enabled on CPU#0.
Oct  9 08:41:02 localhost kernel: Extended CMOS year: 2000
Oct  9 08:41:02 localhost kernel: Enabling non-boot CPUs ...
Oct  9 08:41:02 localhost kernel: SMP alternatives: switching to SMP code
Oct  9 08:41:02 localhost kernel: Booting processor 1/1 ip 6000
Oct  9 08:41:02 localhost kernel: Initializing CPU#1
Oct  9 08:41:02 localhost kernel: Calibrating delay using timer specific routine.. 4835.60 BogoMIPS (lpj=2417803)
Oct  9 08:41:02 localhost kernel: CPU: L1 I cache: 32K, L1 D cache: 32K
Oct  9 08:41:02 localhost kernel: CPU: L2 cache: 2048K
Oct  9 08:41:02 localhost kernel: CPU: Physical Processor ID: 0
Oct  9 08:41:02 localhost kernel: CPU: Processor Core ID: 1
Oct  9 08:41:02 localhost kernel: Intel machine check architecture supported.
Oct  9 08:41:02 localhost kernel: Intel machine check reporting enabled on CPU#1.
Oct  9 08:41:02 localhost kernel: x86 PAT enabled: cpu 1, old 0x7040600070406, new 0x7010600070106
Oct  9 08:41:02 localhost kernel: CPU1: Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz stepping 06
Oct  9 08:41:02 localhost kernel: CPU1 is up
Oct  9 08:41:02 localhost kernel: ACPI: Waking up from system sleep state S3
Oct  9 08:41:02 localhost kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode
Oct  9 08:41:02 localhost kernel: Clocksource tsc unstable (delta = -500098133 ns)
Oct  9 08:41:02 localhost kernel: HDA Intel 0000:00:1b.0: power state changed by ACPI to D0
Oct  9 08:41:02 localhost kernel: HDA Intel 0000:00:1b.0: power state changed by ACPI to D0
Oct  9 08:41:02 localhost kernel: HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.0: enabling device (0000 -> 0001)
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Oct  9 08:41:02 localhost kernel: usb usb2: root hub lost power or was reset
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.1: enabling device (0000 -> 0001)
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 22 (level, low) -> IRQ 22
Oct  9 08:41:02 localhost kernel: usb usb3: root hub lost power or was reset
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.2: enabling device (0000 -> 0001)
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
Oct  9 08:41:02 localhost kernel: usb usb4: root hub lost power or was reset
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.3: enabling device (0000 -> 0001)
Oct  9 08:41:02 localhost kernel: uhci_hcd 0000:00:1d.3: PCI INT D -> GSI 19 (level, low) -> IRQ 19
Oct  9 08:41:02 localhost kernel: usb usb5: root hub lost power or was reset
Oct  9 08:41:02 localhost kernel: ehci_hcd 0000:00:1d.7: enabling device (0000 -> 0002)
Oct  9 08:41:02 localhost kernel: ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Oct  9 08:41:02 localhost kernel: ata_piix 0000:00:1f.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Oct  9 08:41:02 localhost kernel: ACPI Exception (exoparg2-0444): AE_AML_PACKAGE_LIMIT, Index (000000005) is beyond end of object [20080609]
Oct  9 08:41:02 localhost kernel: ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.C24B] (Node f781a450), AE_AML_PACKAGE_LIMIT
Oct  9 08:41:02 localhost kernel: ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.C002.C0DC.C351._STM] (Node f781d318), AE_AML_PACKAGE_LIMIT
Oct  9 08:41:02 localhost kernel: ata5: ACPI set timing mode failed (status=0x300d)
Oct  9 08:41:02 localhost kernel: ahci 0000:00:1f.2: PCI INT B -> GSI 21 (level, low) -> IRQ 21
Oct  9 08:41:02 localhost kernel: pci 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Oct  9 08:41:02 localhost kernel: ata5.00: ACPI cmd ef/03:0c:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata5.00: ACPI cmd ef/03:22:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: tifm_7xx1 0000:04:06.2: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Oct  9 08:41:02 localhost kernel: ata5.00: configured for MWDMA2
Oct  9 08:41:02 localhost kernel: sdhci-pci 0000:04:06.3: PCI INT C -> GSI 22 (level, low) -> IRQ 22
Oct  9 08:41:02 localhost kernel: parport_pc 00:03: activated
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Starting disk
Oct  9 08:41:02 localhost kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Oct  9 08:41:02 localhost kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata1.00: ACPI cmd b1/c1:00:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata1.00: ACPI cmd b1/c1:00:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
Oct  9 08:41:02 localhost kernel: ata1.00: configured for UDMA/100
Oct  9 08:41:02 localhost kernel: ata1.00: configured for UDMA/100
Oct  9 08:41:02 localhost kernel: ata1: EH complete
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] 156301488 512-byte hardware sectors (80026 MB)
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Write Protect is off
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] 156301488 512-byte hardware sectors (80026 MB)
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Write Protect is off
Oct  9 08:41:02 localhost kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Oct  9 08:41:02 localhost kernel: irq 18: nobody cared (try booting with the "irqpoll" option)
Oct  9 08:41:02 localhost kernel: Pid: 0, comm: swapper Not tainted 2.6.27-0.398.rc9.fc10.i686 #1
Oct  9 08:41:02 localhost kernel: [<c0466a2e>] __report_bad_irq+0x33/0x74
Oct  9 08:41:02 localhost kernel: [<c0466c42>] note_interrupt+0x1d3/0x225
Oct  9 08:41:02 localhost kernel: [<c0466159>] ? handle_IRQ_event+0x61/0x69
Oct  9 08:41:02 localhost kernel: [<c046724a>] handle_fasteoi_irq+0x9e/0xc5
Oct  9 08:41:02 localhost kernel: [<c04671ac>] ? handle_fasteoi_irq+0x0/0xc5
Oct  9 08:41:02 localhost kernel: [<c0406fc1>] do_IRQ+0x9f/0xc9
Oct  9 08:41:02 localhost kernel: [<c0405710>] common_interrupt+0x28/0x30
Oct  9 08:41:02 localhost kernel: [<c0447f3c>] ? tick_nohz_stop_sched_tick+0x2ec/0x2fc
Oct  9 08:41:02 localhost kernel: [<c0403bff>] cpu_idle+0x2c/0x139
Oct  9 08:41:02 localhost kernel: [<c06ca943>] rest_init+0x53/0x55
Oct  9 08:41:02 localhost kernel: =======================
Oct  9 08:41:02 localhost kernel: handlers:
Oct  9 08:41:02 localhost kernel: [<c05e24ba>] (usb_hcd_irq+0x0/0xa8)
Oct  9 08:41:02 localhost kernel: [<f8f4955d>] (tifm_7xx1_isr+0x0/0xdf [tifm_7xx1])
Oct  9 08:41:02 localhost kernel: [<f8f58264>] (yenta_interrupt+0x0/0xc3 [yenta_socket])
Oct  9 08:41:02 localhost kernel: Disabling IRQ #18
Oct  9 08:41:02 localhost kernel: usb 2-1: reset full speed USB device using uhci_hcd and address 2
Oct  9 08:41:02 localhost kernel: usb 3-1: reset full speed USB device using uhci_hcd and address 2
Oct  9 08:41:02 localhost kernel: tifm_sd0:1 : controller failed to reset
Oct  9 08:41:02 localhost kernel: PM: Device tifm_sd0:1 failed to resume: error -19
Oct  9 08:41:02 localhost kernel: pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Oct  9 08:41:02 localhost kernel: PM: resume devices took 3.324 seconds
Oct  9 08:41:02 localhost kernel: Restarting tasks ... <6>tifm0 : demand removing card from socket 0:1
Oct  9 08:41:02 localhost kernel: done.
Comment 4 Matěj Cepl 2008-10-24 15:59:19 EDT
Doesn't happen anymore with hal-0.5.12-7.20081022git.fc10.i386
Comment 5 Matthias Clasen 2008-10-25 17:06:08 EDT
Kjartan said that his problems are gone.

Note You need to log in before you can comment on or make changes to this bug.